Bug 154650 - crash while... well, watching the stars. :)
Summary: crash while... well, watching the stars. :)
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jasem Mutlaq
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-26 23:03 UTC by Frederik Schwarzer
Modified: 2010-04-20 00:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (772 bytes, application/octet-stream)
2007-12-26 23:05 UTC, Frederik Schwarzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Schwarzer 2007-12-26 23:03:18 UTC
Version:           1.2.90 (using KDE Devel)
Installed from:    Compiled sources

I started KStars, chose Bremen, Germany as location and watched. After about an hour (I did other things in between :)) KStars crashed an gave me the backtrace I will append in a few minutes.
I did not change any settings or something. Just the location through the first run wizard.
Comment 1 Frederik Schwarzer 2007-12-26 23:05:33 UTC
Created attachment 22692 [details]
Backtrace

Backtrace of the crash happened at ~22:50, watching from location Germany,
Bremen.
Comment 2 kstars 2007-12-27 02:25:00 UTC
Unfortunately, the backtrace is not very informative.  What was KStars doing for that hour before it crashed?  Were you tracking on an object?  Did you have an accelerated timestep?  Any details you can provide would be helpful.

Can you try running KStars from a konsole?  If you see another crash, it might help to see the console output.
Comment 3 Frederik Schwarzer 2007-12-28 00:53:15 UTC
I was not able to reproduce the crash today.

It crashed three times before though.
I just started it cleanly (first start ever for that user), selected the location and watched unfocussed where the app pointed me to. Nothing special.
I'll have a look later again when I have more time.

Sorry, no more info from my side for now.
Comment 4 Frederik Schwarzer 2007-12-29 10:07:11 UTC
Ok, now I had it crashing again. I had to remove the config first and start "clean".

Console output at startup:
==8<==
kstars(8149) main: Date string:  ""
kstars(8149)/kdecore (K*TimeZone*) KSystemTimeZonesPrivate::instance: instance(): ... initialised
kstars(8149)/kdecore (K*TimeZone*) KSystemTimeZonesPrivate::readConfig: readConfig(): local zone= "Europe/Berlin"
kstars(8149)/kdecore (K*TimeZone*) KSystemTimeZonesPrivate::readZoneTab: readZoneTab( "/usr/share/zoneinfo/zone.tab" )
kstars(8149) SimClock::setUTC: "Sat Dec 29 09:59:47 2007"
kstars(8149) SimClock::setUTC: is dateTime valid?  true
kstars(8149) SimClock::setUTC: "Die Uhrzeit wird gesetzt: UTC: 2007-12-29T09:59:47  JT: 2,454,463.92"
kstars(8149)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::KCoreConfigSkeleton: Creating KCoreConfigSkeleton ( 0x8409a88 )
kstars(8149)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::readConfig: KCoreConfigSkeleton::readConfig()
kstars(8149) KStarsDateTime::fromString: Date string:  ""
kstars(8149) KStarsDateTime::fromString: "Die Zeichenkette für Datum/Zeit kann nicht analysiert werden:" ""
kstars(8149) KStarsDateTime::fromString: "Gültige Datumsformate:"
kstars(8149) KStarsDateTime::fromString:   1950-02-25   ;  1950-02-25T05:30:00
kstars(8149) KStarsDateTime::fromString:   25 Feb 1950  ;  25 Feb 1950 05:30:00
kstars(8149) KStarsDateTime::fromString:   Sat Feb 25 1950  ;  Sat Feb 25 05:30:00 1950
kstars(8149) SimClock::setUTC: "Sat Dec 29 08:59:47 2007"
kstars(8149) SimClock::setUTC: is dateTime valid?  true
kstars(8149) SimClock::setUTC: "Die Uhrzeit wird gesetzt: UTC: 2007-12-29T08:59:47Z  JT: 2,454,463.87"
kstars(8149) KStars::KStars: glibc >= 2.1 detected.  Using GNU extension sincos()
Object::connect: No such slot KToggleAction::slotToggled(false)
Object::connect:  (receiver name: 'clock_startstop')
Object::connect: No such slot KToggleAction::slotToggled(true)
Object::connect:  (receiver name: 'clock_startstop')
kstars(8149)/kdeui (KXmlGui) KXMLGUIFactory::removeClient: KXMLGUIFactory::removeClient(  0x83b82d0  )
kstars(8149)/kdeui (KXmlGui) KXMLGUIFactory::addClient: KXMLGUIFactory::addClient(  0x83b82d0  )
kstars(8149) SimClock::start: "Zeit wird gestartet"
kstars(8149) TimeZoneRule::setDST: "Sommerzeit inaktiv"
kstars(8149) TimeZoneRule::nextDSTChange_LTime: "Nächster Sommerzeitwechsel (Ortszeit): " "2008-03-30T02:00:00Z"
kstars(8149) TimeZoneRule::nextDSTChange: "Nächster Sommerzeitwechsel (UTC): " "2008-03-30T00:59:59.999Z"
kstars(8149)/kdeui (KIconLoader) KIconLoader::loadIcon: No such icon "idea"
kstars(8149)/kdeui (KIconLoader) KIconLoader::loadIcon: No such icon "idea"
kstars(8149) KStars::datainitFinished: The current Date/Time is:  "2007-12-29T10:00:09"
==>8==

Console output at the crash:
==8<==
ASSERT: "ap->bezier || bp->bezier" in file painting/qpathclipper.cpp, line 610
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kstars path = <unknown> pid = 8149
sock_file=/home/fs/.kde4/socket-pino/kdeinit4__0
==>8==

I hope it helps.
Comment 5 kstars 2008-01-03 06:52:35 UTC
I finally was able to get a crash that I think is the same crash condition reported here.  I was even able to induce the crash while running KStars through gdb, so I got a real backtrace.  It indicated that the problem was in drawing solar system bodies, and I traced it further to the computed size of the body's image being NaN.

I don't know yet why the size is going haywire.
Comment 6 kstars 2008-01-17 19:35:43 UTC
SVN commit 762712 by harris:

Potential quick-n-dirty fix for bug #154650.  Assuming the 
crash was caused by the size of planets being NaN, this 
should fix it.  Please test!

Note, I still need to figure out *why* the image size is 
becoming NaN, this just firewalls the code against the 
problem.

CCBUG: 154650
CCMAIL: kstars-devel@kde.org



 M  +6 -0      solarsystemsinglecomponent.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=762712
Comment 7 Alexey Khudiakov 2010-02-08 16:34:29 UTC
SVN commit 1087143 by khudyakov:

Refactor code for drawing of planet images

* Remove unused KSPlanetBase::rotateImage

* Change KSPlanetBase::scaleRotateImage so that it resize to target
  planet diameter not to target image width. They are not the same if
  angle isn't zero. Also

* Remove code which accounts for effect mentioned above. Much nicer this
  way

* Remove firewalling againist accidental NaNs when determining
  image size. At this stage it's better to encounter crash and debug
  it than have non-sensical planet size.

CCMAIL: kstars-devel@kde.org
CCBUG: 154650

 M  +12 -31    skycomponents/solarsystemsinglecomponent.cpp  
 M  +3 -7      skyobjects/ksplanetbase.cpp  
 M  +2 -7      skyobjects/ksplanetbase.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1087143
Comment 8 Frederik Schwarzer 2010-04-20 00:45:29 UTC
Closing since it seems to be fixed.