Bug 15465 - kmail memory consumption with large attachements
Summary: kmail memory consumption with large attachements
Status: RESOLVED DUPLICATE of bug 59069
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2000-11-16 17:33 UTC by naeger
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naeger 2000-11-16 17:24:05 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: 2.0 Final 
Severity: grave
Installed from: SuSE 7.0 rpms on ftp.kde.org

Hi 

kmail eats up almost 100M when trying to display a message that contains a text attachement of about 3.8M.

In addition there is no way to delete (or better save :-) the message without displaying it. So I had to edit the inbox manually (vim) to get kmail working again.

Greetings Chris


(submitted via bugs.kde.org)
Comment 1 Max Moritz Sievers 2000-12-20 19:09:31 UTC
I had the same problem too.
But after I edited the folder in which the message was there are several 
messages in this folder where the header-informations aren't displayed 
normally (when I display one of those messages the header ist shown as if 
it were in the body). The Subject is "No Subject" the Sender is 
"Unknown" and the threading list all those messages in one row. The Date 
of these messages is "Wed Dec 31 23:59:59 1969".

Regards
Max Moritz Sievers
Comment 2 Jan Albrecht 2001-06-21 15:42:34 UTC
Hi

the bug seems to have the bigger effect on Solaris.
I tried to read an e-mail with a size of ~ 150 KB.=20
KMail takes [sizes taken from 'top'] a SIZE of 330 MB. My SWAP file sizes up
in nanoseconds from near 87 to over 400 MB.
KMail doesn't respond then for up to 1 hour.

Maybe this is a different bug but it seemed very close for me.

Greetings

Jan Albrecht

--=20
Jan Albrecht                        Phone:  +49-5241-80-88404
Systemadministrator                 Fax:    +49-5241-80-688404
Bertelsmann mediaSystems NMI-DC     mobile: +49-172-2978914
An der Autobahn
33311 G=FCtersloh                     mailto:jan.albrecht@bertelsmann.de=20
Germany
Comment 3 Jan Albrecht 2001-06-21 15:44:27 UTC
My KMail Version is 2.1 not 1.2 a mentioned in the reported bug.
Sorry for that.

Greetings

Jan Albrecht

--=20
Jan Albrecht                        Phone:  +49-5241-80-88404
Systemadministrator                 Fax:    +49-5241-80-688404
Bertelsmann mediaSystems NMI-DC     mobile: +49-172-2978914
An der Autobahn
33311 G=FCtersloh                     mailto:jan.albrecht@bertelsmann.de=20
Germany


> -----Original Message-----
> From: Albrecht Jan NMI-DC=20
> Sent: Thursday June 21 2001 5:43 PM
> To: '15465@bugs.kde.org'
> Subject: Similar Problem on Solaris
>=20
>=20
> Hi
>=20
> the bug seems to have the bigger effect on Solaris.
> I tried to read an e-mail with a size of ~ 150 KB.=20
> KMail takes [sizes taken from 'top'] a SIZE of 330 MB. My=20
> SWAP file sizes up in nanoseconds from near 87 to over 400 MB.
> KMail doesn't respond then for up to 1 hour.
>=20
> Maybe this is a different bug but it seemed very close for me.
>=20
> Greetings
>=20
> Jan Albrecht
>=20
> --=20
> Jan Albrecht                        Phone:  +49-5241-80-88404
> Systemadministrator                 Fax:    +49-5241-80-688404
> Bertelsmann mediaSystems NMI-DC     mobile: +49-172-2978914
> An der Autobahn
> 33311 G=FCtersloh=20=20=20=20=20=20=20=20=20=20=20=20=20=20=20=20=20=20=
=20=20=20
> mailto:jan.albrecht@bertelsmann.de=20
> Germany
>=20
Comment 4 Don Sanders 2001-06-21 16:02:33 UTC
How well does Konqueror display long html pages (like
http://bugs.kde.org/db/ix/summary.html)?

Don.

On Thursday 21 June 2001 17:42 Jan.Albrecht@bertelsmann.de 
wrote:
> Hi
>
> the bug seems to have the bigger effect on Solaris.
> I tried to read an e-mail with a size of ~ 150 KB.
> KMail takes [sizes taken from 'top'] a SIZE of 330 MB. My
> SWAP file sizes up in nanoseconds from near 87 to over
> 400 MB.
> KMail doesn't respond then for up to 1 hour.
>
> Maybe this is a different bug but it seemed very close
> for me.
>
> Greetings
>
> Jan Albrecht
Comment 5 Ingo Klöcker 2004-01-15 20:50:44 UTC

*** This bug has been marked as a duplicate of 59069 ***