Bug 154306 - Krita can't open native document created in 1.6
Summary: Krita can't open native document created in 1.6
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Halla Rempt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-19 11:09 UTC by Thomas Zander
Modified: 2007-12-19 12:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Zander 2007-12-19 11:09:31 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

I created my christmas card in Krita1.x and for fun tried to open it in krita 2.0, I noted that the resolution was off and the graphics were not showing up.
The layer structure was in order though :)

I bet you can reproduce this with most freshly created docs, but if needed I can send the file personally (its 8Mb).
Comment 1 Halla Rempt 2007-12-19 11:15:53 UTC
Yeah, we need to fix that. Casper was going to do that, but he got sidetracked by Oxygen. It's on my todo now.
Comment 2 Halla Rempt 2007-12-19 12:29:54 UTC
Ok, I fixed the resolution bug, but that's not the problem here. We set the image name in the aboutinfo, but later the aboutinfo block is loaded, and since our old images have an empty documentinfo.xml file the image name is reset, which then is empty, which means we cannot find the layer data.
Comment 3 Halla Rempt 2007-12-19 12:36:37 UTC
SVN commit 750476 by rempt:

Fix loading of .kra images (the imagename was set in the info block and then
reset when an empty info block was loaded later on)
BUG:154306


 M  +15 -7     kis_doc2.cc  
 M  +5 -1      kis_load_visitor.cc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=750476