Bug 154108 - Filenames under icons not easily readable
Summary: Filenames under icons not easily readable
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-15 15:03 UTC by Hans Bakker
Modified: 2007-12-23 16:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Plasma::icon text shadows (1.57 KB, patch)
2007-12-15 17:28 UTC, Marco Martin
Details
text shadow, second attempt (2.36 KB, patch)
2007-12-16 22:08 UTC, Marco Martin
Details
text background attempt (35.06 KB, image/png)
2007-12-16 22:13 UTC, Marco Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Bakker 2007-12-15 15:03:42 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When a file is displayed as an Icon plasmoid on the desktop, the filenames under the icons on the desktop are displayed on the transparent area of the Icon plasmoid. This makes it very hard to read depending on the colour of the background. Maybe there could be some less-transparent area behind the filename? Or some border around the text?
Comment 1 Marco Martin 2007-12-15 17:28:53 UTC
Created attachment 22562 [details]
Plasma::icon text shadows

i would make a drop shadow to the icon text, this patch does it in a very basic
way, maybe would be prettier if the shadow is blurred?
Comment 2 Beat Wolf 2007-12-15 17:31:56 UTC
i think the text color should be configurable in the same way it is in kde3, and yes, shadow should be possible too :-)
Comment 3 Marco Martin 2007-12-15 17:39:36 UTC
yes, at the moment since there is no desktop icon color in the standard palette in this patch i used the text highlight color, but it would be nice if it could be configured (unfortunately not in the color config dialog but somewhere else)
but it would not be enough since a wallpaper could have very different colors in different areas and if a slideshow it's used (i love that feature:P) the text color should change for every wallpaper in the slideshow :)
Comment 4 Beat Wolf 2007-12-15 17:55:49 UTC
My opinion is that you should be able to configure the color of the text, and the shadow option, in the same dialog (but in a different tab) where you configure the desktop wallpaper. that would be the first place where i would search that option
Comment 5 Christopher Blauvelt 2007-12-15 20:37:34 UTC
I agree.  I'll try putting in a drop-shadow and see how that works.
Chris

On 15 Dec 2007 14:03:43 -0000, Hans Bakker <hansmbakker@gmail.com> wrote:

[bugs.kde.org quoted mail]
<div>I agree.&nbsp; I&#39;ll try putting in a drop-shadow and see how that works.</div>
<div>Chris<br><br></div>
<div class="gmail_quote">On 15 Dec 2007 14:03:43 -0000, Hans Bakker &lt;<a href="mailto:hansmbakker@gmail.com">hansmbakker@gmail.com</a>&gt; wrote:<br>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">------- You are receiving this mail because: -------<br>You are the assignee for the bug, or are watching the assignee.
<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=154108" target="_blank">http://bugs.kde.org/show_bug.cgi?id=154108</a><br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Summary: Filenames under icons not easily readable<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Product: plasma<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Version: unspecified
<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Platform: Compiled Sources<br>&nbsp; &nbsp; &nbsp; &nbsp;OS/Version: Linux<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Status: UNCONFIRMED<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Severity: wishlist<br>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Priority: NOR<br>&nbsp; &nbsp; &nbsp; &nbsp; Component: general<br>&nbsp; &nbsp; &nbsp; &nbsp;AssignedTo: panel-devel kde org
<br>&nbsp; &nbsp; &nbsp; &nbsp;ReportedBy: hansmbakker gmail com<br><br><br>Version: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;(using KDE Devel)<br>Installed from: &nbsp; &nbsp;Compiled sources<br>OS: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Linux<br><br>When a file is displayed as an Icon plasmoid on the desktop, the filenames under the icons on the desktop are displayed on the transparent area of the Icon plasmoid. This makes it very hard to read depending on the colour of the background. Maybe there could be some less-transparent area behind the filename? Or some border around the text?
<br>_______________________________________________<br>Panel-devel mailing list<br><a href="mailto:Panel-devel@kde.org">Panel-devel@kde.org</a><br><a href="https://mail.kde.org/mailman/listinfo/panel-devel" target="_blank">
https://mail.kde.org/mailman/listinfo/panel-devel</a><br></blockquote></div><br>
Comment 6 Marco Martin 2007-12-16 14:01:37 UTC
can i commit?
maybe the result it's still not the prettiest thing in the world but i think it's far more accessible than now
Comment 7 Aaron J. Seigo 2007-12-16 19:45:44 UTC
this is incorrect: option->palette.color(QPalette::HighlightedText), at least until we change it so that the palette that gets passed around with the paint options is one derived from Plasma::Theme ... this really should be gathered from the KColorScheme that comes with the Theme.

in any case, i think a simpler approach might be to simply provide a rounded "lozenge" of colour behind the text using a known-to-contrast-well colour (the palette can give us that colour). unless we get a performant, good looking text halo algo in, i'd rather go for that. we had something that was OK looking in kde3 but was horrifically slow.

btw, the odds are high that a feature request will end up being using different colours for the background for different icons (making it easier to visually tell them apart).
Comment 8 Marco Martin 2007-12-16 22:08:07 UTC
Created attachment 22582 [details]
text shadow, second attempt

What about this? it uses foreground and background color of the theme
Comment 9 Marco Martin 2007-12-16 22:13:19 UTC
Created attachment 22583 [details]
text background attempt

tried with a very quick and dirty hack to put a background behind the text
icon, this is how it appears, not totally convinced...
Comment 10 Marco Martin 2007-12-18 22:35:44 UTC
how is the last patch? less wrong and committable? or should i try to go with the background rectangle? i don't like the latter very much because the icon looks always selected...
Comment 11 Marco Martin 2007-12-23 16:14:01 UTC
SVN commit 752098 by mart:

White icon text on a semitransparent black background

BUG: 154108

 M  +2 -2      libs/plasma/widgets/icon.cpp  
 M  +25 -52    plasma/desktoptheme/widgets/iconbutton.svg  


WebSVN link: http://websvn.kde.org/?view=rev&revision=752098