Bug 154095 - "Could not connect to host Proxy at port -1" message is displayed when proxy is not defined for HTTPS
Summary: "Could not connect to host Proxy at port -1" message is displayed when proxy...
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: http (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-15 13:08 UTC by Ilia K.
Modified: 2009-08-15 20:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia K. 2007-12-15 13:08:32 UTC
Version:           3.97.00 (KDE 4.0 RC2) (using KDE 3.97.00 (KDE 4.0 RC2), Kubuntu packages)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.22-14-generic

Steps to reproduce:
1. Choose "Settings->Configure Konqueror" menu
2. Choose proxy configuration ("Web Browsing->Proxy"), "Proxy" tab
3. Check "Manually specify the proxy settings" and press "Setup..." button
4. Fill some proxy ONLY for HTTP protocol. Leave HTTPS/FTP fields blank. Ensure, that "Use the same proxy server for all protocols" option is turned off.
5. Apply the settings
6. Type some HTTPS address in an address bar, e.g. https://mail.google.com
7. Observe the error message instead of a page. For example:

An error occurred while loading https://mail.google.com:
Could not connect to host Proxy  at port -1.
Comment 1 solsTiCe 2008-07-28 14:31:26 UTC
i can confirm this with kde 4.1 ( on i686) (arch linux package)

4.1 was supposed to be THE release ? too much bugs to fix to fix this one?
i become more and more dissatisfatied with kde that i always liked
Comment 2 solsTiCe 2008-07-30 10:57:39 UTC
the problem is the same with ftp:// as soon as some http proxy is defined. 
Comment 3 Artem S. Tashkinov 2009-05-05 15:29:38 UTC
*** Bug 188290 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Hartmetz 2009-08-15 20:34:43 UTC
I think this has been fixed in trunk a while ago. Please reopen if still present. Also note that HTTPS over proxy is -currently- broken. HTTPS works however when a HTTP proxy is defined but not HTTPS proxy, which is what this bug is about.