Bug 153970 - crash after releasing a resize.
Summary: crash after releasing a resize.
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 152897 155064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-13 15:45 UTC by Thomas Zander
Modified: 2008-01-17 16:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Zander 2007-12-13 15:45:24 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

With yesterdays svn I resized (using meta) a window and when I released it kwin crashed.

Note that I have the plugin enabled that shows resizing-windows as transparent.
Note also that I have a xinerama setup.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47101903131440 (LWP 9509)]
[KCrash handler]
#5  0x00002ad6c1e9e765 in raise () from /lib/libc.so.6
#6  0x00002ad6c1ea01c0 in abort () from /lib/libc.so.6
#7  0x00002ad6be445868 in qt_message_output (msgType=QtFatalMsg, 
    buf=0x7fffee81c970 "ASSERT: \"!( vertical && horizontal ) || ((( max_mode & MaximizeVertical ) != 0 ) == (( max_mode & MaximizeHorizontal ) != 0 ))\" in file /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp, line "...)
    at /home/zander/work/kde/qt43/src/corelib/global/qglobal.cpp:2137
#8  0x00002ad6be445989 in qFatal (
    msg=0x2ad6be534170 "ASSERT: \"%s\" in file %s, line %d")
    at /home/zander/work/kde/qt43/src/corelib/global/qglobal.cpp:2369
#9  0x00002ad6be445add in qt_assert (
    assertion=0x2ad6bc553470 "!( vertical && horizontal ) || ((( max_mode & MaximizeVertical ) != 0 ) == (( max_mode & MaximizeHorizontal ) != 0 ))", 
    file=0x2ad6bc5531b0 "/home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp", line=1916)
    at /home/zander/work/kde/qt43/src/corelib/global/qglobal.cpp:1894
#10 0x00002ad6bc51ec81 in KWin::Client::changeMaximize (this=0x11cf8e0, 
    vertical=true, horizontal=true, adjust=false)
    at /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp:1915
#11 0x00002ad6bc51f9af in KWin::Client::setMaximize (this=0x11cf8e0, 
    vertically=false, horizontally=true)
    at /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp:1890
#12 0x00002ad6bc51f9f7 in KWin::Client::maximize (this=0x11cf8e0, 
    m=KDecorationDefines::MaximizeHorizontal)
    at /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp:1879
#13 0x00002ad6bc51fc62 in KWin::Client::checkMaximizeGeometry (this=0x11cf8e0)
    at /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp:2105
#14 0x00002ad6bc51fd70 in KWin::Client::finishMoveResize (this=0x11cf8e0, 
    cancel=false)
    at /home/zander/work/kde/kdebase/workspace/kwin/geometry.cpp:2370
#15 0x00002ad6bc4f6827 in KWin::Client::buttonReleaseEvent (this=0x11cf8e0, 
    w=19133064, state=1104, x=0, y=0, x_root=1503, y_root=841)
    at /home/zander/work/kde/kdebase/workspace/kwin/events.cpp:1363
#16 0x00002ad6bc4f8fa0 in KWin::Client::windowEvent (this=0x11cf8e0, 
    e=0x7fffee81f6e0)
    at /home/zander/work/kde/kdebase/workspace/kwin/events.cpp:655
#17 0x00002ad6bc4f98f9 in KWin::Workspace::workspaceEvent (this=0x7481d0, 
    e=0x7fffee81f6e0)
    at /home/zander/work/kde/kdebase/workspace/kwin/events.cpp:317
#18 0x00002ad6bc4ea019 in KWin::Application::x11EventFilter (
    this=0x7fffee81fae0, e=0x7fffee81f6e0)
    at /home/zander/work/kde/kdebase/workspace/kwin/main.cpp:278
#19 0x00002ad6bf7690fc in qt_x11EventFilter (ev=0x7fffee81f6e0)
    at /home/zander/work/kde/qt43/src/gui/kernel/qapplication_x11.cpp:318
#20 0x00002ad6bf7730c0 in QApplication::x11ProcessEvent (this=0x7fffee81fae0, 
    event=0x7fffee81f6e0)
    at /home/zander/work/kde/qt43/src/gui/kernel/qapplication_x11.cpp:2770
#21 0x00002ad6bf7a03b5 in x11EventSourceDispatch (s=0x61f8d0, callback=0, 
    user_data=0x0)
    at /home/zander/work/kde/qt43/src/gui/kernel/qguieventdispatcher_glib.cpp:112
#22 0x00002ad6c30edfd3 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#23 0x00002ad6c30f12dd in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00002ad6c30f180e in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#25 0x00002ad6be524856 in QEventDispatcherGlib::processEvents (this=0x61bf50, 
    flags=@0x7fffee81f940)
    at /home/zander/work/kde/qt43/src/corelib/kernel/qeventdispatcher_glib.cpp:315
#26 0x00002ad6bf79fc23 in QGuiEventDispatcherGlib::processEvents (
    this=0x61bf50, flags=@0x7fffee81f990)
    at /home/zander/work/kde/qt43/src/gui/kernel/qguieventdispatcher_glib.cpp:168
#27 0x00002ad6be4fa455 in QEventLoop::processEvents (this=0x7fffee81fa40, 
    flags=@0x7fffee81fa00)
    at /home/zander/work/kde/qt43/src/corelib/kernel/qeventloop.cpp:117
#28 0x00002ad6be4fa5aa in QEventLoop::exec (this=0x7fffee81fa40, 
    flags=@0x7fffee81fa60)
    at /home/zander/work/kde/qt43/src/corelib/kernel/qeventloop.cpp:159
#29 0x00002ad6be4fd920 in QCoreApplication::exec ()
    at /home/zander/work/kde/qt43/src/corelib/kernel/qcoreapplication.cpp:736
#30 0x00002ad6bf70ff78 in QApplication::exec ()
    at /home/zander/work/kde/qt43/src/gui/kernel/qapplication.cpp:3030
#31 0x00002ad6bc4eb664 in kdemain (argc=1, argv=0x7fffee81ffa8)
    at /home/zander/work/kde/kdebase/workspace/kwin/main.cpp:425
#32 0x00000000004008d3 in main (argc=1, argv=0x7fffee81ffa8)
    at /home/zander/work/kde/current/kdebase/workspace/kwin/kwin_dummy.cpp:3
#0  0x00002ad6c1f072b0 in nanosleep () from /lib/libc.so.6
Comment 1 Lubos Lunak 2007-12-17 18:58:20 UTC
*** Bug 152897 has been marked as a duplicate of this bug. ***
Comment 2 Lubos Lunak 2008-01-04 18:10:25 UTC
*** Bug 155064 has been marked as a duplicate of this bug. ***
Comment 3 Lubos Lunak 2008-01-17 16:44:39 UTC
SVN commit 762644 by lunakl:

Handle correctly the case when maximization changes in both direction
in opposite ways.
BUG: 153970



 M  +8 -3      geometry.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=762644