Bug 153745 - konqueror corrupts some webpages
Summary: konqueror corrupts some webpages
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 160560 169856 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-09 21:13 UTC by Patrizio Bassi
Modified: 2011-08-08 00:34 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
revision792695 (12.18 KB, patch)
2008-08-27 15:34 UTC, Andrea Iacovitti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrizio Bassi 2007-12-09 21:13:07 UTC
Version:           3.5.7 and 3.5.8 (using KDE KDE 3.5.8)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1 / 4.2 
OS:                Linux

problem introduced with 3.5.7

when i surf in a couple of website (http://www.f1grandprix.it/ or http://www.motograndprix.it/)
konqueror destroys all links, while rendering is ok.

attached a video for corruption:
http://www.patriziobassi.it/downloads/konq-corruption.ogg

kde-base/konqueror-3.5.8 corrupts some webpages

Firefox and other browsers work ok there.
Comment 1 Patrizio Bassi 2007-12-09 21:37:42 UTC
my website is sometimes down, so i put here http://it.youtube.com/watch?v=OJ93B1p2xFI
Comment 2 Tommi Tervo 2007-12-10 08:48:13 UTC
Confirmed with KDE4 too (3.96.3). Whole page disappears.
Comment 3 Rolf Eike Beer 2007-12-11 11:27:36 UTC
It works if you disable Javascript.
Comment 4 Allan Sandfeld 2007-12-11 14:43:54 UTC
Confirmed, but the page has some nasty compressed JS.
Comment 5 Patrizio Bassi 2007-12-11 20:29:20 UTC
you're right putting javascript in blacklist works.

but it's not normal behaviour, IE and firefox do not do this...
Comment 6 Patrizio Bassi 2007-12-16 17:01:03 UTC
shouldn't this get Higher attention for 4.0 release?
Comment 7 Tommi Tervo 2008-04-08 15:32:59 UTC
*** Bug 160560 has been marked as a duplicate of this bug. ***
Comment 8 FiNeX 2008-04-21 13:42:55 UTC
Bug confirmed on 3.5.8.
Fixed on konqueror 4 (tested in trunk r797319)
Comment 9 James Spahlinger 2008-04-22 22:36:09 UTC
Ok, strange results here. Both 4.0.3 and 3.5.9 exhibit similar behavior. 

Loading either example given in comment #0 the page loads then when its almost done loading reverts to a blank page. I'm defining blank page as a white background with no content or images in it. However the url address is that of the site, and the status bar states that the page has loaded successfully. 

Talking in IRC, krop notes that the page has an auto reload, could this be part of the problem?

This may be fixed in trunk, I can't test, but this is acting oddly for 4.0.3 and 3.5.9, though my odd behavior is not what is reported in the original bug report. Please note that I do not have flash installed on either browser, and both were compiled from source using GCC 4.3.0. (Gentoo linux).
Comment 10 FiNeX 2008-04-22 23:10:19 UTC
I've just tried with revision 799878 (compiled 2 hours ago). The page become blank for some seconds while loading (about 90% of loading), after the page is all correctly rendered.
Comment 11 Andrea Iacovitti 2008-04-23 10:09:46 UTC
Did you mean this revision: http://websvn.kde.org/?view=rev&revision=799878 ?
It seams unrelated to that bug.
I would like to try the patch, where can i catch it?

Comment 12 Björn Tjorven Herzig 2008-04-23 14:03:49 UTC
I have a similar problem when i browse wiki.kubuntu-de.org. Konqueror leaves some pages blank until i reload them.
Comment 13 Björn Tjorven Herzig 2008-04-23 14:06:50 UTC
Forgot to mention: I use KDE 4.0.3 (Kubuntu Hardy packages)
Comment 14 Andrea Iacovitti 2008-05-09 10:50:23 UTC
I have same problem with www.lemonde.fr but in a different way: konqueror destroys all links in the page on mouse over but only while the page is not completely loaded (sometimes my connection is slow). After the whole page is loaded it's well rendered.
Hope will help. 
Comment 15 Andrea Iacovitti 2008-05-14 08:56:42 UTC
Additional tests (kde 3.5.9 on Debian):

-open a tabbed enabled konqueror
-go to www.cellularmagazine.it and wait the page is loaded
-right-click on the tab page and choose "Duplicate Tab"
:
You have the bug only on the first tab, moreover on the second tab you see the top horizontal menu (celestial background) not display on the first page.
(additional: "View Document information" works only on the first tab, normal behavior?)
Comment 16 FiNeX 2008-05-14 11:39:58 UTC
I confirm the comment #15 using konqueror 3.5.9.
Instead konqueror 4 (trunk, r806921) doesn't destroy links.
Comment 17 Andrea Iacovitti 2008-06-12 17:51:49 UTC
Saving a local copy of page www.cellularmagazine.it (with firefox) and opening this one with konqueror the page is rendered quite well.
Only the on line page is bad rendered.
This confirmed by the fact that reloading the "Duplicate Tab" mentioned in the comment #15 also presents the same problem.
Comment 18 Andrea Iacovitti 2008-08-27 15:34:52 UTC
Created attachment 27085 [details]
revision792695
Comment 19 Andrea Iacovitti 2008-08-27 15:36:41 UTC
Resolved on kde 3.5.9/3.5.10 applying revision #792695 (http://websvn.kde.org/?view=rev&revision=792695) that "rework the tracking of stylesheets' loaded state.". I attach the patch modified to be suitable for kde 3.5.9/10.
Comment 20 Rui G. 2008-08-27 21:51:32 UTC
*** Bug 169856 has been marked as a duplicate of this bug. ***
Comment 21 Rui G. 2008-08-27 21:54:37 UTC
I also can't reproduce this bug in kde 4.1 , seems fixed.
Comment 22 Rui G. 2008-08-28 12:40:47 UTC
I guess I wasn't very thorough, I can replicate the bug in Opensuse 11.0 kde 4.1.1 under very specific circumstances. 

In the following www.ask.com (after searching for something) and www.f1grandprix.it , if I clear cache and disable it, and don't do any mouse events like mouse scroll or clicks, sometimes the links disappear .
Although, if after they are gone I scroll with mouse, they magically reappear. 
Comment 23 Andrea Iacovitti 2008-08-29 11:55:44 UTC
Probably is usefull to note that sites we have this bug all make use of frame or iframe.
Comment 24 Andrea Iacovitti 2011-08-08 00:34:13 UTC
Cannot reproduce with recent KDE (>= 4.6.5)
Closing