Bug 153599 - Konqueror consumes 100% CPU when your history has many entries for a particular site and your enter it in a address bar
Summary: Konqueror consumes 100% CPU when your history has many entries for a particul...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.3.0
Platform: Fedora RPMs Linux
: NOR normal with 22 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-07 06:30 UTC by Artem S. Tashkinov
Modified: 2020-06-06 12:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem S. Tashkinov 2007-12-07 06:30:17 UTC
Version:           3.5.8 (using KDE KDE 3.5.8)
Installed from:    Fedora RPMs
Compiler:          GCC 4.1.2 Fedora 8 
OS:                Linux

Imagine you are a heavy user of a particular web site like www.site.com/myforum. Imagine that you visit some 100-200 pages from it on a daily basis. After a week of using this site when entering the first chars of this site like www.si... into the address bar Konqueror will slow down as hell consuming 100% of CPU. It will then show the right visited past history entries from this site but it will take up to 10-20 seconds to complete - at that time Konqueror window is almost unresponsive and you cannot do anything.

This bug is always reproducible.
Comment 1 Jonas Vejlin 2009-06-18 22:07:30 UTC
Do you still have the problem in konq 4.2?
Comment 2 Artem S. Tashkinov 2009-06-19 06:17:23 UTC
I no longer can reproduce it.
Comment 3 squan 2009-06-21 08:27:57 UTC
At comment #2:
In the latest KDE-4.3 betas konqueror history offers only a rudiment of functionality compared with KDE-3 (see bug 92818 comment #4 or bug 193966 ).
Especially the number of entries is no longer configurable and limited to 500 entries (see bug 181763).
With just 500 entries to be searched it is no wonder, that you can't reproduce this bug.
It may be reasonable to only search about 500 latest entries. But I suspect that this restriction is implemented directly but just a side effect of the broken history and that as soon as konqueror history is repaired, this bug will show up again.
Comment 4 Artem S. Tashkinov 2009-07-31 05:54:15 UTC
(In reply to comment #3)
> At comment #2:
> With just 500 entries to be searched it is no wonder, that you can't
> reproduce this bug.

You aren't quite right, I have my history configured for 50 thousands maximum number of URLs and its expiration is set to 180 days.

However I'm not sure that Konqueror really stores that 50 thousands entries (probably there's an upper hidden limit to that number).
Comment 5 Artem S. Tashkinov 2009-08-18 08:57:54 UTC
I have to reopen this bug since in KDE 4.3 when I start entering any address Konqueror takes up to 3 seconds before it finds older history entries and becomes usable so that I could complete entering the URL.

I can attach a video showing this problem.
Comment 6 Andrew Crouthamel 2018-11-06 15:17:24 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrew Crouthamel 2018-11-18 03:27:54 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Artem S. Tashkinov 2020-06-06 12:00:52 UTC
Konqueror seems to be abandoned, no new releases since 2016.