Bug 152375 - dot.kde.org ain't kde4 ready -- overhaul needed!
Summary: dot.kde.org ain't kde4 ready -- overhaul needed!
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Websites
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 60 votes (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-15 18:22 UTC by Bartemius Crouch
Modified: 2010-05-27 10:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartemius Crouch 2007-11-15 18:22:13 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

dot.kde.org has a KDE 2.0 look with this old Gear as a favicon etc.
There should be a design overhaul for the kde 4.0 release, as there will be thousands of newbie-visitors and the current states makes a very poor impression. 

Also the comment-system is unflexible and annoying. 

It might be smart to consider an existing blog plattform, as dot.kde.org doesn't do anything else (news + comments and some rdf-links on the right). Also Slashcode might be an option. 

The Copyright disclamer on the bottom of dot.kde.org hasn't been updated and still  says: The rest: Copyright © 2000-2006 KDE e.V. for The KDE Project. 

Even if it's not possible to migrate to a complete new news-plattform in time, the favicon and the few images used including colors should be replaced by the oxygen team. That shouldn't be to much work. A .css contest could be annouced and integrated without any problems.
Comment 1 Sebastian Kügler 2007-11-20 16:16:46 UTC
Thanks for your feedback.

Unless you step up to do this, I won't hold my breath that this happens before 4.0 is out. The Oxygen team is working on the desktop itself right now. Webpages are currently not a showstopper.
Comment 2 Milian Wolff 2007-11-20 23:20:32 UTC
I have experience with webdevelopment and would like to get involved with KDE - this would be a place I could start I think. Who shall I ask to get more information?

And converting to something like Drupal or similar would mean that all old articles and comments have to be migrated. I could write a script for that.

Of course I'd also fix bugs, update templates and remove quirks in the comment system.

Please, get in tough with me!
Comment 3 Yitzchak Schwarz 2007-11-21 08:27:00 UTC
I might be able to put something into this, depending on what skills are required.
Comment 4 Andre Gemünd 2007-11-21 09:51:33 UTC
It would be really nice to have a Drupal codebase and a common (or at least similar) theme / look for all kde pages. I think planet.kde.org doesn't look to fresh neither. But they work, and it would be some work to setup apache/php/drupal correctly (proxy, bytecode cache, drupal cache etc.). I really doubt it could be ready by the release of KDE4.
I guess the hardest part is the Design part though. If you're going to tackle it and got anyone for the design, contact me at gmail (same accountname) and i would be glad to help out with module programming or some CCK/Views stuff.
Comment 5 navindra 2007-11-22 00:50:33 UTC
Just send me the new icons and I'll update it.
Comment 6 Emil Sedgh 2007-11-23 10:40:19 UTC
I wanted to change the look of the dot.i get the zope and squishdot.im trying to look how their look could be changed and i will try to create a kde'sh theme for it but really, there is no reason to use Squishdot and Zope at there.really they have no special feature.
I think we have two possible options:

1)continue using Squishdot: maybe someone at least will succeed to make it look better, but its hard to do.Zope stuff is too much complicated...
2)Migrate to another thing, maybe Drupal? I think this is our very best option...
Comment 7 Mark Ziegler 2007-11-24 14:12:16 UTC
If there would be a migration please don't forget to convert all the articles.
The history of dot.kde.org is very useful.
I don't know any details about zope and it's cms, but I am waiting for some work now for years. I am the webmaster of kde.de and we often translate news artices to german. But I hate to grep the website for articles. I want to get the articles in an XML-Format. With Drupal I am sure to get this done, cause I can code php a little.
Navindra seems busy all the time.
I agree with Bartemius. The page layout looks a little outdated compared to kde.org and other pages using CI.
Comment 8 Mark Ziegler 2007-11-24 14:13:41 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 navindra 2007-11-28 02:21:13 UTC
The XML thing is really not hard to do.  True, I haven't done it myself yet but it's not hard at all theory... just do it the same way the RDF code does it currently.  

I'm going on vacation from work in a couple of weeks, so with some luck I could look at this in December if you guys still refuse to work with Squishdot.  Squishdot is not hard, here is what the RDF code looks like.  It's not rocket science... if you are able to understand the messy PHP stuff, you should be able to grok this too!

 <!DOCTYPE rss PUBLIC "-//Netscape Communications//DTD RSS 0.91//EN"
             "http://static.kdenews.org/mirrors/my.netscape.com/publish/formats/rss-0.91.dtd" >
  <rss version="0.91">
    <channel>
        <title><dtml-var "striptags(rss_title)" html_quote></title>
        <language>en</language>
        <link><dtml-var rss_site_url>/</link>
        <description><dtml-var "striptags(rss_description)"></description>
<dtml-if rss_image_url>
        <image>
           <title><dtml-var "striptags(rss_title)" html_quote></title>
           <url><dtml-var imageserver_url>/<dtml-var rss_image_url></url>
           <link><dtml-var rss_site_url>/</link>
           </image>
</dtml-if>
<dtml-if item_list>
<dtml-in "item_list[:10]">
        <item>
           <title><dtml-var "striptags(title)" html_quote></title>
           <link><dtml-var rss_site_url><dtml-var thread_path>/<dtml-var id>/</link>
           </item>
</dtml-in></dtml-if>
        </channel>
    </rss>

Changing the look should not be that hard either.  Just give me some HTML code templates and the new images to use.
Comment 10 Daniel Molkentin 2009-02-05 13:06:36 UTC
Somebody told me this is still open. With the new dot online, I will close this ticket. Thanks to everyone involved in the transition and setup.
Comment 11 Mark Ziegler 2009-06-19 17:11:26 UTC
Until old links are not working again (redirects) it is not ready in my opinion.

So I open it again.

I already wrote an email to Kyle (Cornelius dit it as well), but nothing happens.

What is the status about that?
Comment 12 Ben Cooksley 2010-05-27 10:06:00 UTC
I fixed redirecting the old urls a month or two ago.