Bug 151791 - kde startup breaks XRandR setup
Summary: kde startup breaks XRandR setup
Status: RESOLVED DUPLICATE of bug 131197
Alias: None
Product: krandr
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Gustavo Pichorim Boiko
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-03 01:18 UTC by Andreas Pakulat
Modified: 2012-06-20 07:48 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Pakulat 2007-11-03 01:18:30 UTC
Version:            (using KDE KDE 3.5.8)
Installed from:    Debian testing/unstable Packages

After switching from Xinerama/Xorg 7.2 to XRandR/Xorg 7.3 for a multi-head setup KDE broke the working XRandR setup when I ran startkde. The problem is the randr-configuration thats stored in startupconfig and has hardcoded values for the screens and their positions. Then during startkde these values are read and set via xrandr and this breaks if something changed in the setup and the user doesn't get notified at all.

In my case the kde startup just disabled the 2nd head.
Comment 1 MKuutti 2007-11-19 15:40:11 UTC
I can confirm this, using Ubuntu Gutsy, kde 3.5.8
I added my own xrandr commands to xstartup script and it did work for a while but now it seems that startkde somehow disables my second head. Using intel driver and first head is VGA and another is TMDS-1
Comment 2 Lubos Lunak 2010-08-31 15:32:32 UTC

*** This bug has been marked as a duplicate of bug 131197 ***