Bug 151773 - konqueror crashed when clicking on an image link
Summary: konqueror crashed when clicking on an image link
Status: RESOLVED DUPLICATE of bug 151083
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-02 19:55 UTC by Martin Koller
Modified: 2007-11-22 20:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2007-11-02 19:55:35 UTC
Version:           unknown (using KDE 3.95.00 (KDE 4.0 Beta4))
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.7-default

I was testing konqueror by using "ggi:wallpapers" and clicked on some image link, where I got the following crash bt:
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1236855088 (LWP 518)]
[KCrash handler]
#9  0xb7f67410 in ?? ()
#10 0xbf9167b8 in ?? ()
#11 0x00000006 in ?? ()
#12 0x00000206 in ?? ()
#13 0xb6798200 in raise () from /lib/libc.so.6
#14 0xb67999a1 in abort () from /lib/libc.so.6
#15 0xb679184b in __assert_fail () from /lib/libc.so.6
#16 0xb4687d2c in ~KHTMLFactory (this=0x813c718)
    at /home/KDE4/source/kdelibs/khtml/khtml_factory.cpp:63
#17 0xb720f5c2 in QObjectCleanupHandler::clear () from /usr/lib/libQtCore.so.4
#18 0xb720f62d in QObjectCleanupHandler::~QObjectCleanupHandler ()
   from /usr/lib/libQtCore.so.4
#19 0xb7afd9d5 in destroy ()
    at /home/KDE4/source/kdelibs/kdecore/util/kpluginfactory.cpp:29
#20 0xb7afd958 in __tcf_0 ()
    at /home/KDE4/source/kdelibs/kdecore/kernel/kglobal.h:65
#21 0xb679ad6d in exit () from /lib/libc.so.6
#22 0xb714fedc in qt_message_output () from /usr/lib/libQtCore.so.4
#23 0xb714ff79 in qFatal () from /usr/lib/libQtCore.so.4
#24 0xb7150015 in qt_assert () from /usr/lib/libQtCore.so.4
#25 0xb7e73155 in KParts::BrowserRun::askEmbedOrSave (url=@0xbf918b88, 
    mimeType=@0xbf918c28, suggestedFileName=@0xbf918ba0, flags=0)
    at /home/KDE4/source/kdelibs/kdecore/util/ksharedptr.h:114
#26 0xb4656476 in KHTMLPart::processObjectRequest (this=0x81a0940, 
    child=0x8b31ac8, _url=@0xbf918c20, mimetype=@0xbf918c28)
    at /home/KDE4/source/kdelibs/khtml/khtml_part.cpp:4359
#27 0xb4687220 in KHTMLRun::foundMimeType (this=0x93db780, _type=@0xbf918c78)
    at /home/KDE4/source/kdelibs/khtml/khtml_run.cpp:53
#28 0xb7e760c3 in KParts::BrowserRun::slotBrowserMimetype (this=0x93db780, 
    _job=0x87a99a0, type=@0xbf919814)
    at /home/KDE4/source/kdelibs/kparts/browserrun.cpp:215
#29 0xb7e767c5 in KParts::BrowserRun::qt_metacall (this=0x93db780, 
    _c=QMetaObject::InvokeMetaMethod, _id=-3, _a=0xbf9191d8)
    at /mnt/usbstick/KDE4/build/kdelibs/kparts/browserrun.moc:72
#30 0xb4686e22 in KHTMLRun::qt_metacall (this=0x93db780, 
    _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf9191d8)
    at /mnt/usbstick/KDE4/build/kdelibs/khtml/khtml_run.moc:58
#31 0xb720bb61 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#32 0xb720c662 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#33 0xb7be7319 in KIO::TransferJob::mimetype (this=0x87a99a0, _t1=0x87a99a0, 
    _t2=@0xbf919814) at /mnt/usbstick/KDE4/build/kdelibs/kio/jobclasses.moc:382
#34 0xb7be83d2 in KIO::TransferJob::slotMimetype (this=0x87a99a0, 
    type=@0xbf919814) at /home/KDE4/source/kdelibs/kio/kio/job.cpp:1125
#35 0xb7bf398d in KIO::TransferJob::qt_metacall (this=0x87a99a0, 
    _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf91970c)
    at /mnt/usbstick/KDE4/build/kdelibs/kio/jobclasses.moc:337
#36 0xb720bb61 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#37 0xb720c662 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#38 0xb7cc2f63 in KIO::SlaveInterface::mimeType (this=0x837ff80, 
    _t1=@0xbf919814)
    at /mnt/usbstick/KDE4/build/kdelibs/kio/slaveinterface.moc:264
#39 0xb7cc7ebc in KIO::SlaveInterface::dispatch (this=0x837ff80, _cmd=21, 
    rawdata=@0xbf919884)
    at /home/KDE4/source/kdelibs/kio/kio/slaveinterface.cpp:283
#40 0xb7cc3bfd in KIO::SlaveInterface::dispatch (this=0x837ff80)
    at /home/KDE4/source/kdelibs/kio/kio/slaveinterface.cpp:88
#41 0xb7cb5afd in KIO::Slave::gotInput (this=0x837ff80)
    at /home/KDE4/source/kdelibs/kio/kio/slave.cpp:318
#42 0xb7cb686d in KIO::Slave::qt_metacall (this=0x837ff80, 
    _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf919da4)
    at /mnt/usbstick/KDE4/build/kdelibs/kio/slave.moc:74
#43 0xb720bb61 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#44 0xb720c662 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#45 0xb7bb7407 in KIO::Connection::readyRead (this=0x86393d8)
    at /mnt/usbstick/KDE4/build/kdelibs/kio/connection.moc:83
#46 0xb7bb9290 in KIO::ConnectionPrivate::dequeue (this=0x837dd28)
    at /home/KDE4/source/kdelibs/kio/kio/connection.cpp:77
#47 0xb7bb9325 in KIO::Connection::qt_metacall (this=0x86393d8, 
    _c=QMetaObject::InvokeMetaMethod, _id=-3, _a=0x9224cb8)
    at /mnt/usbstick/KDE4/build/kdelibs/kio/connection.moc:71
#48 0xb720693b in QMetaCallEvent::placeMetaCall () from /usr/lib/libQtCore.so.4
#49 0xb720904c in QObject::event () from /usr/lib/libQtCore.so.4
#50 0xb6adfe10 in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#51 0xb6ae5ef9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#52 0xb77c919a in KApplication::notify (this=0xbf91a60c, receiver=0x86393d8, 
    event=0x931aec0)
    at /home/KDE4/source/kdelibs/kdeui/kernel/kapplication.cpp:319
#53 0xb71fa9ab in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#54 0xb71fbd45 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#55 0xb71fbffd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#56 0xb721bc3b in postEventSourceDispatch () from /usr/lib/libQtCore.so.4
#57 0xb6630de2 in g_main_context_dispatch ()
   from /opt/gnome/lib/libglib-2.0.so.0
#58 0xb6633e1f in ?? () from /opt/gnome/lib/libglib-2.0.so.0
#59 0x0805e240 in ?? ()
#60 0x00000000 in ?? ()
#0  0xb7f67410 in ?? ()
Comment 1 Tommi Tervo 2007-11-22 09:47:45 UTC

*** This bug has been marked as a duplicate of 151453 ***
Comment 2 Maksim Orlovich 2007-11-22 20:06:20 UTC
Not quite there, Tommi.. It assert-failed in BrowserRun, and then assert-failed again in that..
Comment 3 Maksim Orlovich 2007-11-22 20:38:48 UTC

*** This bug has been marked as a duplicate of 151083 ***