Bug 151546 - Knotify4 has over 900 wakeups per second
Summary: Knotify4 has over 900 wakeups per second
Status: CLOSED NOT A BUG
Alias: None
Product: Phonon
Classification: Frameworks and Libraries
Component: Xine backend (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Matthias Kretz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-30 00:34 UTC by Kyle Cunningham
Modified: 2022-09-22 17:51 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Powertop output on kernel version 2.6.22-hrt6 (406 bytes, text/plain)
2007-10-30 00:36 UTC, Kyle Cunningham
Details
Powertop output on kernel version 2.6.23-rc8 (284 bytes, text/plain)
2007-10-30 00:38 UTC, Kyle Cunningham
Details
strace of knotify4 (49.77 KB, text/plain)
2007-11-03 17:10 UTC, Kyle Cunningham
Details
Powertop output after disabling sound in kcmshell kcmnotify. (1.05 KB, text/plain)
2007-11-03 17:11 UTC, Kyle Cunningham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle Cunningham 2007-10-30 00:34:39 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          g++ 4.1.3 
OS:                Linux

Powertop shows knotify4 waking up the processor generally over 900 times per second.  This behavior occurs on
both Linux kernels 2.6.22-hrt6 and with 2.6.23-rc8.

This can be reproduced simply by starting a full kde4 session and can be seen in Powertop.
Comment 1 Kyle Cunningham 2007-10-30 00:36:58 UTC
Created attachment 21944 [details]
Powertop output on kernel version 2.6.22-hrt6
Comment 2 Kyle Cunningham 2007-10-30 00:38:27 UTC
Created attachment 21945 [details]
Powertop output on kernel version 2.6.23-rc8
Comment 3 Olivier Goffart 2007-10-31 13:46:58 UTC
Thanks for your report.

I have not been able to identify the problem.  
I've tried to run knotify4 with strace, and I did not identified a special problem.
There was no timer inside the knotify code, I do not see where the problem can be, maybe in phonon.

Try this:
 - run knotify under strace.
 - disable sound in the knotify player preferences and see if the problem still happen.
Comment 4 Kyle Cunningham 2007-11-03 17:09:32 UTC
I ran strace and have attached it to the report.

Additionally, it appears the disabling sound with knotify has done the trick.
To do this I went into "kcmshell kcmnotify".  I then disabled sounds on the player settings tab and also went through each event individually and disabled the sound event associated with each one.  I have also attatched the output from powertop after I disabled sound.
Comment 5 Kyle Cunningham 2007-11-03 17:10:19 UTC
Created attachment 21987 [details]
strace of knotify4
Comment 6 Kyle Cunningham 2007-11-03 17:11:32 UTC
Created attachment 21988 [details]
Powertop output after disabling sound in kcmshell kcmnotify.
Comment 7 Josep Febrer 2007-11-16 16:48:20 UTC
I think that the cause of this bug it is related to Phonon or xine, because if I run Juk and amaroK from KDE4 which also uses Phonon they show the exact same bad numbers as knotify4. However using amaroK 1.4 which the xine backend but not with Phonon doesn't have this problem.
Comment 8 Matthias Kretz 2007-11-16 18:38:16 UTC
new bug report opened at xine bugtracker:
http://sourceforge.net/tracker/index.php?func=detail&aid=1833274&group_id=9655&atid=109655
Comment 9 Yves Glodt 2008-01-11 00:26:41 UTC
I just installed the kde4.0 packages available from the ppa repository for kubuntu 7.10, and I see the bug:
52.6% (890.6)          knotify4 : do_nanosleep (hrtimer_wakeup)
29.7% (427.2)       <interrupt> : extra timer interrupt
Comment 10 Yves Glodt 2008-01-11 00:27:41 UTC
sorry, I did not read #8
Comment 11 S. Burmeister 2008-09-26 15:47:02 UTC
The bug-report at sourceforge is private, are there any news? One can "work around" the bug by killing knotify4. It is restarted again but does not do any wakeups anymore.