Bug 150154 - Saving multiple attachments causes Kontact crash with signal 11 (SIGSEGV)
Summary: Saving multiple attachments causes Kontact crash with signal 11 (SIGSEGV)
Status: RESOLVED DUPLICATE of bug 136145
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 1.2.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-24 17:00 UTC by John K. Hohm
Modified: 2007-11-19 12:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John K. Hohm 2007-09-24 17:00:57 UTC
Version:           1.2.4 (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

After selecting several attached images of a multipart message in my IMAP inbox, and choosing Save As... from the context menu, Kontact crashes with SIGSEGV.  This is reproducible on the same 937 KB email if I first choose one of several combinations of the 19 attached images; the same sets of images -- in some cases just two -- always trigger the crash.  However if in a single Kontact session I first select each image individually and choose Save As... I can then select all the images and choose Save As... without a crash.  Also if I save the entire message and then open it from disk I can immediately choose all the attachments and Save As... will not crash.

The message is not private so I can forward it if desired.

Here is a backtrace when run with LD_LIBRARY_PATH=/usr/lib/debug:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 47858682592816 (LWP 6888)]
[New Thread 1107310912 (LWP 6892)]
[New Thread 1098918208 (LWP 6891)]
[New Thread 1090525504 (LWP 6890)]
[New Thread 1082132800 (LWP 6889)]
[KCrash handler]
#5  0x00002b86fcc697f1 in KMLoadPartsCommand::slotPartRetrieved ()
   from /usr/lib/libkmailprivate.so
#6  0x00002b86fcc699a0 in KMLoadPartsCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#7  0x00002b86f0d20ce2 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#8  0x00002b86fcb12987 in KMail::FolderJob::messageUpdated ()
   from /usr/lib/libkmailprivate.so
#9  0x00002b86fcc8c0f0 in KMail::ImapJob::slotGetMessageResult ()
   from /usr/lib/libkmailprivate.so
#10 0x00002b86fcd398ff in KMail::ImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#11 0x00002b86f0d20ce2 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#12 0x00002b86f16abd32 in KIO::Job::result () from /usr/lib/libkio.so.4
#13 0x00002b86f16e5e9f in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#14 0x00002b86f16f1aca in KIO::SimpleJob::slotFinished ()
   from /usr/lib/libkio.so.4
#15 0x00002b86f16f211a in KIO::TransferJob::slotFinished ()
   from /usr/lib/libkio.so.4
#16 0x00002b86f16e5b08 in KIO::TransferJob::qt_invoke ()
   from /usr/lib/libkio.so.4
#17 0x00002b86f0d20ce2 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#18 0x00002b86f0d2187c in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#19 0x00002b86f170a445 in KIO::SlaveInterface::dispatch ()
   from /usr/lib/libkio.so.4
#20 0x00002b86f16fb31e in KIO::SlaveInterface::dispatch ()
   from /usr/lib/libkio.so.4
#21 0x00002b86f16ba24b in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#22 0x00002b86f16fe6c8 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#23 0x00002b86f0d20ce2 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#24 0x00002b86f0d216d3 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#25 0x00002b86f108f79c in QSocketNotifier::activated ()
   from /usr/lib/libqt-mt.so.3
#26 0x00002b86f0d42640 in QSocketNotifier::event ()
   from /usr/lib/libqt-mt.so.3
#27 0x00002b86f0cbc1d6 in QApplication::internalNotify ()
   from /usr/lib/libqt-mt.so.3
#28 0x00002b86f0cbdf65 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#29 0x00002b86f03e2378 in KApplication::notify ()
   from /usr/lib/libkdecore.so.4
#30 0x00002b86f0c4ecc2 in QApplication::sendEvent ()
   from /usr/lib/libqt-mt.so.3
#31 0x00002b86f0caedef in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#32 0x00002b86f0c633d0 in QEventLoop::processEvents ()
   from /usr/lib/libqt-mt.so.3
#33 0x00002b86f0cd570b in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#34 0x00002b86f0cd5513 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#35 0x00002b86f0cbdc9c in QApplication::exec () from /usr/lib/libqt-mt.so.3
#36 0x000000000041dc12 in ?? ()
#37 0x00002b86efebb8e4 in __libc_start_main (
    main=0x41d780 <_ZN7QWidget17setUpdatesEnabledEb@plt+32168>, argc=1, 
    ubp_av=0x7fffbc915028, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffbc915018) at libc-start.c:231
#38 0x0000000000415a19 in ?? ()
#39 0x00007fffbc915018 in ?? ()
#40 0x0000000000000000 in ?? ()
Comment 1 Johannes Perl 2007-11-19 12:23:40 UTC
I can confirm this bug. Have had it up to know everytime trying to download more than one file with kontact. Single file downloads work fine.
Comment 2 Tommi Tervo 2007-11-19 12:47:11 UTC

*** This bug has been marked as a duplicate of 136145 ***