Bug 150077 - Find Duplicate Images tool quite unusable on many images (a couple of issues).
Summary: Find Duplicate Images tool quite unusable on many images (a couple of issues).
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Searches-Similarity (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-22 00:33 UTC by Sebastian Sjöberg
Modified: 2017-07-05 04:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Sjöberg 2007-09-22 00:33:00 UTC
Version:           0.9.2-final (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
OS:                Linux

I did a scan for duplicate images on my collection and I had around 1000 duplicate images and found that the dialog that pops up where you delete the duplicates is completely unusable on such large numbers.

I had between one and six similar images per "duplicate" so checking all those checkboxes per duplicate and also inspecting every image because it gave some false duplicates was really tedious. The thumbnail loading showing the duplicate during inspection was also very slow as was switching the lefthand picture. When removing an image via the delete button in the window it didn't seem to get removed from the database so whenever I started digikam it complained about not finding images.

I've got some suggestions:

There should be a thumbnail on the left side for every duplicate of an image on the right side.
The duplicates should all be selected so you only had to click to _deselect_ a duplicate.
Clicking delete should delete and advance to the next image on the right side.
Comment 1 Sebastian Sjöberg 2007-09-22 00:37:48 UTC
Btw, I mixed up left and right so my suggestions are instead:

There should be a thumbnail on the right side for every duplicate of an image on the left side.
The duplicates should all be selected so you only had to click to _deselect_ a duplicate.
Clicking delete should delete and advance to the next image on the left side.
Comment 2 caulier.gilles 2008-06-16 23:26:00 UTC
SVN commit 821218 by cgilles:

digiKam from trunk: "Et Voila !!!" Now the Find Duplicates tool from digiKam core is fully functional. This one is based on Haar wavelets fingerprints managed by new digiKam database.
A screenshot : http://digikam3rdparty.free.fr/Screenshots/temp/findduplicatesview3.png

Note: with KDE4, the old FindImages kipi-plugin become obsolete wit digiKam.

BUGS: 162152
BUGS: 161858
BUGS: 150077
BUGS: 112473
BUGS: 107095
BUGS: 104067


 M  +40 -23    findduplicatesview.cpp  
 M  +10 -7     findduplicatesview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=821218