Bug 149925 - Custom shortcuts not saved
Summary: Custom shortcuts not saved
Status: RESOLVED DUPLICATE of bug 137484
Alias: None
Product: kmail
Classification: Applications
Component: keys and menus (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-16 22:36 UTC by hex
Modified: 2008-01-07 19:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hex 2007-09-16 22:36:49 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14.1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-16-generic

When I save a keyboard shortcut - in this case Shift+S to mark messages as being spam it doesn't remember the setting and I have to reset it at each logon - is there a way around this? (I also tried a couple of other 'free' (ie not already assigned shortcuts) but the same thing happens.
Comment 1 Thomas McGuire 2008-01-06 12:23:33 UTC
So to clarify: You can not change any shortcut under under Settings->Configure Shortcuts? This seems strange to me, as KMail uses the standard shortcut dialog from KDE. What about other KDE applications? Does changing shortcuts there work? 
Do you have write permission to your kmailrc file in ~/.kde/share/config/kmailrc?

Reports about keyboard shortcuts being lost:
bug 136011
bug 137484
bug 149925
Comment 2 Michal Vojan 2008-01-07 09:26:32 UTC
I can confirm the same behavior, but it's somehow strange. When I quit kmail, it forgets the defined shortcut for 'Mark as spam'. I also tried shortcut for another action ('About kmail') and I can still use it.

Qt: 3.3.8
KDE: 3.5.8 "release 22.3"
KMail: 1.9.6 (enterprise 20070831.706792)

LANG=cs_CZ
LC_CTYPE="cs_CZ"
LC_NUMERIC="cs_CZ"
LC_TIME="cs_CZ"
LC_COLLATE=cs_CZ
LC_MONETARY="cs_CZ"
LC_MESSAGES="cs_CZ"
LC_PAPER="cs_CZ"
LC_NAME="cs_CZ"
LC_ADDRESS="cs_CZ"
LC_TELEPHONE="cs_CZ"
LC_MEASUREMENT="cs_CZ"
LC_IDENTIFICATION="cs_CZ"
Comment 3 Thomas McGuire 2008-01-07 19:06:39 UTC
Oh, I misread the report, it seems to be about the same issue as bug 137484.

*** This bug has been marked as a duplicate of 137484 ***