Bug 149838 - (fxrstor) vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
Summary: (fxrstor) vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
Status: RESOLVED DUPLICATE of bug 126389
Alias: None
Product: valgrind
Classification: Developer tools
Component: vex (show other bugs)
Version: 3.2.3
Platform: OpenSUSE Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks: 256630
  Show dependency treegraph
 
Reported: 2007-09-13 23:10 UTC by Nilesh Asher
Modified: 2011-08-11 10:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nilesh Asher 2007-09-13 23:10:05 UTC
There was no warning about a bad jump prior to this so I am assuming its item
no. 2. 

vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
==31895== valgrind: Unrecognised instruction at address 0x86FD8CD.
==31895== Your program just tried to execute an instruction that Valgrind
==31895== did not recognise.  There are two possible reasons for this.
==31895== 1. Your program has a bug and erroneously jumped to a non-code
==31895==    location.  If you are running Memcheck and you just saw a
==31895==    warning about a bad jump, it's probably your program's fault.
==31895== 2. The instruction is legitimate but Valgrind doesn't handle it,
==31895==    i.e. it's Valgrind's fault.  If you think this is the case or
==31895==    you are not sure, please let us know and we'll try to fix it.
==31895== Either way, Valgrind will now raise a SIGILL signal which will
==31895== probably kill your program.

I did run with -v or --verbose and got the following 2 lines just prior to the
vex messages (if that helps any)
--31895-- REDIR: 0x41B4480 (strcat) redirected to 0x401D540 (strcat)
--31895-- REDIR: 0x41B5B70 (bcmp) redirected to 0x401DF80 (bcmp)
vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0
Comment 1 Julian Seward 2007-11-16 03:45:08 UTC
It's probably FXRSTOR.  A lot of hassle to implement for relatively
little gain.  Can you give some details on what s/w you were running
on Valgrind when this happened?
Comment 2 Nilesh Asher 2007-11-16 16:16:02 UTC
It was a C++ library/application that I am developing which was compiled with g++ (3.4.3). 

-Nilesh.
----- Original Message ----
From: Julian Seward <jseward@acm.org>
To: nilesh_asher@yahoo.com
Sent: Thursday, November 15, 2007 6:45:09 PM
Subject: [Bug 149838] vex x86->IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0   

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=149838         




------- Additional Comments From jseward acm org  2007-11-16 03:45
 -------
It's probably FXRSTOR.  A lot of hassle to implement for relatively
little gain.  Can you give some details on what s/w you were running
on Valgrind when this happened?






      ____________________________________________________________________________________
Be a better pen pal. 
Text or chat with friends inside Yahoo! Mail. See how.  http://overview.mail.yahoo.com/<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:tahoma,new york,times,serif;font-size:10pt"><div style="font-family: tahoma,new york,times,serif; font-size: 10pt;">It was a C++ library/application that I am developing which was compiled with g++ (3.4.3). <br><br>-Nilesh.<br><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;">----- Original Message ----<br>From: Julian Seward &lt;jseward@acm.org&gt;<br>To: nilesh_asher@yahoo.com<br>Sent: Thursday, November 15, 2007 6:45:09 PM<br>Subject: [Bug 149838] vex x86-&gt;IR: unhandled instruction bytes: 0xF 0xAE 0xD 0xE0   <br><br>------- You are receiving this mail because: -------<br>You reported the bug, or are watching the reporter.<br>&nbsp; &nbsp; &nbsp; &nbsp;  <br><a href="http://bugs.kde.org/show_bug.cgi?id=149838" target="_blank">http://bugs.kde.org/show_bug.cgi?id=149838</a>&nbsp; &nbsp; &nbsp; &nbsp; 
 <br><br><br><br><br>------- Additional Comments From jseward acm org&nbsp; 2007-11-16 03:45
 -------<br>It's probably FXRSTOR.&nbsp; A lot of hassle to implement for relatively<br>little gain.&nbsp; Can you give some details on what s/w you were running<br>on Valgrind when this happened?<br></div><br></div></div><br>
      <hr size=1>Be a better pen pal. 
Text or chat with friends inside Yahoo! Mail. <a href="http://us.rd.yahoo.com/evt=51732/*http://overview.mail.yahoo.com/">See how.</a></body></html>
Comment 3 Tom Hughes 2011-08-11 10:07:16 UTC

*** This bug has been marked as a duplicate of bug 194402 ***
Comment 4 Tom Hughes 2011-08-11 10:09:11 UTC

*** This bug has been marked as a duplicate of bug 126389 ***