Bug 149766 - kmail crashes when reading my kmailrc file from kmail version 3.5.5
Summary: kmail crashes when reading my kmailrc file from kmail version 3.5.5
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: config compatibility (show other bugs)
Version: enterprise
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 150530 152118 153395 154364 157813 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-11 10:17 UTC by Dr. Jürgen Vollmer
Modified: 2008-09-15 14:37 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash log (547 bytes, text/plain)
2007-09-12 08:38 UTC, Dr. Jürgen Vollmer
Details
a minimal kmailrc file triggering the crash (849 bytes, text/plain)
2007-09-12 08:40 UTC, Dr. Jürgen Vollmer
Details
Logfile produced by: valgrind --leak-check=full --verbose kmail (18.80 KB, text/plain)
2007-09-12 08:51 UTC, Dr. Jürgen Vollmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Jürgen Vollmer 2007-09-11 10:17:09 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

I upgraded my KDE from 3.5.5 to 3.5.7 on my SuSE 10.2 system.
After that kmail crashes each time. If I remove my kmailrc file kmail creates a new one and starts fine. I "played" a little bit with the kmailrc file and deleted from the old file some entries until I get working version.
Background: I have ~40 filter rules which I don't want to be lost.

If needed I may send you my old kmailrc file.
Comment 1 Thomas McGuire 2007-09-11 17:31:32 UTC
Please add a backtrace, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports.

Also, since you removed entries until KMail did not crash anymore, you can probably say which entry makes KMail crash. Then you can just paste that entry here instead of the whole kmailrc.

What exact version is KMail at (Help->About KMail dialog)?
Comment 2 Dr. Jürgen Vollmer 2007-09-12 08:38:52 UTC
Created attachment 21611 [details]
crash log
Comment 3 Dr. Jürgen Vollmer 2007-09-12 08:40:03 UTC
Created attachment 21612 [details]
a minimal kmailrc file triggering the crash
Comment 4 Dr. Jürgen Vollmer 2007-09-12 08:44:23 UTC
I reduced my kmailrc causing the crash to the example attached to this report.
I use KMail 1.9.6 (enterprise 20070831.706792) (KDE 3.5.7 "release 74.2" openSUSE) on a SuSE 10.2 system. My CPU is a AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Comment 5 Dr. Jürgen Vollmer 2007-09-12 08:51:43 UTC
Created attachment 21613 [details]
Logfile produced by: valgrind --leak-check=full --verbose  kmail
Comment 6 Thomas McGuire 2007-09-20 19:47:55 UTC
Pasting backtrace for easier searching:

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47524374741344 (LWP 1385)]
[KCrash handler]
#5  0x00002b391690d45b in KMFolderCachedImap::account ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002b39169eea59 in KMailICalIfaceImpl::readConfig ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002b3916937cb4 in KMKernel::init ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x0000000000402944 in main ()
Comment 7 Thomas McGuire 2007-10-19 19:38:16 UTC
*** Bug 150530 has been marked as a duplicate of this bug. ***
Comment 8 Thomas McGuire 2007-11-10 18:28:13 UTC
*** Bug 152118 has been marked as a duplicate of this bug. ***
Comment 9 Tommi Tervo 2007-12-04 14:49:37 UTC
*** Bug 153395 has been marked as a duplicate of this bug. ***
Comment 10 Thomas McGuire 2007-12-20 15:53:04 UTC
*** Bug 154364 has been marked as a duplicate of this bug. ***
Comment 11 Thomas McGuire 2008-02-14 17:56:20 UTC
*** Bug 157813 has been marked as a duplicate of this bug. ***
Comment 12 Nils Schmeisser 2008-03-19 15:38:10 UTC
I can reproduce this error as for KMail 1.9.9 (KDE 3.5.9) of Kubuntu package
To cross check: in kmailicalifaceimpl.cpp:1623 (this is kdepim-3.5.7 source)

KMAcctCachedImap::GroupwareType groupwareType = dynamic_cast<KMFolderCachedImap *>( folderParent->storage() )->account()->groupwareType();

is invoked which invokes KMFolderCachedImap::account () ???.
As I have an IMAP server I removed this line and replaced it by:

KMAcctCachedImap::GroupwareType groupwareType = KMAcctCachedImap::GroupwareNone;

Now kmail starts fine, groupware function can be set. Folder types can be
set BUT: still no access to IMAP ressources from korganizer nor kaddressbook.

My kmailrc (relevant part) looks like this:

[GroupwareFolderInfo]
.1772865749.directory/Aufgaben-storageFormat=icalvcard
.1772865749.directory/Journal-storageFormat=icalvcard
.1772865749.directory/Kalender-storageFormat=icalvcard
.1772865749.directory/Kontakte-storageFormat=icalvcard
.1772865749.directory/Notizen-storageFormat=icalvcard

[IMAP Resource]
Enabled=true
Folder Language=1
HideGroupwareFolders=false
TheIMAPResourceAccount=1772865749
TheIMAPResourceEnabled=false
TheIMAPResourceFolderLanguage=1
TheIMAPResourceFolderParent=1772865749

ID's are correct, strangly TheIMAPResourceFolderParent looks different
than anywhere else described (should look like .1772865749.directory ???)

Hope this helps to track down the error.
Comment 13 Jaime Torres 2008-09-14 12:41:16 UTC
If the crash happens when kmail starts with the attached kmailrc. It does not happens here with kmail 1.10.1 (kde 4.1.1).
Is there anything else that should be done to trigger the bug? Or should it be considered fixed?
Comment 14 Dr. Jürgen Vollmer 2008-09-15 14:37:35 UTC
> If the crash happens when kmail starts with the attached kmailrc. 
> It does not happens here with kmail 1.10.1 (kde 4.1.1).
> Is there anything else that should be done to trigger the bug? 
> Or should it be considered fixed?

I just tested that kmailrc with kmail 1.9.9 (KDE 3.5.9 release 49.1 openSUSE 11.0) and kmail didn't crash anymore. So I think that bug can be considered as fixed.

Jürgen