Bug 149630 - kontact crashes in summary view
Summary: kontact crashes in summary view
Status: RESOLVED DUPLICATE of bug 148172
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-07 16:06 UTC by Andre Woebbeking
Modified: 2007-09-07 16:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Woebbeking 2007-09-07 16:06:42 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.1.2 
OS:                Linux

Hi,

kontact crashes when I switch to the summary view. valgrind finds access to already deleted data.

Backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47603217404016 (LWP 4303)]
[New Thread 1107310928 (LWP 4307)]
[New Thread 1098918224 (LWP 4306)]
[New Thread 1090525520 (LWP 4305)]
[New Thread 1082132816 (LWP 4304)]
[KCrash handler]
#5  QString (this=0x7fff36354810, s=@0x1d4f1d0) at tools/qshared.h:49
#6  0x00002b4b7500bcf2 in KCal::Incidence::relatedToUid (
    this=<value optimized out>)
    at /Devel/src/kde/kdepim/libkcal/incidence.cpp:288
#7  0x00002b4b750389da in KCal::ICalFormatImpl::populate (
    this=<value optimized out>, cal=0x19c2920, calendar=<value optimized out>)
    at /Devel/src/kde/kdepim/libkcal/icalformatimpl.cpp:2032
#8  0x00002b4b75033ee4 in KCal::ICalFormat::fromRawString (
    this=0x7fff36354b00, cal=0x19c2920, text=<value optimized out>)
    at /Devel/src/kde/kdepim/libkcal/icalformat.cpp:184
#9  0x00002b4b7503448c in KCal::ICalFormat::load (this=0x7fff36354b00, 
    calendar=0x19c2920, fileName=<value optimized out>)
    at /Devel/src/kde/kdepim/libkcal/icalformat.cpp:98
#10 0x00002b4b7504c252 in KCal::FileStorage::load (this=0x7fff36354bb0)
    at /Devel/src/kde/kdepim/libkcal/filestorage.cpp:97
#11 0x00002b4b7502ad77 in KCal::CalendarLocal::load (this=0x19c2920, 
    fileName=@0x7fff36354c40, format=0x0)
    at /Devel/src/kde/kdepim/libkcal/calendarlocal.cpp:66
#12 0x00002b4b7504ead3 in KCal::ResourceLocal::doLoad (this=0x19c28b0)
    at /Devel/src/kde/kdepim/libkcal/resourcelocal.cpp:154
#13 0x00002b4b7504e019 in KCal::ResourceCalendar::load (this=0x7fff36354810)
    at /Devel/src/kde/kdepim/libkcal/resourcecalendar.cpp:111
#14 0x00002b4b750588d3 in KCal::CalendarResources::load (this=0x19af930)
    at /Devel/src/kde/kdepim/libkcal/calendarresources.cpp:143
#15 0x00002b4b7f81471c in SummaryWidget (this=0x1c1cdd0, 
    plugin=<value optimized out>, parent=<value optimized out>, 
    name=<value optimized out>)
    at /Devel/src/kde/kdepim/kontact/plugins/korganizer/summarywidget.cpp:68
#16 0x00002b4b7f80f90c in KOrganizerPlugin::createSummaryWidget (
    this=0x8bbef0, parent=0x18fb6a0)
    at /Devel/src/kde/kdepim/kontact/plugins/korganizer/korganizerplugin.cpp:73
#17 0x00002b4b81f9b5e5 in SummaryViewPart::updateWidgets (this=0x1869b00)
    at /Devel/src/kde/kdepim/kontact/plugins/summary/summaryview_part.cpp:179
#18 0x00002b4b81f9c2bb in SummaryViewPart (this=0x1869b00, core=0x71e8f0, 
    aboutData=0x18c5f70, parent=0x94df70, name=<value optimized out>)
    at /Devel/src/kde/kdepim/kontact/plugins/summary/summaryview_part.cpp:78
#19 0x00002b4b81f998d1 in SummaryView::createPart (this=0x94df70)
    at /Devel/src/kde/kdepim/kontact/plugins/summary/summaryview_plugin.cpp:47
#20 0x00002b4b74d6a6d1 in Kontact::Plugin::part (this=0x7fff36354810)
    at /Devel/src/kde/kdepim/kontact/interfaces/plugin.cpp:144
#21 0x000000000041c8a1 in Kontact::MainWindow::selectPlugin (this=0x71e8f0, 
    plugin=0x94df70) at /Devel/src/kde/kdepim/kontact/src/mainwindow.cpp:536


Cheers,
André
Comment 1 Andre Woebbeking 2007-09-07 16:16:17 UTC
Isn't it possible to search for backtraces in advance?

*** This bug has been marked as a duplicate of 148172 ***