Bug 149561 - Crash when sending email to two recipients, one with and one without gpg settings
Summary: Crash when sending email to two recipients, one with and one without gpg sett...
Status: RESOLVED DUPLICATE of bug 144303
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.9.7
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-05 11:49 UTC by Yuval Langer
Modified: 2007-09-05 16:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuval Langer 2007-09-05 11:49:23 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Gentoo Packages
Compiler:          gcc-4.2.0 
OS:                Linux

1. add two recipients to your mailing list in kmail. one that has gpg encryption settings set in kaddressbook, and the other that doesn't.
2. press send.
3. a dialogue box pops, telling you:
"There are conflicting signing prefrences for these recipients.

Sign this message?"
4. choose "Sign" in the dialogue box.
5. choose "Encrypt" in the dialogue box.
6. choose "Cancel" in the dialogue box.
7. CRASH 

This doesn't happen ALL the time, only most of the times.

It's the kde-3.5.7-r2 ebuild.

USE="-arts crypt -debug -elibc_FreeBSD -kdeenablefinal -xinerama"

CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=pentium-m -O3 -pipe"
MAKEOPTS="-j2"

Thanks!
Comment 1 Thomas McGuire 2007-09-05 12:43:26 UTC
Please provide a backtrace, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 2 Yuval Langer 2007-09-05 16:42:24 UTC
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in ?? ()
#0  0xffffe410 in ?? ()
#1  0xbffe4a88 in ?? ()
#2  0xb56f8ff4 in ?? () from /lib/libc.so.6
#3  0xbffe4a74 in ?? ()
#4  0xb565b776 in nanosleep () from /lib/libc.so.6
#5  0xb565b587 in sleep () from /lib/libc.so.6
#6  0xb661c2dc in KCrash::startDrKonqi ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#7  0xb661cb4b in KCrash::defaultCrashHandler ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#8  0xffffe420 in ?? ()
#9  0x0000000b in ?? ()
#10 0x00000033 in ?? ()
#11 0xc0400000 in ?? ()
#12 0x0000007b in ?? ()
#13 0x0000007b in ?? ()
#14 0x088421d8 in ?? ()
#15 0xbffe7034 in ?? ()
#16 0xbffe7048 in ?? ()
#17 0xbffe7010 in ?? ()
#18 0xb7f406a8 in ?? () from /usr/kde/3.5/lib/libkmailprivate.so
#19 0x00000400 in ?? ()
#20 0x08840db0 in ?? ()
#21 0x00000001 in ?? ()
#22 0x0000000e in ?? ()
#23 0x00000004 in ?? ()
#24 0xb7de2498 in MessageComposer::emitDone ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#25 0xb7de27aa in MessageComposer::doNextJob ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#26 0xb7de2862 in MessageComposer::slotDoNextJob ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#27 0xb7de2b52 in MessageComposer::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#28 0xb5f5a939 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb62e81de in QSignal::signal () from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb5f774a5 in QSignal::activate () from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb5f7eb03 in QSingleShotTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb5eefefc in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#33 0xb5ef0b96 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#34 0xb6593232 in KApplication::notify ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#35 0xb5ee42e0 in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#36 0xb5e9366a in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#37 0xb5f09121 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#38 0xb5f08fb6 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#39 0xb5eef95f in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#40 0x0804a444 in ?? ()
#41 0xbffe7670 in ?? ()
#42 0xbffe7860 in ?? ()
#43 0x00000000 in ?? ()



Thanks!
Comment 3 Thomas McGuire 2007-09-05 16:49:02 UTC

*** This bug has been marked as a duplicate of 144303 ***