Bug 149442 - Bug when replying messages with attached text file
Summary: Bug when replying messages with attached text file
Status: RESOLVED DUPLICATE of bug 134705
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-01 05:47 UTC by Francisco Castro
Modified: 2007-09-01 11:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Castro 2007-09-01 05:47:04 UTC
Version:           1.9.5 (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.21-2-k7

Someone has sent me an email with an attached text file. Then if I right click over the file and choose "view", select some text and press the "r" key to reply, it crashes with a segmentation fault.

My kmail is stripped, so the backtrace is useless.

#0  0xb7d28826 in the text of /usr/lib/libkmailprivate.so ()
#1  0xbfaecf34 in the stack ()
#2  0xb7e84a8f in the text of /usr/lib/libkmailprivate.so ()
#3  0x00000011 in ?? ()
#4  0xb7e84a8f in the text of /usr/lib/libkmailprivate.so ()
#5  0x00000010 in ?? ()
#6  0xb75185ac in /usr/lib/libqt-mt.so.3.3.7 ()
#7  0xbfaecf08 in the stack ()
#8  0xb7337c35 in the text of /usr/lib/libkdecore.so.4.2.0 ()
#9  0xbfaecf34 in the stack ()
#10 0xb7e84a8f in the text of /usr/lib/libkmailprivate.so ()
#11 0x00000011 in ?? ()
#12 0xb7ef2858 in /usr/lib/libkmailprivate.so ()
#13 0xbfaecf40 in the stack ()
#14 0xbfaecf34 in the stack ()
#15 0xbfaecf68 in the stack ()
#16 0xb7d8973f in /usr/lib/libkmailprivate.so ()
#17 0xbfaecf40 in the stack ()
#18 0x00000000 in ?? ()
Comment 1 Francisco Castro 2007-09-01 05:49:41 UTC
This was the backtrace shown in the crash dialog:

(no debugging symbols found)
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1250473184 (LWP 27906)]
[New Thread -1280320624 (LWP 27910)]
[New Thread -1271927920 (LWP 27909)]
[New Thread -1263535216 (LWP 27908)]
[New Thread -1255142512 (LWP 27907)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7f087f2 in ?? () from /lib/ld-linux.so.2
#0  0xb7f087f2 in ?? () from /lib/ld-linux.so.2
#1  0xb782ee36 in nanosleep () from /lib/i686/cmov/libc.so.6
#2  0xb782ec47 in sleep () from /lib/i686/cmov/libc.so.6
#3  0xb762b117 in KCrash::startDrKonqi () from /usr/lib/libkdecore.so.4
#4  0xb7641127 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#5  0xb77c6898 in killpg () from /lib/i686/cmov/libc.so.6
#6  0xb7d8173f in KMMessage::identityUoid () from /usr/lib/libkmailprivate.so
#7  0xb7d81986 in KMMessage::initFromMessage ()
   from /usr/lib/libkmailprivate.so
#8  0xb7e2c3fe in KMMessage::createReply () from /usr/lib/libkmailprivate.so
#9  0xb7e2e978 in KMReplyToCommand::execute ()
   from /usr/lib/libkmailprivate.so
#10 0xb7b9f549 in KMCommand::slotPostTransfer ()
   from /usr/lib/libkmailprivate.so
#11 0xb7c2b126 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#12 0xb7c2ba2b in KMReplyToCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#13 0xb7048d23 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb7b9f66e in KMCommand::messagesTransfered ()
   from /usr/lib/libkmailprivate.so
#15 0xb7c8c184 in KMCommand::transferSelectedMsgs ()
   from /usr/lib/libkmailprivate.so
#16 0xb7c8c2e7 in KMCommand::slotStart () from /usr/lib/libkmailprivate.so
#17 0xb7c2b138 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#18 0xb7c2ba2b in KMReplyToCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#19 0xb7048d23 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0xb73d5360 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#21 0xb7068d4e in QSignal::activate () from /usr/lib/libqt-mt.so.3
#22 0xb70707a0 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#23 0xb6fe04e0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#24 0xb6fe230f in QApplication::notify () from /usr/lib/libqt-mt.so.3
#25 0xb76fc142 in KApplication::notify () from /usr/lib/libkdecore.so.4
#26 0xb6f73595 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#27 0xb6fd2e6b in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#28 0xb6f87a10 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xb6ffabe6 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xb6ffa9f6 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0xb6fe2089 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x0804a094 in ?? ()
#33 0xbfeab6d4 in ?? ()
#34 0xbfeab8c0 in ?? ()
#35 0x00000000 in ?? ()
Comment 2 Bram Schoenmakers 2007-09-01 11:17:06 UTC

*** This bug has been marked as a duplicate of 134705 ***