Bug 149276 - JJ: Convert config dialogs to .ui files
Summary: JJ: Convert config dialogs to .ui files
Status: RESOLVED NOT A BUG
Alias: None
Product: kbackgammon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Alexander Smirnov
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2007-08-27 21:56 UTC by Albert Astals Cid
Modified: 2009-11-23 22:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2007-08-27 21:56:46 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

Configuration dialogs in KBackgammon are created using C++ code, that is not needed and hinders easy expansion for the future. They should be converted to .ui files generated by designer. Implementing this JJ will give you knowledge about designer, and KDE related configuration classes.

Contact me at aacid@kde.org for questions.
Comment 1 Wesley Stessens 2007-08-27 22:37:20 UTC
Hi,

I'd like to implement this feature. I contacted you by email 
Comment 2 FiNeX 2009-08-26 14:43:58 UTC
Changed the default assignee.
Comment 3 Albert Astals Cid 2009-11-23 22:14:54 UTC
kbackgammon is "dead" so no point in having this JJ