Bug 149165 - cannot edit anymore - sqlite lock?
Summary: cannot edit anymore - sqlite lock?
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 0.9.1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-24 12:57 UTC by Gerben Gieling
Modified: 2017-07-25 10:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.9.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerben Gieling 2007-08-24 12:57:46 UTC
Version:           0.9.1 (using KDE KDE 3.5.7)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1.2 
OS:                Linux

I cannot creat any new tags or add tags to my pictures anymore.
I assume this is caused by a lock in the underlying sqlite database, but don't know how to verify and resolve this.
Comment 1 caulier.gilles 2007-08-24 13:00:58 UTC
Gerben,

Do you use a remote file system to host album library path (like NFS or SAMBA) ?

If yes, read this FAQ : http://www.digikam.org/?q=node/219

Gilles Caulier
Comment 2 Gerben Gieling 2007-08-24 17:14:34 UTC
No,

It is local (ext3) and it worked ok for a while. I already tried by
changing permissions to 666, but without success.

I'm not familiar with sqlite, is there a method to verify directly into
the db file?

Gerben

-----Original Message-----
From: owner@bugs.kde.org [mailto:owner@bugs.kde.org] On Behalf Of Gilles
Caulier
Sent: Friday, 24 August, 2007 13:01
To: Gerben Gieling
Subject: [Bug 149165] cannot edit anymore - sqlite lock? 


------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=149165         




------- Additional Comments From caulier.gilles gmail com  2007-08-24
13:00 ------- Gerben,

Do you use a remote file system to host album library path (like NFS or
SAMBA) ?

If yes, read this FAQ : http://www.digikam.org/?q=node/219

Gilles Caulier
 
-----------------------------------------------------------------------
DISCLAIMER:
This message (including any attachments) is confidential and may be privileged. If you have received it by mistake please notify the sender by return e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited. Please note that e-mails are susceptible to change. Synthon shall not be liable for the improper or incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system. Synthon does not guarantee that the integrity of this communication has been maintained nor that this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of the company.
-----------------------------------------------------------------------
Comment 3 caulier.gilles 2007-08-24 17:57:19 UTC
You can use sqlite command line tool, but it's not trivial.

Question : are you some debug/warning/errors message on the console when you start digiKam ?

Gilles Caulier
Comment 4 Gerben Gieling 2007-08-27 19:55:04 UTC
Gilles,

Starting digikam from a concole prompt generates the message below.
The program launches and shows the images in the directories and the labelling already entered before july.

Therefor I conclude that it opens the proper sqlite file and it actually reads all data available, it just can't make changes.

That is why I assume the problem lies in sqlite, not in digikam itself.

regards,
Gerben

digikam
Qt: Locales not supported on X server
digikam: WARNING: sqlite_step error: unable to open database file on query: REPLACE into Settings VALUES ('Scanned','2007-08-27T12:28:30');


-----Oorspronkelijk bericht-----
Van:	owner@bugs.kde.org namens Gilles Caulier
Verzonden:	vr 24-aug-07 17:57
Aan:	Gerben Gieling
CC:	
Onderwerp:	[Bug 149165] cannot edit anymore - sqlite lock?   

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=149165         




------- Additional Comments From caulier.gilles gmail com  2007-08-24 17:57 -------
You can use sqlite command line tool, but it's not trivial.

Question : are you some debug/warning/errors message on the console when you start digiKam ?

Gilles Caulier
 
-----------------------------------------------------------------------
DISCLAIMER:
This message (including any attachments) is confidential and may be privileged. If you have received it by mistake please notify the sender by return e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited. Please note that e-mails are susceptible to change. Synthon shall not be liable for the improper or incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system. Synthon does not guarantee that the integrity of this communication has been maintained nor that this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of the company.
-----------------------------------------------------------------------
Comment 5 caulier.gilles 2007-08-27 20:00:03 UTC
Gerben,

The SQlite DB file used by digiKam is named 'digikam3.db. it plcaed on top of your albums library path. This file is in read only ? Try 'touch digikam3.db' for ex.

Are you update libsqlite library on your computer ?

Gilles Caulier
Comment 6 Gerben Gieling 2007-08-28 08:47:50 UTC
Yes,

I upgraded to 3.3.17 on 2007-06-23. The last time I edited the file it was in version 2.8.16.

The file digikam.db is not read only it is in chmod 666 (read/write for everyone)


Gerben


-----Oorspronkelijk bericht-----
Van:	owner@bugs.kde.org namens Gilles Caulier
Verzonden:	ma 27-aug-07 20:00
Aan:	Gerben Gieling
CC:	
Onderwerp:	[Bug 149165] cannot edit anymore - sqlite lock?   

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=149165         




------- Additional Comments From caulier.gilles gmail com  2007-08-27 20:00 -------
Gerben,

The SQlite DB file used by digiKam is named 'digikam3.db. it plcaed on top of your albums library path. This file is in read only ? Try 'touch digikam3.db' for ex.

Are you update libsqlite library on your computer ?

Gilles Caulier
 
-----------------------------------------------------------------------
DISCLAIMER:
This message (including any attachments) is confidential and may be privileged. If you have received it by mistake please notify the sender by return e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited. Please note that e-mails are susceptible to change. Synthon shall not be liable for the improper or incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system. Synthon does not guarantee that the integrity of this communication has been maintained nor that this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of the company.
-----------------------------------------------------------------------
Comment 7 Gerben Gieling 2007-09-07 12:06:03 UTC
Gilles,

Is it an option to
- dump the data of the current Digikam sqlite database
- move the current database to a different location
- let Digikam create a new database
- reload the old sqlite data into the new database.

If so, can you inform me how to proceed, I'm not familiar with sqlite.

Gerben
 
-----------------------------------------------------------------------
DISCLAIMER:
This message (including any attachments) is confidential and may be privileged. If you have received it by mistake please notify the sender by return e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited. Please note that e-mails are susceptible to change. Synthon shall not be liable for the improper or incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system. Synthon does not guarantee that the integrity of this communication has been maintained nor that this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of the company.
-----------------------------------------------------------------------
Comment 8 caulier.gilles 2008-12-04 16:27:39 UTC
Gerben,

What news about this entry, it still valid when you use digiKam 0.9.4 ?

Gilles Caulier
Comment 9 caulier.gilles 2008-12-04 17:58:08 UTC
Message from Gerben Gieling by private mail:

-----------------------------------------------------------------------

The problem was solved in a gentoo portage update followed by update
world.

Problem is, I don't know what part of the update world solved it.

Gerben

-----------------------------------------------------------------------

So, close this file now...

Gilles Caulier