Bug 148437 - Odd behaviour of the +q nicklist icon
Summary: Odd behaviour of the +q nicklist icon
Status: RESOLVED DUPLICATE of bug 153580
Alias: None
Product: konversation
Classification: Unclassified
Component: protocol (show other bugs)
Version: 1.0.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-02 00:36 UTC by Thern
Modified: 2013-04-15 03:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thern 2007-08-02 00:36:42 UTC
Version:           1.0.1 (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages

This applies to networks with ChanServ.

When a nick with Super-OP (SOP) status joins a channel they are assigned the +q nicklist icon.

Related bug 1:
the nick info pop-up (on mouse over in the nicklist) shows such nicks as having modes "Admin, Operator, Owner"

Related bug 2:
when such nicks change modes they nicklist will not reflect the mode change (e.g. they retain the +q icon even though they might be +v)

Quick Fix to both 1 & 2: /whois (but not /who) on such nicks updates both the pop-up and the icon.
Comment 1 argonel 2008-04-18 16:37:41 UTC
What network is this happening on?
Comment 2 Bartosz Kwitniewski 2008-05-19 17:48:10 UTC
I have same problem here. It is related to Inspire IRCd (www.inspircd.org). You can try to reproduce this bug on ChatSpike (dexter.chatspike.net:6667, stitch.chatspike.net:6667, www.chatspike.net) or my tiny server (astral.org.pl:6667).

- InspIRCd uses +a for channel admins.
- Konversation uses +p for channel admins (from Configure>Behavior>Nickname List), however it appears to have some kind of autodetection for other networks.

Some examples to reproduce:

Exemple nr 1:
--> You have joined the channel #Test
*** Channel modes: +nt
*** This channel was created on 05/19/2008 05:07:33 PM.
--> zOwner has joined this channel.
*** astral.org.pl sets mode: +qao zOwner zOwner zOwner
--> zAdmin has joined this channel.
*** astral.org.pl sets mode: +ao zAdmin zAdmin
[==> zAdmin has Owner icon now (wrong). <==]
[/whois zAdmin]
[==> zAdmin has Admin icon now (ok). <==]

Exemple nr 2:
--> You have joined the channel #Test
*** Channel modes: +nt
*** This channel was created on 05/19/2008 05:07:33 PM.
--> zOwner has joined this channel.
*** astral.org.pl sets mode: +qao zOwner zOwner zOwner
--> zAdmin has joined this channel.
*** astral.org.pl sets mode: +qao zAdmin zAdmin zAdmin
[==> zAdmin has Owner icon now (ok). <==]
*** astral.org.pl sets mode: -q zAdmin
[==> zAdmin has Admin icon now (ok). <==]

Exemple nr 3:
--> You have joined the channel #Test
*** Channel modes: +nt
*** This channel was created on 05/19/2008 05:07:33 PM.
--> zOwner has joined this channel.
*** astral.org.pl sets mode: +qao zOwner zOwner zOwner
--> zAdmin has joined this channel.
*** astral.org.pl sets mode: +ao zAdmin zAdmin
[==> zAdmin has Owner icon now (wrong). <==]
[/leave #Test]
[/join #Test]
[==> zAdmin has Admin icon now (ok). <==]

Exemple nr 4:
--> You have joined the channel #Test
*** Channel modes: +nt
*** This channel was created on 05/19/2008 05:07:33 PM.
--> zAdmin has joined this channel.
*** astral.org.pl sets mode: +ao zAdmin zAdmin
[==> zAdmin has Owner icon now (wrong). <==]
[/leave #Test]
[/join #Test]
[==> zAdmin has Admin icon now (ok). <==]

If You'd like a quick live demonstration using SAMODE, contact me at:
e-mail: zerg2000 (a) astral org pl
jabber: zerg2000 (a) jabber astral org pl
Comment 3 Eike Hein 2009-05-13 01:04:22 UTC
Bug #139591 may be related.
Comment 4 Eike Hein 2009-05-13 01:21:26 UTC
Possibly also related to bug #153580.
Comment 5 Eike Hein 2013-04-15 03:09:21 UTC

*** This bug has been marked as a duplicate of bug 153580 ***