Bug 148347 - KMail shortcuts "Go to next/previous message" do not work when a message is viewed in a window instead of the preview pane.
Summary: KMail shortcuts "Go to next/previous message" do not work when a message is v...
Status: RESOLVED DUPLICATE of bug 132089
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-30 01:29 UTC by Tero Pesonen
Modified: 2007-08-01 18:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tero Pesonen 2007-07-30 01:29:09 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

This is not a wish but a usability bug. It may be related to bug 96301.

In KMail, when a message is viewed in a window (after having double clicked on it, or pressed "enter"), the keyboard shortcuts for going to next or previous message are not usable in that message view any more.

The message view simply does not recognise them. If the user wants to read another message, the current window needs to closed or minimised, and the other message selected. So the "go to next message etc." shortcuts work only in select situations, not always. What is important, they do not work always when a message is shown. 

This is contrary to all other email apps out there. If a message on a list can be viewed in a separate window, the navigation keys remain functional in that message view. Which, of course, makes a lot of sense.

People who are used to reading all or some of their mail using a full message view find KMail unusable. I believe this would not brake anything if implemented, i.e. enabling this functionally should not affect existing usage habits.
Comment 1 Thomas McGuire 2007-08-01 18:28:36 UTC

*** This bug has been marked as a duplicate of 132089 ***