Bug 148166 - leave tags tree (right sidebar) as set when closing digikam
Summary: leave tags tree (right sidebar) as set when closing digikam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-TreeView (show other bugs)
Version: 0.9.3
Platform: openSUSE RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-24 16:23 UTC by Daniel Bauer
Modified: 2017-07-29 05:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bauer 2007-07-24 16:23:19 UTC
Version:           0.9.3 svn (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

When closing a tags tree in right sidebar), the next time I start digiKam its open again. In fact, every time I start digikam all tags are displayed in the sidebar with an open tree. I'd like to have my "tree view" saved, so that when I open digikam the next time it displays the same as when I closed digikam.

(I have many many tags, grouped in trees and subtrees. Having them all open makes it hard to find the needed tags - i.e. I alsways have to close all unused trees first...).

kind regards

Daniel
Comment 1 Mathias Lindner 2008-09-22 16:40:50 UTC
Two additional buttons "open complete tree" and "close complete tree" would also help. And/ or a setting to display the tree opened/ closed/ in the last view when starting digiKam.
Comment 2 caulier.gilles 2008-12-05 12:42:33 UTC
Andi, 

i remember that you have implemented something like this with album tree view. Right ?

Gilles Caulier
Comment 3 Andi Clemens 2008-12-05 12:59:33 UTC
No not really, this was for collapsing the tree when using quickfilter search on the folder list (but the patch might be used for this).

I wanted to fix this issue here some time ago, but it wasn't that easy.
The same issue was reported in another bugreport, I will search for it and mark this one here a a duplicate.

Andi
Comment 4 Andi Clemens 2008-12-05 13:19:24 UTC
I found the bug, but it is not a duplicate of it: bug 161988

Now I can remember what was wrong with those folder views, they contain CheckListItems which are not capable to deliver some values that a FolderItem does (I don't right now what it was), and so they are not saved correctly on exit. When starting digiKam, those views are always fully expanded.

I will take a look at this again...

Andi
Comment 5 Andi Clemens 2009-02-01 13:19:36 UTC
SVN commit 919579 by aclemens:

Fix saveViewState() for folderviews with CheckListItems, like
TAlbumListView and TagFilterView.

With current implementation, we are not able to have one common
loadViewState() and saveViewState() method, so we need to re-implement
them in TAlbumListView and TagFilterView. This is not nice because we
have duplicate code now, but since we are going to switch to ModelView
concept next release, it would be a waste of time to create a new common
interface or abstract class now.

We can not call virtual methods in constructors / destructors, so every
view inherited from FolderView needs to call saveViewState() in its own
destructor instead.

BUG:148166

 M  +2 -0      digikam/albumfolderview.cpp  
 M  +1 -1      digikam/folderview.cpp  
 M  +72 -1     digikam/tagfilterview.cpp  
 M  +5 -1      digikam/tagfilterview.h  
 M  +3 -1      digikam/tagfolderview.cpp  
 M  +6 -2      libs/imageproperties/imagedescedittab.cpp  
 M  +71 -1     libs/imageproperties/talbumlistview.cpp  
 M  +7 -1      libs/imageproperties/talbumlistview.h  
 M  +3 -1      utilities/fuzzysearch/fuzzysearchfolderview.cpp  
 M  +3 -1      utilities/gpssearch/gpssearchfolderview.cpp  
 M  +4 -2      utilities/searchwindow/searchfolderview.cpp  
 M  +3 -1      utilities/timeline/timelinefolderview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=919579
Comment 6 Andi Clemens 2009-02-01 17:00:29 UTC
SVN commit 919759 by aclemens:

backport commit #919579 from KDE4 trunk

CCBUG:148166

 M  +2 -0      digikam/albumfolderview.cpp  
 M  +2 -2      digikam/folderview.cpp  
 M  +8 -6      digikam/searchfolderview.cpp  
 M  +73 -1     digikam/tagfilterview.cpp  
 M  +7 -3      digikam/tagfilterview.h  
 M  +3 -1      digikam/tagfolderview.cpp  
 M  +5 -3      digikam/timelinefolderview.cpp  
 M  +4 -3      digikam/timelinefolderview.h  
 M  +6 -2      libs/imageproperties/imagedescedittab.cpp  
 M  +1 -0      libs/imageproperties/imagedescedittab.h  
 M  +73 -2     libs/imageproperties/talbumlistview.cpp  
 M  +7 -1      libs/imageproperties/talbumlistview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=919759