Bug 148138 - crash while starting kontact
Summary: crash while starting kontact
Status: RESOLVED DUPLICATE of bug 148172
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-23 14:22 UTC by Christo
Modified: 2007-08-05 16:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christo 2007-07-23 14:22:13 UTC
Version:           Unbekannt (using KDE 3.5.7 "release 60.1" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.18.8-0.5-default

no idea why .. since last update kontact crashes at startup :-( 

tnx4support

-c-

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47570299184704 (LWP 4180)]
[New Thread 1107310912 (LWP 4188)]
[New Thread 1098918208 (LWP 4187)]
[New Thread 1090525504 (LWP 4186)]
[New Thread 1082132800 (LWP 4185)]
[KCrash handler]
#5  0x00002b43cc6e6e92 in QGDict::hashKeyString ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#6  0x00002b43cc6e7d0e in QGDict::look_string ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#7  0x00002b43cd2687cd in KCal::Calendar::incidence ()
   from /opt/kde3/lib64/libkcal.so.2
#8  0x00002b43cd2847d7 in KCal::ICalFormatImpl::populate ()
   from /opt/kde3/lib64/libkcal.so.2
#9  0x00002b43cd27a7a4 in KCal::ICalFormat::fromRawString ()
   from /opt/kde3/lib64/libkcal.so.2
#10 0x00002b43cd27ad9b in KCal::ICalFormat::load ()
   from /opt/kde3/lib64/libkcal.so.2
#11 0x00002b43cd29d602 in KCal::FileStorage::load ()
   from /opt/kde3/lib64/libkcal.so.2
#12 0x00002b43cd26dbb6 in KCal::CalendarLocal::load ()
   from /opt/kde3/lib64/libkcal.so.2
#13 0x00002b43cd2a0750 in KCal::ResourceLocal::doLoad ()
   from /opt/kde3/lib64/libkcal.so.2
#14 0x00002b43cd29fe18 in KCal::ResourceCalendar::load ()
   from /opt/kde3/lib64/libkcal.so.2
#15 0x00002b43cd2a9ec6 in KCal::CalendarResources::load ()
   from /opt/kde3/lib64/libkcal.so.2
#16 0x00002b43d6e6dcec in SummaryWidget::SummaryWidget ()
   from /opt/kde3/lib64/kde3/libkontact_korganizerplugin.so
#17 0x00002b43d6e670f6 in KOrganizerPlugin::createSummaryWidget ()
   from /opt/kde3/lib64/kde3/libkontact_korganizerplugin.so
#18 0x00002b43d9a41fc9 in SummaryViewPart::updateWidgets ()
   from /opt/kde3/lib64/kde3/libkontact_summaryplugin.so
#19 0x00002b43d9a432d9 in SummaryViewPart::SummaryViewPart ()
   from /opt/kde3/lib64/kde3/libkontact_summaryplugin.so
#20 0x00002b43d9a3fb2e in SummaryView::createPart ()
   from /opt/kde3/lib64/kde3/libkontact_summaryplugin.so
#21 0x00002b43c9f115e9 in Kontact::Plugin::part ()
   from /opt/kde3/lib64/libkpinterfaces.so.1
#22 0x0000000000418380 in Kontact::MainWindow::selectPlugin ()
#23 0x0000000000416e1c in Kontact::MainWindow::activatePluginModule ()
#24 0x0000000000414fe2 in KontactApp::newInstance ()
#25 0x00002b43cbc1c78d in KUniqueApplication::processDelayed ()
   from /opt/kde3/lib64/libkdecore.so.4
#26 0x00002b43cbc229c8 in KUniqueApplication::qt_invoke ()
   from /opt/kde3/lib64/libkdecore.so.4
#27 0x00002b43cc47859c in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x00002b43cc75dd02 in QSignal::signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#29 0x00002b43cc491025 in QSignal::activate ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#30 0x00002b43cc497638 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#31 0x00002b43cc421425 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#32 0x00002b43cc422057 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#33 0x00002b43cbc0a168 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#34 0x00002b43cc417a6f in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#35 0x00002b43cc3d779d in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#36 0x00002b43cc435fd3 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#37 0x00002b43cc435e82 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#38 0x0000000000415455 in main ()
Comment 1 Thomas McGuire 2007-07-24 23:53:05 UTC

*** This bug has been marked as a duplicate of 148172 ***
Comment 2 Christo 2007-08-05 16:00:34 UTC
I wont agree that this issue is a duplicate of 148172 .. i have notroubles with   libkcal at all .. it just stopped working using latest KDE-susebuilt .. my kalendar works great 

CLIENT: Task: Task::done()
CLIENT: Task: emitting finished
QGDict::hashKeyString: Invalid null key
DCOP aborting (delayed) call from 'anonymous-4901' to 'kontact'
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
ERROR: Communication problem with kontact, it probably crashed.
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
KCrash: Application 'kontact' crashing...
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)