Bug 148048 - Message display errors of multipart mime messages if mail contains different encodings for diffirent parts
Summary: Message display errors of multipart mime messages if mail contains different ...
Status: RESOLVED DUPLICATE of bug 91393
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-20 10:09 UTC by Gappy
Modified: 2007-07-20 16:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of display error (68.27 KB, image/png)
2007-07-20 10:11 UTC, Gappy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gappy 2007-07-20 10:09:27 UTC
Version:           KMail 1.9.5 (Using KDE 3.5.5) (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
Compiler:          gcc-Version 3.4.6 (Gentoo 3.4.6-r2, ssp-3.4.6-1.0, pie-8.7.10) CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
OS:                Linux

The mail contains a text that is ISO-8859-15 encoded and a vcard that is UTF-8 encoded.
KMail displays the mail correctly with ISO-8859-15 but the vcard is displayed wrong.
It seems that KMail uses also ISO-8859-15 for the vcard instead of UTF-8.
-> Two Byte UTF-8 chars are displayed as two characters.
e.g. "ä" instead of "ä"

I guess KMail has a limitation of displaying two different encodings in one mail.

The mail was sent by Mozilla Thunderbird.

Here are the snippets of the MIME headers:

This is a multi-part message in MIME format.
--------------070608020208060209090802
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

Text...

--------------070608020208060209090802
Content-Type: text/x-vcard; charset=utf-8;
 name="christian.zugfil.vcf"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
 filename="name.surname.vcf"

The vcard...
Comment 1 Gappy 2007-07-20 10:11:21 UTC
Created attachment 21199 [details]
Screenshot of display error
Comment 2 Thomas McGuire 2007-07-20 16:31:34 UTC

*** This bug has been marked as a duplicate of 91393 ***