Bug 148011 - Wrong Hebrew text translation: deleting recurring events
Summary: Wrong Hebrew text translation: deleting recurring events
Status: RESOLVED FIXED
Alias: None
Product: i18n
Classification: Frameworks and Libraries
Component: he (show other bugs)
Version: 3.5
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Diego Iastrubni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-19 09:12 UTC by Dotan Cohen
Modified: 2008-08-14 22:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot with corrected text (24.96 KB, image/png)
2008-06-30 17:35 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2007-07-19 09:12:52 UTC
Version:           1.2.4 (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

When deleting a recurring event in Kontact, I am presented with three options (translated form Hebrew):
1) Delete the current event
2) Delete the current event
3) Delete 1%
4) Cancel

I believe that either option 1 or 2 is mistranslated.
Comment 1 Thomas McGuire 2007-07-19 17:45:41 UTC
The english version in KDE 3.5.7 is indeed correct.
What is the language code (usually two letters) for Hebrew? I need that to move this report to the proper component.
Comment 2 Dotan Cohen 2007-07-19 23:17:28 UTC
Thanks, Thomas. The Hebrew language code seems to be 'he', according to locale:
LANG=he_IL.UTF-8

However, the keyboard layout in Kcontrol is 'il'.
Comment 3 Diego Iastrubni 2007-07-23 11:21:56 UTC
‎Thomas, I found this issue a few days ago (while cleanning my calendar, due to fact that academic year is over ). However, the catalog manager canno find the string I am seeing on screen. I tried a simple grep on whole KDE, and still could not find that string.

I checked out the PO's from: https://svn.kde.org/home/kde/branches/stable/l10n/he/messages, and using the latest revision. In what file should I count that string? (and yes the language code for hebrew is he).

Dotan, what distro are you using? what kde-i18n-he version are you using?
Comment 4 Dotan Cohen 2007-07-23 22:49:25 UTC
I'm currently on Ubuntu, I'm not sure how to determine the kde-i18n-he version. What I wrote was a translation of the text, as I assumed that a Hebrew speaker would make the correction. And I did not want to put gibberish for the non-Hebrew speakers who would probably read this. The repeated string is (without the quotes):
"מחק את המופע הנוכחי"

For a screenshot:
http://dotancohen.com/images/examples/kde-hebrew-typo.png
Comment 5 Marek Laane 2007-07-24 01:02:05 UTC
As it is seemingly from KOrganizer, so maybe it has smth to do with these strings?
#: calendarview.cpp:1982
msgid ""
"The calendar item \"%1\" recurs over multiple dates; are you sure you want to "
"delete it and all its recurrences?
(and following... - sorry, I cant hebrew for helping properly, so it's just my opinion for origin of strings)
Comment 6 Dotan Cohen 2007-07-24 08:19:53 UTC
Marek, yes, it seems logical that those strings should be found nearby the strings that I'm referring to.
Comment 7 Thomas McGuire 2007-07-25 00:01:20 UTC
I don't know anything about translations.

The code however ( http://websvn.kde.org/branches/KDE/3.5/kdepim/korganizer/calendarview.cpp?revision=654061&view=markup ) looks correct.

No idea where the problem is exactly, sorry.
Comment 8 Marek Laane 2007-07-25 00:53:45 UTC
Yeah, it seems to be related to the translation, either in KDE or in Ubuntu (don't know if there are some additional Hebrew translators "bettering" KDE's translations in Ubuntu but some languages has had such problems...)
Comment 9 Dotan Cohen 2007-07-25 05:42:54 UTC
The relevant part of the code looks fine:

  if ( !force ) {
    km=KMessageBox::questionYesNoCancel( this,
                                i18n("The item \"%1\" has sub-to-dos. "
                                     "Do you want to delete just this item and "
                                     "make all its sub-to-dos independent, or "
                                     "delete the to-do with all its sub-to-dos?"
                                ).arg( todo->summary() ),
                                i18n("KOrganizer Confirmation"),
                                i18n("Delete Only This"),
                                i18n("Delete All"));
  }


So it's likely the translation. Note that the string "The item \"%1\" has sub-to-dos. " actually includes the %1, that is, %1 is not parsed.
Comment 10 Marek Laane 2007-07-26 00:13:20 UTC
And relevant part of http://websvn.kde.org/branches/stable/l10n/he/messages/kdepim/korganizer.po?revision=692101&view=markup seems also to be correct... Weird... Maybe smth Ubuntu untroduced?
Comment 11 Marek Laane 2007-08-02 23:27:04 UTC
Just an idea: maybe there is smth wrong how Kontact uses Korganizer? Is the same phenomenon apparent when using Korganizer as standalone or only when using in Kontact?
Comment 12 Marek Laane 2007-09-09 01:39:29 UTC
Some news about it? Did somebody find something about it?
Comment 13 Dotan Cohen 2008-01-06 07:30:18 UTC
The Ubuntu bug is here:
https://bugs.launchpad.net/ubuntu/+source/meta-kde/+bug/128451

Marek Laane, can you confirm this problem? On what KDE version, and on what distro? Thanks.
Comment 14 Marek Laane 2008-01-08 00:52:09 UTC
Well, using Estonian on Mandriva's KDE (Kontact 1.2.4 (enterprise 0.20071123.740460)), I've four options: Delete current, Delete Future, Delete all and Cancel. 
Comment 15 Dotan Cohen 2008-06-30 17:35:21 UTC
Created attachment 25737 [details]
Screenshot with corrected text

Here is an image of the incorrect dialog, with corrected text below (it's all
in Hebrew). I use this image to remind myself which button to push whenever I
need to erase something.
Comment 16 Diego Iastrubni 2008-08-13 09:13:50 UTC
Shalom Dotan,

I cannot reproduce this bug under 4.2 trunk, so I assume also 4.1 is not affected since I have not touched those translations since they forked from 3.5.

Now as for Mandriva, I have kde-i18n-he-3.5.9-1mdv2008.1 which displays this correctly. I also run "rpm -qV kde-i18n-he-3.5.9-1mdv2008.1" to verify that I was not playing with the mo files, and here korganizer looks perfect (well, at least that bug is not reproducable).

This looks like a bug in the distro, or your installation and this not a valid bug report for this bugzilla. We can continue debugging this in private if you want, but not here. 
Comment 17 Dotan Cohen 2008-08-14 22:21:17 UTC
Thank you Diego. Coincidentally or not, within hours of your message the downstream (Kubuntu) bug had a fix released. I will test it in Kubuntu when I get a chance. Thanks.