Bug 147947 - On crash created messages don't save
Summary: On crash created messages don't save
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2007-07-17 11:09 UTC by Andrey Cherepanov
Modified: 2009-06-15 10:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Cherepanov 2007-07-17 11:09:49 UTC
Version:           1.9.7 (using KDE 3.5.7, ALT Linux i586)
Compiler:          Target: i586-alt-linux
OS:                Linux (i686) release 2.6.18-wks-smp-alt2

In older version of KMail if application is crashed, all new (created by user) messages are saved and restore on next KMail start. Now on crash these messages don't restored.
Comment 1 Thomas McGuire 2007-07-17 12:40:52 UTC
I can not reproduce.
I tried crashing KMail using the "kill window" shortcut while composing a message. After restarting KMail, the composer window opened, showing the old message.
Are you using IMAP?

Anyway, I suspect this is the same as bug 98116.
Comment 2 Andrey Cherepanov 2007-07-17 12:53:06 UTC
I cannot use IMAP at all. What file contains composed message on crash?
Comment 3 Thomas McGuire 2007-07-17 12:59:11 UTC
On Tuesday 17 July 2007, Andrey Cherepanov wrote:
> I cannot use IMAP at all. What file contains composed message on crash?

That message should be in $HOME/.kde/share/apps/kmail/autosave/cur
But it probably isn't in your case, since you said it is not working.
Comment 4 Andrey Cherepanov 2007-07-17 13:17:26 UTC
Composed message doesn't save to this folder immediately, only 1 minute (!) later. If message stored in this folder, it restores on crash without problem.

Please, make autosave less that 1 min (minimal interval of autosave in composer settings).
Comment 5 Reinhold Kainhofer 2007-10-24 00:30:58 UTC
I also encountered this problem a few times. Most of the time, kmail correctly restores messages I was composing before a crash, but sometimes, none of them are restored. I have not found a way to reproduce the problem, but I confirm it's there.
Comment 6 Thomas McGuire 2008-01-19 19:51:34 UTC
See also bug 156190.
Comment 7 Dominik Tritscher 2009-04-05 10:39:54 UTC
Did you test this with a recent version of kmail? I can't reproduce that with kmail 1.11.90 from trunk.
Comment 8 Christophe Giboudeaux 2009-06-14 23:39:54 UTC
No feedback for two monthes (comment #7). Changing the bug status.
Comment 9 Andrey Cherepanov 2009-06-15 10:44:44 UTC
I close this bug. Need wait at least one autosave for message.