Bug 147792 - Composer does not handle unknown characters with incorrect encoding correctly
Summary: Composer does not handle unknown characters with incorrect encoding correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Unclassified
Component: composer (show other bugs)
Version: 1.9.5
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2007-07-11 19:14 UTC by Hauke Laging
Modified: 2009-08-17 19:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
one of the emails which trigger the buggy behaviour (2.22 KB, text/plain)
2007-07-15 15:33 UTC, Hauke Laging
Details
screenshot (2.93 KB, image/png)
2007-07-15 15:33 UTC, Hauke Laging
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hauke Laging 2007-07-11 19:14:01 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs

When I receive an email without character set definition then kmail shows an rectangle for each unknown character. That's OK for me but the editor doesn't handle these correctly. It seems the editor sees less characters in that line than it shows. This makes it quite difficult to erase or correct the problematic characters. Pressing the end of line key does not put the cursor at the end but somewhere within the last word (depending on the count of problematic characters in that line).
Comment 1 Thomas McGuire 2007-07-15 14:57:22 UTC
Could you please attach such a mail here?
Make sure you remove personal things from it first.
Comment 2 Hauke Laging 2007-07-15 15:33:00 UTC
Created attachment 21157 [details]
one of the emails which trigger the buggy behaviour

The requested file.
Comment 3 Hauke Laging 2007-07-15 15:33:56 UTC
Created attachment 21158 [details]
screenshot

This screen shot shows the cursor position after positioning it logically at
the end of the line.
Comment 4 Hauke Laging 2007-07-15 15:34:55 UTC
Sure. I have just removed email addresses. I have modified the file with kate. In kate the problematic charachters look different. There is a space and the next character is deleted. I hope kate has not changed anything to these characters. I have not checked that with a hex editor.

I also attach a screen shot of the reply window. Please note the cursor position. It is positioned at the ("logical") end of the line. Pressing backspace five times erases everything up to (including) the "t". The cursor is displayed two chars before the end of line. In that case it is displayed between the next "t" and the left rectangle. Pressing backspace again erases the right rectangle but does not move he cursor, reducing the difference between "logical" and "physical" end of line to one character.
Comment 5 Thomas McGuire 2007-07-15 21:32:32 UTC
Hmm, with your mail I can not reproduce the problem. There are strange characters shown, but they don't cause the problems you describe.

Maybe editing the file with Kate messed things up indeed.
You can check that yourself by downloading your email from this bug report again and saving it somewhere under $HOME/.kde/share/apps/kmail/mail/[..]/cur
It should then show up under KMail in that folder. Try replying and see if the problem is still there. If not, then the problem went away after editing the file with Kate.

If the problem still occurs with the mail attached here, you should try upgrading KMail to the lastest version.
Comment 6 Michael Leupold 2009-04-05 10:49:04 UTC
I can't reproduce on trunk r948809 either. I'm unsure if the encoding got messed up, after all I still see some gibberish characters.
Comment 7 Martin Koller 2009-08-17 19:40:56 UTC
let's close it then