Bug 147775 - Kmail crashes with a find message process running and cannot be restarted
Summary: Kmail crashes with a find message process running and cannot be restarted
Status: RESOLVED DUPLICATE of bug 127188
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-11 06:28 UTC by chris
Modified: 2007-07-11 10:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2007-07-11 06:28:21 UTC
Version:           1.9.1 (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

I'm running KMail 1.9.1 in KDE 3.5.1 level "a" on Suse 10.1.
I started a Find Messages... process from the Tools menu. The process ran for a few minutes and then crashed KMail. Every time I now open KMail the process seems to restart immediately and within a minute or so crashes KMail. I am unable to get any other function running within KMail such as checking mail so I am forced to use web mail to deal with my mail at the moment. How can I stop the search function so that KMail becomes usable. I have tried rebooting the box but to no avail. The backtrace reads:

(I have removed the multiple (no debugging symbols found) lines)
Using host libthread_db library "/lib64/libthread_db.so.1".

[Thread debugging using libthread_db enabled]
[New Thread 47783456678992 (LWP 4705)]
[New Thread 1107310912 (LWP 4709)]
[New Thread 1098918208 (LWP 4708)]
[New Thread 1090525504 (LWP 4707)]
[New Thread 1082132800 (LWP 4706)]
(no debugging symbols found)

(no debugging symbols found)
[KCrash handler]
#5  0x00002b756d72e221 in KMMessage::asDwString ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002b756d758719 in KMMessage::asString ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002b756d925490 in KMSearchRuleString::matches ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002b756d7400bf in KMSearchPattern::matches ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002b756d870f30 in KMSearchPattern::matches ()
   from /opt/kde3/lib64/libkmailprivate.so
#10 0x00002b756d87132f in FolderStorage::slotProcessNextSearchBatch ()
   from /opt/kde3/lib64/libkmailprivate.so
#11 0x00002b756d871500 in FolderStorage::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#12 0x00002b756d8715dd in KMFolderIndex::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#13 0x00002b756d8715f9 in KMFolderMaildir::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#14 0x00002b756e4107ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#15 0x00002b756e6f2308 in QSignal::signal ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#16 0x00002b756e4292b5 in QSignal::activate ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#17 0x00002b756e42f8d8 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#18 0x00002b756e3b9985 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#19 0x00002b756e3ba5b7 in QApplication::notify ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#20 0x00002b756ddbc708 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#21 0x00002b756e3afef5 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#22 0x00002b756e3704bd in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#23 0x00002b756e3ce6a1 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#24 0x00002b756e3ce54a in QEventLoop::exec ()
   from /usr/lib/qt3/lib64//libqt-mt.so.3
#25 0x000000000040296d in ?? ()
#26 0x00002b756ec24154 in __libc_start_main () from /lib64/libc.so.6
#27 0x00000000004026f9 in ?? ()
#28 0x00007fff3d6cd0d8 in ?? ()
#29 0x0000000000000000 in ?? ()
Comment 1 Tommi Tervo 2007-07-11 10:04:17 UTC

*** This bug has been marked as a duplicate of 127188 ***