Bug 147723 - filtering outgoing mail is done after the mail is actually sent, rendering the feature partially useless
Summary: filtering outgoing mail is done after the mail is actually sent, rendering th...
Status: RESOLVED DUPLICATE of bug 48938
Alias: None
Product: kmail
Classification: Unclassified
Component: filtering (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-10 00:45 UTC by Imre Péntek
Modified: 2007-07-10 18:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Imre Péntek 2007-07-10 00:45:59 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-16-generic

I set a filter: settings->configure filters
My (only one) dummy filter looks like this:
filter criteria: match all the following
<size> > 1 byte
<size> > 2 byte
filter actions:
set transport to: the name of one of my sending accounts (differing from the default one)
Advanced options:
Apply this filter to sent messages

When sending the X-KMail-Transport: header gets overridden correctly, but the mail is sent via the default SMTP server. This is why I think applying the filters after sending the mail (at least) partially renders the feature useless.
By the way the checkbox named properly: "Apply this filter to sent messages", as stated above there is reason to name this checkbox e.g. "Apply this filter to outgoing mails", and act accordingly.

By the way my favourite MUA is still KMail, so thank you for providing this nice software.
Comment 1 Thomas McGuire 2007-07-10 18:57:47 UTC

*** This bug has been marked as a duplicate of 48938 ***