Bug 147454 - kdm_greet: Internal error: memory corruption detected
Summary: kdm_greet: Internal error: memory corruption detected
Status: RESOLVED NOT A BUG
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-02 15:13 UTC by S. Umar
Modified: 2008-05-19 17:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kdm.log with valgrind (14.52 KB, text/plain)
2007-07-02 16:39 UTC, S. Umar
Details
messages file showing the message (968 bytes, text/plain)
2007-07-02 16:40 UTC, S. Umar
Details
test patch (680 bytes, patch)
2007-07-02 16:59 UTC, Oswald Buddenhagen
Details
new kdm.log (13.98 KB, text/plain)
2007-07-02 18:09 UTC, S. Umar
Details
new messages (201.14 KB, text/plain)
2007-07-02 18:09 UTC, S. Umar
Details
kdm.log with -debug 0x800 (608.65 KB, text/plain)
2007-07-06 15:47 UTC, S. Umar
Details
another test patch (434 bytes, patch)
2007-07-06 16:17 UTC, Oswald Buddenhagen
Details
messages file created with -debug 0x40f (148.05 KB, text/plain)
2007-07-06 17:16 UTC, S. Umar
Details
kdm.log with valgrind (10.52 KB, text/plain)
2007-07-06 17:16 UTC, S. Umar
Details
Try again... (21.47 KB, text/plain)
2007-07-06 17:39 UTC, S. Umar
Details
gdb output for kdm_greet (2.46 KB, text/plain)
2007-07-08 19:04 UTC, S. Umar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Umar 2007-07-02 15:13:22 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Fedora RPMs
Compiler:          gcc-4.1.2 
OS:                Linux

every time kdm_greet is invoked I get a message in my /var/log/messages
file like:

        kdm_greet[28386]: Internal error: memory corruption detected

Otherwise everything seems to work fine. I looked in the code and the
statement seems to originate from some check on /tmp/ and HOME environment
variables in the cleanup code. I am not a c programmer so I did not exactly
understand what and why I am getting this error. I was not getting it with
KDE 3.5.6. As you can imagine such a statement really worries some users!
Thanks
Comment 1 Oswald Buddenhagen 2007-07-02 15:25:13 UTC
little surprisingly, the reason for this statement *is* worrisome. a false positive is possible, but relatively improbable, given that the code did not change in years.
please terminate kdm and restart it with -debug 0x40f. mail me the resulting /var/log/kdm.log and the output of the daemon.* syslog facility.
you will need to install valgrind first. if available, install debug packages for kdm, kdelibs and qt.
Comment 2 S. Umar 2007-07-02 15:53:02 UTC
Here are some more facts:

I have 5 machines and they are ALL giving this error after upgrading to 3.5.7.
Four of the machines are x86_64 and one is i386. I will try to do some of the
stuff you suggested and let you know.
Thanks
Comment 3 S. Umar 2007-07-02 16:39:43 UTC
Created attachment 21015 [details]
kdm.log with valgrind
Comment 4 S. Umar 2007-07-02 16:40:17 UTC
Created attachment 21016 [details]
messages file showing the message
Comment 5 S. Umar 2007-07-02 16:42:58 UTC
Some more info: I have used Fedora rpms with release 3.5.7 and also rebuilt the
rpms by updating from 3.5 SVN branch. They both give the same error.
Comment 6 Oswald Buddenhagen 2007-07-02 16:59:21 UTC
Created attachment 21017 [details]
test patch

nothing unusual in the valgrind log.
your syslog definitely does not contain daemon.debug.
as you are able to rebuild, please apply the attached patch and run with -debug
7.
Comment 7 S. Umar 2007-07-02 18:08:27 UTC
I have done all of the above:

1. Running valgrind
2. Recompiled kdebase with the above patch AND installed the .debug
   package as well.
3. Restarted kdm with -debug 0x40f.

I am attaching files. Let me know if I have to run with -debug 7...
Comment 8 S. Umar 2007-07-02 18:09:31 UTC
Created attachment 21019 [details]
new kdm.log
Comment 9 S. Umar 2007-07-02 18:09:51 UTC
Created attachment 21020 [details]
new messages
Comment 10 Oswald Buddenhagen 2007-07-02 18:27:18 UTC
so for some reason $HOME is reset ... no idea why. it ain't good in any case.
you could place some more Debug() statements in main() and kg_main() to localize the culprit.

btw, you posted your password in the log ... the 0x8 debug bit is not particularly selective about what it prints.
Comment 11 S. Umar 2007-07-02 18:36:22 UTC
Bummer....now I have to change the nice password!

Can you send me a patch for more debug statements otherwise I will try
to figure it out after lunch.
Thanks
Comment 12 Oswald Buddenhagen 2007-07-02 18:40:54 UTC
yeah, the pipe dumping mode is pretty talkative, that's why i reduced debug to 7 when i realized that it would not help anyway.

i'd prefer it if you do it yourself, incrementally adding more statements when you get closer to the critical point. i don't think you'll have a problem implementing that. :)
Comment 13 S. Umar 2007-07-02 20:58:39 UTC
I am trying...I am a fortran programmer to bare with me. I think I found
something funny. I put the following debug statements around atexit:

        Debug( "savhome @ startup-1: %'s\n$HOME: %'s\n", savhome, getenv( "HOME" ) );
        atexit( cleanup );
        Debug( "savhome @ startup-2: %'s\n$HOME: %'s\n", savhome, getenv( "HOME" ) );

Here, I get in the log message:

    savhome @ startup-1: '/tmp/1105252278'
    $HOME: '/tmp/1105252278'
    savhome @ startup-2: '/tmp/1105252278'
    $HOME: '/tmp/1105252278'

So, before and after atexit (cleanup) the savhome is the same. However, inside
the cleanup we get:

     savhome @ exit: '/tmp/1105252278'
     $HOME: '/root'

Could it be that atexit() is goes out of the program environement for getenv()?
     
Comment 14 Oswald Buddenhagen 2007-07-02 21:04:44 UTC
atexit() adds an exit handler, as one look into the man page would have revealed. ;)

no need to output savhome - we already know that it stays constant.
first check $HOME at the start and end of kg_main(), then bisect further.
Comment 15 S. Umar 2007-07-02 21:38:46 UTC
I filled up kg_main with Debug statements. Initiall HOME is NULL upto the
statement:
.....
  okay:
        if (setenv( "HOME", qtrc, 1 ))
.....

after this it is the correct /tmp/.... value all the way to:
        kg_main( argv[0] );
statement. Right after this statement HOME=/root  (before RETURN EX_NORMAL)
Comment 16 Oswald Buddenhagen 2007-07-02 21:42:53 UTC
hmm? you "filled" main(), not kg_main().
but now we know that the reset *does* happen within kg_main(), which isn't the worst possible news. you can continue from here. :-P
Comment 17 S. Umar 2007-07-02 22:13:27 UTC
OK. In kgapp.cpp, kg_main this is were the change happens:

        Debug( " HOME in kg_main -3:%'s\n", getenv( "HOME" ) );
        GreeterApp app;
        Debug( " HOME in kg_main -4:%'s\n", getenv( "HOME" ) );

Statement before gives '/tmp/0846599094', statement after gives '/root'.
Comment 18 Oswald Buddenhagen 2007-07-02 22:14:37 UTC
ok, i can work with that. thanks so far ...
Comment 19 Nadav Kavalerchik 2007-07-04 23:37:46 UTC
i think i have the same issue.
i can't login remotely but i can login locally.
(it's very important to us, because we use KDE in an LTSP environment)
i get the same error in daemon.log
:-(

after upgrade from fc6 to fc7 (kde 3.5.7-0.1-fc7)
Comment 20 S. Umar 2007-07-05 18:17:56 UTC
There are many blogs discussing this issue but no solution:

   https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/47455
   http://mepislovers.org/forums/archive/index.php/t-7562.html

Ubuntu and Fedora seem to be one of the common denominators.
Comment 21 Oswald Buddenhagen 2007-07-05 19:53:00 UTC
bah, i *thought* i can work with this.
for some reason, the KApplication constructor is resetting $HOME to the value from /etc/passwd or maybe just the value at program startup (kdm.log from a run with -debug 0x800 should clear that up - make sure that you have strace installed). And i have no idea why ...
Comment 22 Nadav Kavalerchik 2007-07-05 20:33:16 UTC
here is my kdm debug output (using debug level 7)
trying to login from a remote terminal as user pc22

Jul  5 21:17:36 server kdm[2663]: select returns 2
Jul  5 21:17:36 server kdm[2663]: select returns 2
Jul  5 21:17:36 server kdm[2663]: manager wait returns  pid 4236  sig 0  core 0  code 33
Jul  5 21:17:36 server kdm[2663]: display exited with EX_RESERVER_DPY
Jul  5 21:17:36 server kdm[2663]: ExitDisplay ws022:0, endState = 0, serverCmd = 1, GoodExit = 1
Jul  5 21:17:36 server kdm[2663]: stopping display ws022:0 to state 0
Jul  5 21:17:36 server kdm[2663]: Removing display ws022:0
Jul  5 21:17:36 server kdm[4248]: execute: /usr/bin/kdm_config  ; CONINFO=16 21
Jul  5 21:17:36 server kdm[2663]: started config reader ("/usr/bin/kdm_config"), pid 4248
Jul  5 21:17:36 server kdm[2663]: getter now ready
Jul  5 21:17:36 server kdm_config[4248]: getting global config
Jul  5 21:17:36 server kdm_config[4248]: reading config /usr/share/config/kdm/kdmrc ...
Jul  5 21:17:36 server kdm_config[4248]: getting values for section class [General]
Jul  5 21:17:36 server kdm_config[4248]: line 54: ConfigVersion = '2.3'
Jul  5 21:17:36 server kdm_config[4248]: default: PAMService = 'kdm'
Jul  5 21:17:36 server kdm_config[4248]: line 58: StaticServers = ':0'
Jul  5 21:17:36 server kdm_config[4248]: line 61: ReserveServers = ':1,:2,:3'
Jul  5 21:17:36 server kdm_config[4248]: line 66: ServerVTs = '-7'
Jul  5 21:17:36 server kdm_config[4248]: line 69: ConsoleTTYs = 'tty1,tty2,tty3,tty4,tty5,tty6'
Jul  5 21:17:36 server kdm_config[4248]: line 72: PidFile = '/var/run/kdm.pid'
Jul  5 21:17:36 server kdm_config[4248]: default: LockPidFile = 'true'
Jul  5 21:17:36 server kdm_config[4248]: default: AuthDir = '/var/run/xauth'
Jul  5 21:17:36 server kdm_config[4248]: default: AutoRescan = 'true'
Jul  5 21:17:36 server kdm_config[4248]: default: ExportList = ''
Jul  5 21:17:36 server kdm_config[4248]: default: RandomDevice = ''
Jul  5 21:17:36 server kdm_config[4248]: default: FifoDir = '/var/run/xdmctl'
Jul  5 21:17:36 server kdm_config[4248]: default: FifoGroup = '0'
Jul  5 21:17:36 server kdm_config[4248]: default: DataDir = '/var/lib/kdm'
Jul  5 21:17:36 server kdm_config[4248]: default: DmrcDir = ''
Jul  5 21:17:36 server kdm_config[4248]: getting values for section class [Xdmcp]
Jul  5 21:17:36 server kdm_config[4248]: line 113: Enable = 'true'
Jul  5 21:17:36 server kdm_config[4248]: default: Port = '177'
Jul  5 21:17:36 server kdm_config[4248]: default: KeyFile = ''
Jul  5 21:17:36 server kdm_config[4248]: default: ChoiceTimeout = '15'
Jul  5 21:17:36 server kdm_config[4248]: default: RemoveDomainname = 'true'
Jul  5 21:17:36 server kdm_config[4248]: default: SourceAddress = 'false'
Jul  5 21:17:36 server kdm_config[4248]: default: Willing = ''
Jul  5 21:17:36 server kdm_config[4248]: getting values for section class [Shutdown]
Jul  5 21:17:36 server kdm_config[4248]: line 145: HaltCmd = '/sbin/poweroff'
Jul  5 21:17:36 server kdm_config[4248]: default: RebootCmd = '/sbin/reboot'
Jul  5 21:17:36 server kdm_config[4248]: default: AllowFifo = 'false'
Jul  5 21:17:36 server kdm_config[4248]: default: AllowFifoNow = 'true'
Jul  5 21:17:36 server kdm_config[4248]: line 162: BootManager = 'Grub'
Jul  5 21:17:36 server kdm[2663]: ScanServers
Jul  5 21:17:36 server kdm[2663]: found existing local display: :0 (null)
Jul  5 21:17:36 server kdm[2663]: found existing local reserve display: :1 (null)
Jul  5 21:17:36 server kdm[2663]: found existing local reserve display: :2 (null)
Jul  5 21:17:36 server kdm[2663]: found existing local reserve display: :3 (null)
Jul  5 21:17:36 server kdm[2663]: ScanAccessDatabase
Jul  5 21:17:36 server kdm_config[4248]: getting values for section class [General]
Jul  5 21:17:36 server kdm_config[4248]: getting values for section class [Xdmcp]
Jul  5 21:17:36 server kdm_config[4248]: line 122: Xaccess = '/etc/X11/xdm/Xaccess'
Jul  5 21:17:36 server kdm[2663]: closed config reader
Jul  5 21:17:36 server kdm[2663]: getter now closed
Jul  5 21:17:36 server kdm[2663]: select returns 1
Jul  5 21:17:37 server kdm[2663]: select returns 1
Jul  5 21:17:37 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:37 server kdm[2663]: header: 1 2 1
Jul  5 21:17:37 server kdm[2663]: <query> respond 1
Jul  5 21:17:37 server kdm[2663]: ConvertAddr returning 0 for family 10
Jul  5 21:17:37 server kdm[2663]: all_query_respond: conntype=0, addr=4: c0 a8 0a 16
Jul  5 21:17:37 server kdm[2663]: ScanAccessDatabase
Jul  5 21:17:37 server kdm[2663]: send <willing> (null) Willing to manage
Jul  5 21:17:40 server kdm[2663]: select returns 1
Jul  5 21:17:40 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:40 server kdm[2663]: header: 1 7 92
Jul  5 21:17:40 server kdm[2663]: <request> respond 92
Jul  5 21:17:40 server kdm[2663]: FindProtoDisplay
Jul  5 21:17:40 server kdm[2663]: NewProtoDisplay
Jul  5 21:17:40 server kdm[2663]: NewProtoDisplay 0x091caad8
Jul  5 21:17:40 server kdm[2663]: got 0x091cb250 (18 MIT-MAGIC-COOKIE-1)
Jul  5 21:17:40 server kdm[2663]: <accept> session ID 53008011
Jul  5 21:17:40 server kdm[2663]: select returns 1
Jul  5 21:17:40 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:40 server kdm[2663]: header: 1 10 23
Jul  5 21:17:40 server kdm[2663]: <manage> 23
Jul  5 21:17:40 server kdm[2663]: FindProtoDisplay
Jul  5 21:17:40 server kdm[2663]: <manage> session ID 53008011, pdpy 0x091caad8
Jul  5 21:17:40 server kdm[2663]: computed display name: ws022:0
Jul  5 21:17:40 server kdm[2663]: created new display ws022:0
Jul  5 21:17:40 server kdm[2663]: ConvertAddr returning 0 for family 10
Jul  5 21:17:40 server kdm[2663]: starting display ws022:0,MIT-unspecified
Jul  5 21:17:40 server kdm[4249]: execute: /usr/bin/kdm_config  ; CONINFO=16 21
Jul  5 21:17:40 server kdm[2663]: started config reader ("/usr/bin/kdm_config"), pid 4249
Jul  5 21:17:40 server kdm[2663]: getter now ready
Jul  5 21:17:40 server kdm_config[4249]: getting config for display ws022:0, class MIT-unspecified
Jul  5 21:17:40 server kdm_config[4249]: reading config /usr/share/config/kdm/kdmrc ...
Jul  5 21:17:40 server kdm_config[4249]: getting values for section class [-Core]
Jul  5 21:17:40 server kdm_config[4249]: default: OpenDelay = '15'
Jul  5 21:17:40 server kdm_config[4249]: default: OpenTimeout = '120'
Jul  5 21:17:40 server kdm_config[4249]: default: OpenRepeat = '5'
Jul  5 21:17:40 server kdm_config[4249]: default: StartAttempts = '4'
Jul  5 21:17:40 server kdm_config[4249]: default: ServerAttempts = '1'
Jul  5 21:17:40 server kdm_config[4249]: default: ServerTimeout = '15'
Jul  5 21:17:40 server kdm_config[4249]: default: ServerCmd = '/usr/bin/X -br'
Jul  5 21:17:40 server kdm_config[4249]: default: ServerArgsLocal = ''
Jul  5 21:17:40 server kdm_config[4249]: default: ServerArgsRemote = ''
Jul  5 21:17:40 server kdm_config[4249]: default: ServerVT = '0'
Jul  5 21:17:40 server kdm_config[4249]: default: PingInterval = '5'
Jul  5 21:17:40 server kdm_config[4249]: default: PingTimeout = '5'
Jul  5 21:17:40 server kdm_config[4249]: default: TerminateServer = 'false'
Jul  5 21:17:40 server kdm_config[4249]: default: ResetSignal = '1'
Jul  5 21:17:40 server kdm_config[4249]: default: TermSignal = '15'
Jul  5 21:17:40 server kdm_config[4249]: default: Authorize = 'true'
Jul  5 21:17:40 server kdm_config[4249]: default: AuthNames = 'MIT-MAGIC-COOKIE-1'
Jul  5 21:17:40 server kdm_config[4249]: default: ResetForAuth = 'false'
Jul  5 21:17:40 server kdm_config[4249]: default: AuthFile = ''
Jul  5 21:17:40 server kdm_config[4249]: default: Resources = ''
Jul  5 21:17:40 server kdm_config[4249]: default: Xrdb = '/usr/bin/xrdb'
Jul  5 21:17:40 server kdm_config[4249]: line 214: *:*_*/Setup = '/etc/X11/xdm/Xsetup_0'
Jul  5 21:17:40 server kdm_config[4249]: default: Startup = ''
Jul  5 21:17:40 server kdm_config[4249]: default: Reset = ''
Jul  5 21:17:40 server kdm_config[4249]: line 225: *:*_*/Session = '/etc/kde/kdm/Xsession'
Jul  5 21:17:40 server kdm_config[4249]: line 228: *:*_*/FailsafeClient = '/usr/X11R6/bin/xterm'
Jul  5 21:17:40 server kdm_config[4249]: default: UserPath = '/usr/local/bin:/usr/bin:/bin:/usr/bin:/usr/games'
Jul  5 21:17:40 server kdm_config[4249]: default: SystemPath = '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin'
Jul  5 21:17:40 server kdm_config[4249]: line 237: *:*_*/SystemShell = '/bin/bash'
Jul  5 21:17:40 server kdm_config[4249]: default: UserAuthDir = '/tmp'
Jul  5 21:17:40 server kdm_config[4249]: line 245: *:*_*/AutoReLogin = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 247: *:*_*/AllowRootLogin = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 249: *:*_*/AllowNullPasswd = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 255: *:*_*/AllowShutdown = 'None'
Jul  5 21:17:40 server kdm_config[4249]: default: AllowSdForceNow = 'All'
Jul  5 21:17:40 server kdm_config[4249]: default: DefaultSdMode = 'Schedule'
Jul  5 21:17:40 server kdm_config[4249]: default: ScheduledSd = 'Never'
Jul  5 21:17:40 server kdm_config[4249]: line 290: *:*_*/NoPassEnable = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 291: *:*_*/NoPassUsers = 'science,math,internet,konqi,bible,office,talmid,classview,pc1,pc2,pc3,pc4,pc5,pc6,pc7,pc8,pc9,pc10,pc11,pc12,pc13,pc14,pc15,pc16,pc17,pc18,pc19,pc20,pc21,pc22,pc23,pc24,pc25,pc26,pc27,pc28,pc29,pc30,pc31,pc32,pc33,pc34,pc35,pc36,pc37,pc38,pc39,pc40,pc41,pc42,pc43,pc44,pc45,pc46,pc47,pc48,pc49,pc50'
Jul  5 21:17:40 server kdm_config[4249]: line 289: *:*_*/AutoLoginEnable = 'true'
Jul  5 21:17:40 server kdm_config[4249]: default: AutoLoginAgain = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 288: *:*_*/AutoLoginDelay = '5'
Jul  5 21:17:40 server kdm_config[4249]: line 674: ws022:0_*/AutoLoginUser = 'pc22'
Jul  5 21:17:40 server kdm_config[4249]: default: AutoLoginPass = ''
Jul  5 21:17:40 server kdm_config[4249]: default: AutoLoginLocked = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 277: *:*_*/SessionsDirs = '/usr/share/xsessions'
Jul  5 21:17:40 server kdm_config[4249]: line 281: *:*_*/ClientLogFile = '.xsession-errors-%s'
Jul  5 21:17:40 server kdm_config[4249]: default: UseSessReg = 'true'
Jul  5 21:17:40 server kdm_config[4249]: getting values for section class [-Greeter]
Jul  5 21:17:40 server kdm_config[4249]: default: GUIStyle = ''
Jul  5 21:17:40 server kdm_config[4249]: line 464: *:*_*/ColorScheme = 'FedoraFlyingHigh'
Jul  5 21:17:40 server kdm_config[4249]: line 307: *:*_*/LogoArea = 'Logo'
Jul  5 21:17:40 server kdm_config[4249]: line 310: *:*_*/LogoPixmap = '/usr/share/apps/kdm/pics/kdelogo.png'
Jul  5 21:17:40 server kdm_config[4249]: default: GreeterPos = '50,50'
Jul  5 21:17:40 server kdm_config[4249]: default: GreeterScreen = '0'
Jul  5 21:17:40 server kdm_config[4249]: line 331: *:*_*/GreetString = '\327\221\327\250\327\225\327\233\327\231\327\235 \327\224\327\221\327\220\327\231\327\235 \327\220\327\234 %s \327\221%n'
Jul  5 21:17:40 server kdm_config[4249]: line 343: *:*_*/AntiAliasing = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 334: *:*_*/GreetFont = 'Sans,16,-1,5,75,0,0,0,0,0'
Jul  5 21:17:40 server kdm_config[4249]: line 337: *:*_*/StdFont = 'Sans,10,-1,5,50,0,0,0,0,0'
Jul  5 21:17:40 server kdm_config[4249]: line 340: *:*_*/FailFont = 'Sans,12,-1,5,75,0,0,0,0,0'
Jul  5 21:17:40 server kdm_config[4249]: default: NumLock = 'Keep'
Jul  5 21:17:40 server kdm_config[4249]: default: Language = 'en_US'
Jul  5 21:17:40 server kdm_config[4249]: default: UserCompletion = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 358: *:*_*/UserList = 'false'
Jul  5 21:17:40 server kdm_config[4249]: default: ShowUsers = 'NotHidden'
Jul  5 21:17:40 server kdm_config[4249]: default: SelectedUsers = ''
Jul  5 21:17:40 server kdm_config[4249]: line 377: *:*_*/HiddenUsers = 'adm,alias,amanda,apache,bin,bind,daemon,exim,falken,ftp,games,gdm,gopher,halt,httpd,ident,ingres,kmem,lp,mail,mailnull,man,mta,mysql,named,news,nfsnobody,nobody,nscd,ntp,operator,pcap,pop,postfix,postgres,qmaild,qmaill,qmailp,qmailq,qmailr,qmails,radvd,reboot,rpc,rpcuser,rpm,sendmail,shutdown,squid,sympa,sync,tty,uucp,xfs,xten'
Jul  5 21:17:40 server kdm_config[4249]: line 381: *:*_*/MinShowUID = '500'
Jul  5 21:17:40 server kdm_config[4249]: line 384: *:*_*/MaxShowUID = '65530'
Jul  5 21:17:40 server kdm_config[4249]: default: SortUsers = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 365: *:*_*/FaceSource = 'PreferUser'
Jul  5 21:17:40 server kdm_config[4249]: default: FaceDir = '/usr/share/apps/kdm/faces'
Jul  5 21:17:40 server kdm_config[4249]: line 403: *:*_*/PreselectUser = 'Default'
Jul  5 21:17:40 server kdm_config[4249]: line 676: ws022:0_*/DefaultUser = 'pc22'
Jul  5 21:17:40 server kdm_config[4249]: line 407: *:*_*/FocusPasswd = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 413: *:*_*/EchoMode = 'OneStar'
Jul  5 21:17:40 server kdm_config[4249]: line 416: *:*_*/UseBackground = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 419: *:*_*/BackgroundCfg = '/etc/kde/kdm/backgroundrc'
Jul  5 21:17:40 server kdm_config[4249]: default: GrabServer = 'false'
Jul  5 21:17:40 server kdm_config[4249]: default: GrabTimeout = '3'
Jul  5 21:17:40 server kdm_config[4249]: default: AuthComplain = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 466: *:*_*/LoginMode = 'DefaultLocal'
Jul  5 21:17:40 server kdm_config[4249]: default: ChooserHosts = '*'
Jul  5 21:17:40 server kdm_config[4249]: line 435: *:*_*/ForgingSeed = '1108476160'
Jul  5 21:17:40 server kdm_config[4249]: default: PluginsLogin = 'classic'
Jul  5 21:17:40 server kdm_config[4249]: default: PluginsShutdown = 'classic'
Jul  5 21:17:40 server kdm_config[4249]: default: PluginOptions = ''
Jul  5 21:17:40 server kdm_config[4249]: default: AllowConsole = 'true'
Jul  5 21:17:40 server kdm_config[4249]: line 465: *:*_*/AllowClose = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 456: *:*_*/Preloader = '/usr/bin/preloadkde'
Jul  5 21:17:40 server kdm_config[4249]: default: UseTheme = 'false'
Jul  5 21:17:40 server kdm_config[4249]: line 462: *:*_*/Theme = '/usr/share/apps/kdm/themes/circles'
Jul  5 21:17:40 server kdm[2663]: StartDisplay ws022:0, try 1
Jul  5 21:17:40 server kdm[2663]: file: /var/run/xauth/Aws022:0-TIKPxl  auth: 0x091cab68
Jul  5 21:17:40 server kdm[2663]: forking session
Jul  5 21:17:40 server kdm: ws022:0[4250]: before XOpenDisplay(ws022:0)
Jul  5 21:17:40 server kdm[2663]: forked session, pid 4250
Jul  5 21:17:40 server kdm[2663]: closed config reader
Jul  5 21:17:40 server kdm[2663]: getter now closed
Jul  5 21:17:40 server kdm[2663]: select returns 1
Jul  5 21:17:40 server kdm: ws022:0[4250]: after XOpenDisplay(ws022:0)
Jul  5 21:17:40 server kdm: ws022:0[4250]: got remote address ws022:0 16
Jul  5 21:17:40 server kdm: ws022:0[4250]: ManageSession ws022:0
Jul  5 21:17:40 server kdm: ws022:0[4250]: autoLogon, tdiff = -11, rLogin = 0, goodexit = 1, nuser = (null)
Jul  5 21:17:40 server kdm: ws022:0[4250]: starting greeter for display ws022:0
Jul  5 21:17:40 server kdm: ws022:0[4251]: execute: /usr/bin/kdm_greet ; DISPLAY=ws022:0 DM_CONTROL=/var/run/xdmctl XAUTHORITY=/var/run/xauth/Aws022:0-TIKPxl PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin SHELL=/bin/bash CONINFO=7 10 24 27
Jul  5 21:17:40 server kdm: ws022:0[4250]: started greeter for display ws022:0 ("/usr/bin/kdm_greet"), pid 4251
Jul  5 21:17:40 server kdm_greet[4251]: SecureDisplay ws022:0
Jul  5 21:17:40 server kdm_greet[4251]: Before XGrabServer ws022:0
Jul  5 21:17:40 server kdm_greet[4251]: XGrabServer succeeded ws022:0
Jul  5 21:17:40 server kdm_greet[4251]: pseudoReset screen 0
Jul  5 21:17:40 server kdm_greet[4251]: before XSync
Jul  5 21:17:40 server kdm_greet[4251]: pseudoReset done
Jul  5 21:17:40 server kdm_greet[4251]: done secure ws022:0
Jul  5 21:17:40 server kdm: ws022:0[4250]: G_SetupDpy
Jul  5 21:17:40 server kdm: ws022:0[4250]: source /etc/X11/xdm/Xsetup_0
Jul  5 21:17:40 server kdm: ws022:0[4253]: execute: /etc/X11/xdm/Xsetup_0 ; DISPLAY=ws022:0 DM_CONTROL=/var/run/xdmctl XAUTHORITY=/var/run/xauth/Aws022:0-TIKPxl PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin SHELL=/bin/bash
Jul  5 21:17:40 server kdm: ws022:0[4250]: G_Ready
Jul  5 21:17:40 server kdm: ws022:0[4250]: greeter for display ws022:0 ready
Jul  5 21:17:40 server kdm: ws022:0[4250]: ManageSession, greeting, tdiff = -11
Jul  5 21:17:40 server kdm_greet[4251]: GreeterPlugin classic (Username + password (classic)) loaded
Jul  5 21:17:40 server kdm_greet[4251]: new greet_classic
Jul  5 21:17:40 server kdm_greet[4251]: greet_classic->presetEntity("pc22", 0)
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic->start()
Jul  5 21:17:41 server kdm_greet[4251]: entering event loop
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_ReadDmrc
Jul  5 21:17:41 server kdm: ws022:0[4250]:  user "pc22"
Jul  5 21:17:41 server kdm: ws022:0[4250]:  -> status 0
Jul  5 21:17:41 server kdm: ws022:0[4250]:  => "[Desktop]\nSession=custom\n"
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_GetDmrc
Jul  5 21:17:41 server kdm: ws022:0[4250]:  key "Session"
Jul  5 21:17:41 server kdm: ws022:0[4250]:  -> "custom"
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic->next()
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugActivity()
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugSetUser("pc22")
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_ReadDmrc
Jul  5 21:17:41 server kdm: ws022:0[4250]:  user "pc22"
Jul  5 21:17:41 server kdm: ws022:0[4250]:  -> status 0
Jul  5 21:17:41 server kdm: ws022:0[4250]:  => keeping old
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_GetDmrc
Jul  5 21:17:41 server kdm: ws022:0[4250]:  key "Session"
Jul  5 21:17:41 server kdm: ws022:0[4250]:  -> "custom"
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugActivity()
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugActivity()
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugStart()
Jul  5 21:17:41 server kdm_greet[4251]: handleVerify ...
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_Verify
Jul  5 21:17:41 server kdm: ws022:0[4250]:  type "classic"
Jul  5 21:17:41 server kdm: ws022:0[4250]: Verify ...
Jul  5 21:17:41 server kdm_greet[4251]:  V_GET_TEXT
Jul  5 21:17:41 server kdm_greet[4251]:   prompt NULL
Jul  5 21:17:41 server kdm_greet[4251]:   echo = 1
Jul  5 21:17:41 server kdm_greet[4251]:   ndelay = 0
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic->textPrompt(...)
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugReturnText("pc22", 2)
Jul  5 21:17:41 server kdm_greet[4251]: handleVerify ...
Jul  5 21:17:41 server kdm_greet[4251]:  V_GET_TEXT
Jul  5 21:17:41 server kdm_greet[4251]:   prompt NULL
Jul  5 21:17:41 server kdm_greet[4251]:   echo = 0
Jul  5 21:17:41 server kdm_greet[4251]:   ndelay = 1
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic->textPrompt(...)
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugReturnText("<masked>", 5)
Jul  5 21:17:41 server kdm_greet[4251]: handleVerify ...
Jul  5 21:17:41 server kdm: ws022:0[4250]:  PAM service kdm-np
Jul  5 21:17:41 server kdm: ws022:0[4250]:  pam_authenticate() ...
Jul  5 21:17:41 server kdm: ws022:0[4250]:  pam_authenticate() returned: Success
Jul  5 21:17:41 server kdm: ws022:0[4250]: restrict pc22 ...
Jul  5 21:17:41 server kdm: ws022:0[4250]:  pam_acct_mgmt() ...
Jul  5 21:17:41 server kdm: ws022:0[4250]:  pam_acct_mgmt() returned: Success
Jul  5 21:17:41 server kdm: ws022:0[4250]:  -> return success
Jul  5 21:17:41 server kdm_greet[4251]:  V_OK
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic->succeeded()
Jul  5 21:17:41 server kdm_greet[4251]: greet_classic: gplugActivity()
Jul  5 21:17:41 server kdm: ws022:0[4250]: G_Ready
Jul  5 21:17:41 server kdm_greet[4251]: left event loop
Jul  5 21:17:41 server kdm_greet[4251]: delete greet_classic
Jul  5 21:17:41 server kdm_greet[4251]: Unsecure display ws022:0
Jul  5 21:17:41 server kdm_greet[4251]: Internal error: memory corruption detected
Jul  5 21:17:41 server kdm: ws022:0[4250]: closed greeter for display ws022:0
Jul  5 21:17:41 server kdm: ws022:0[4250]: greeter for ws022:0 stopped
Jul  5 21:17:41 server kdm[2663]: select returns 2
Jul  5 21:17:41 server kdm[2663]: select returns 2
Jul  5 21:17:41 server kdm[2663]: manager wait returns  pid 4250  sig 11  core 0  code 0
Jul  5 21:17:41 server kdm[2663]: Unknown session exit code 0 (sig 11) from manager process
Jul  5 21:17:41 server kdm[2663]: ExitDisplay ws022:0, endState = 4, serverCmd = 0, GoodExit = 0
Jul  5 21:17:41 server kdm[2663]: stopping display ws022:0 to state 4
Jul  5 21:17:41 server kdm[2663]: Removing display ws022:0
Jul  5 21:17:42 server kdm[2663]: select returns 1
Jul  5 21:17:42 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:42 server kdm[2663]: header: 1 2 1
Jul  5 21:17:42 server kdm[2663]: <query> respond 1
Jul  5 21:17:42 server kdm[2663]: ConvertAddr returning 0 for family 10
Jul  5 21:17:42 server kdm[2663]: all_query_respond: conntype=0, addr=4: c0 a8 0a 16
Jul  5 21:17:42 server kdm[2663]: send <willing> (null) Willing to manage
Jul  5 21:17:44 server kdm[2663]: select returns 1
Jul  5 21:17:44 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:44 server kdm[2663]: header: 1 7 92
Jul  5 21:17:44 server kdm[2663]: <request> respond 92
Jul  5 21:17:44 server kdm[2663]: FindProtoDisplay
Jul  5 21:17:44 server kdm[2663]: NewProtoDisplay
Jul  5 21:17:44 server kdm[2663]: NewProtoDisplay 0x091caad8
Jul  5 21:17:44 server kdm[2663]: got 0x091cb250 (18 MIT-MAGIC-COOKIE-1)
Jul  5 21:17:44 server kdm[2663]: <accept> session ID 53008012
Jul  5 21:17:44 server kdm[2663]: select returns 1
Jul  5 21:17:44 server kdm[2663]: ProcessRequestSocket
Jul  5 21:17:44 server kdm[2663]: header: 1 10 23
Jul  5 21:17:44 server kdm[2663]: <manage> 23
Jul  5 21:17:44 server kdm[2663]: FindProtoDisplay
Jul  5 21:17:44 server kdm[2663]: <manage> session ID 53008012, pdpy 0x091caad8
Jul  5 21:17:44 server kdm[2663]: computed display name: ws022:0
Jul  5 21:17:44 server kdm[2663]: created new display ws022:0
Jul  5 21:17:44 server kdm[2663]: ConvertAddr returning 0 for family 10
Jul  5 21:17:44 server kdm[2663]: starting display ws022:0,MIT-unspecified
Jul  5 21:17:44 server kdm[4260]: execute: /usr/bin/kdm_config  ; CONINFO=16 21
Jul  5 21:17:44 server kdm[2663]: started config reader ("/usr/bin/kdm_config"), pid 4260
Jul  5 21:17:44 server kdm[2663]: getter now ready
Jul  5 21:17:44 server kdm_config[4260]: getting config for display ws022:0, class MIT-unspecified
Jul  5 21:17:44 server kdm_config[4260]: reading config /usr/share/config/kdm/kdmrc ...
Jul  5 21:17:44 server kdm_config[4260]: getting values for section class [-Core]
Jul  5 21:17:44 server kdm_config[4260]: default: OpenDelay = '15'
Jul  5 21:17:44 server kdm_config[4260]: default: OpenTimeout = '120'
Jul  5 21:17:44 server kdm_config[4260]: default: OpenRepeat = '5'
Jul  5 21:17:44 server kdm_config[4260]: default: StartAttempts = '4'
Jul  5 21:17:44 server kdm_config[4260]: default: ServerAttempts = '1'
Jul  5 21:17:44 server kdm_config[4260]: default: ServerTimeout = '15'
Jul  5 21:17:44 server kdm_config[4260]: default: ServerCmd = '/usr/bin/X -br'
Jul  5 21:17:44 server kdm_config[4260]: default: ServerArgsLocal = ''
Jul  5 21:17:44 server kdm_config[4260]: default: ServerArgsRemote = ''
Jul  5 21:17:44 server kdm_config[4260]: default: ServerVT = '0'
Jul  5 21:17:44 server kdm_config[4260]: default: PingInterval = '5'
Jul  5 21:17:44 server kdm_config[4260]: default: PingTimeout = '5'
Jul  5 21:17:44 server kdm_config[4260]: default: TerminateServer = 'false'
Jul  5 21:17:44 server kdm_config[4260]: default: ResetSignal = '1'
Jul  5 21:17:44 server kdm_config[4260]: default: TermSignal = '15'
Jul  5 21:17:44 server kdm_config[4260]: default: Authorize = 'true'
Jul  5 21:17:44 server kdm_config[4260]: default: AuthNames = 'MIT-MAGIC-COOKIE-1'
Jul  5 21:17:44 server kdm_config[4260]: default: ResetForAuth = 'false'
Jul  5 21:17:44 server kdm_config[4260]: default: AuthFile = ''
Jul  5 21:17:44 server kdm_config[4260]: default: Resources = ''
Jul  5 21:17:44 server kdm_config[4260]: default: Xrdb = '/usr/bin/xrdb'
Jul  5 21:17:44 server kdm_config[4260]: line 214: *:*_*/Setup = '/etc/X11/xdm/Xsetup_0'
Jul  5 21:17:44 server kdm_config[4260]: default: Startup = ''
Jul  5 21:17:44 server kdm_config[4260]: default: Reset = ''
Jul  5 21:17:44 server kdm_config[4260]: line 225: *:*_*/Session = '/etc/kde/kdm/Xsession'
Jul  5 21:17:44 server kdm_config[4260]: line 228: *:*_*/FailsafeClient = '/usr/X11R6/bin/xterm'
Jul  5 21:17:44 server kdm_config[4260]: default: UserPath = '/usr/local/bin:/usr/bin:/bin:/usr/bin:/usr/games'
Jul  5 21:17:44 server kdm_config[4260]: default: SystemPath = '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin'
Jul  5 21:17:44 server kdm_config[4260]: line 237: *:*_*/SystemShell = '/bin/bash'
Jul  5 21:17:44 server kdm_config[4260]: default: UserAuthDir = '/tmp'
Jul  5 21:17:44 server kdm_config[4260]: line 245: *:*_*/AutoReLogin = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 247: *:*_*/AllowRootLogin = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 249: *:*_*/AllowNullPasswd = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 255: *:*_*/AllowShutdown = 'None'
Jul  5 21:17:44 server kdm_config[4260]: default: AllowSdForceNow = 'All'
Jul  5 21:17:44 server kdm_config[4260]: default: DefaultSdMode = 'Schedule'
Jul  5 21:17:44 server kdm_config[4260]: default: ScheduledSd = 'Never'
Jul  5 21:17:44 server kdm_config[4260]: line 290: *:*_*/NoPassEnable = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 291: *:*_*/NoPassUsers = 'science,math,internet,konqi,bible,office,talmid,classview,pc1,pc2,pc3,pc4,pc5,pc6,pc7,pc8,pc9,pc10,pc11,pc12,pc13,pc14,pc15,pc16,pc17,pc18,pc19,pc20,pc21,pc22,pc23,pc24,pc25,pc26,pc27,pc28,pc29,pc30,pc31,pc32,pc33,pc34,pc35,pc36,pc37,pc38,pc39,pc40,pc41,pc42,pc43,pc44,pc45,pc46,pc47,pc48,pc49,pc50'
Jul  5 21:17:44 server kdm_config[4260]: line 289: *:*_*/AutoLoginEnable = 'true'
Jul  5 21:17:44 server kdm_config[4260]: default: AutoLoginAgain = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 288: *:*_*/AutoLoginDelay = '5'
Jul  5 21:17:44 server kdm_config[4260]: line 674: ws022:0_*/AutoLoginUser = 'pc22'
Jul  5 21:17:44 server kdm_config[4260]: default: AutoLoginPass = ''
Jul  5 21:17:44 server kdm_config[4260]: default: AutoLoginLocked = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 277: *:*_*/SessionsDirs = '/usr/share/xsessions'
Jul  5 21:17:44 server kdm_config[4260]: line 281: *:*_*/ClientLogFile = '.xsession-errors-%s'
Jul  5 21:17:44 server kdm_config[4260]: default: UseSessReg = 'true'
Jul  5 21:17:44 server kdm_config[4260]: getting values for section class [-Greeter]
Jul  5 21:17:44 server kdm_config[4260]: default: GUIStyle = ''
Jul  5 21:17:44 server kdm_config[4260]: line 464: *:*_*/ColorScheme = 'FedoraFlyingHigh'
Jul  5 21:17:44 server kdm_config[4260]: line 307: *:*_*/LogoArea = 'Logo'
Jul  5 21:17:44 server kdm_config[4260]: line 310: *:*_*/LogoPixmap = '/usr/share/apps/kdm/pics/kdelogo.png'
Jul  5 21:17:44 server kdm_config[4260]: default: GreeterPos = '50,50'
Jul  5 21:17:44 server kdm_config[4260]: default: GreeterScreen = '0'
Jul  5 21:17:44 server kdm_config[4260]: line 331: *:*_*/GreetString = '\327\221\327\250\327\225\327\233\327\231\327\235 \327\224\327\221\327\220\327\231\327\235 \327\220\327\234 %s \327\221%n'
Jul  5 21:17:44 server kdm_config[4260]: line 343: *:*_*/AntiAliasing = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 334: *:*_*/GreetFont = 'Sans,16,-1,5,75,0,0,0,0,0'
Jul  5 21:17:44 server kdm_config[4260]: line 337: *:*_*/StdFont = 'Sans,10,-1,5,50,0,0,0,0,0'
Jul  5 21:17:44 server kdm_config[4260]: line 340: *:*_*/FailFont = 'Sans,12,-1,5,75,0,0,0,0,0'
Jul  5 21:17:44 server kdm_config[4260]: default: NumLock = 'Keep'
Jul  5 21:17:44 server kdm_config[4260]: default: Language = 'en_US'
Jul  5 21:17:44 server kdm_config[4260]: default: UserCompletion = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 358: *:*_*/UserList = 'false'
Jul  5 21:17:44 server kdm_config[4260]: default: ShowUsers = 'NotHidden'
Jul  5 21:17:44 server kdm_config[4260]: default: SelectedUsers = ''
Jul  5 21:17:44 server kdm_config[4260]: line 377: *:*_*/HiddenUsers = 'adm,alias,amanda,apache,bin,bind,daemon,exim,falken,ftp,games,gdm,gopher,halt,httpd,ident,ingres,kmem,lp,mail,mailnull,man,mta,mysql,named,news,nfsnobody,nobody,nscd,ntp,operator,pcap,pop,postfix,postgres,qmaild,qmaill,qmailp,qmailq,qmailr,qmails,radvd,reboot,rpc,rpcuser,rpm,sendmail,shutdown,squid,sympa,sync,tty,uucp,xfs,xten'
Jul  5 21:17:44 server kdm_config[4260]: line 381: *:*_*/MinShowUID = '500'
Jul  5 21:17:44 server kdm_config[4260]: line 384: *:*_*/MaxShowUID = '65530'
Jul  5 21:17:44 server kdm_config[4260]: default: SortUsers = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 365: *:*_*/FaceSource = 'PreferUser'
Jul  5 21:17:44 server kdm_config[4260]: default: FaceDir = '/usr/share/apps/kdm/faces'
Jul  5 21:17:44 server kdm_config[4260]: line 403: *:*_*/PreselectUser = 'Default'
Jul  5 21:17:44 server kdm_config[4260]: line 676: ws022:0_*/DefaultUser = 'pc22'
Jul  5 21:17:44 server kdm_config[4260]: line 407: *:*_*/FocusPasswd = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 413: *:*_*/EchoMode = 'OneStar'
Jul  5 21:17:44 server kdm_config[4260]: line 416: *:*_*/UseBackground = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 419: *:*_*/BackgroundCfg = '/etc/kde/kdm/backgroundrc'
Jul  5 21:17:44 server kdm_config[4260]: default: GrabServer = 'false'
Jul  5 21:17:44 server kdm_config[4260]: default: GrabTimeout = '3'
Jul  5 21:17:44 server kdm_config[4260]: default: AuthComplain = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 466: *:*_*/LoginMode = 'DefaultLocal'
Jul  5 21:17:44 server kdm_config[4260]: default: ChooserHosts = '*'
Jul  5 21:17:44 server kdm_config[4260]: line 435: *:*_*/ForgingSeed = '1108476160'
Jul  5 21:17:44 server kdm_config[4260]: default: PluginsLogin = 'classic'
Jul  5 21:17:44 server kdm_config[4260]: default: PluginsShutdown = 'classic'
Jul  5 21:17:44 server kdm_config[4260]: default: PluginOptions = ''
Jul  5 21:17:44 server kdm_config[4260]: default: AllowConsole = 'true'
Jul  5 21:17:44 server kdm_config[4260]: line 465: *:*_*/AllowClose = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 456: *:*_*/Preloader = '/usr/bin/preloadkde'
Jul  5 21:17:44 server kdm_config[4260]: default: UseTheme = 'false'
Jul  5 21:17:44 server kdm_config[4260]: line 462: *:*_*/Theme = '/usr/share/apps/kdm/themes/circles'
Jul  5 21:17:44 server kdm[2663]: StartDisplay ws022:0, try 1
Jul  5 21:17:44 server kdm[2663]: file: /var/run/xauth/Aws022:0-WYwEj3  auth: 0x091cab68
Jul  5 21:17:44 server kdm[2663]: forking session
Jul  5 21:17:44 server kdm: ws022:0[4261]: before XOpenDisplay(ws022:0)
Jul  5 21:17:44 server kdm[2663]: forked session, pid 4261
Jul  5 21:17:44 server kdm[2663]: closed config reader
Jul  5 21:17:44 server kdm[2663]: getter now closed
Jul  5 21:17:44 server kdm[2663]: select returns 1
Jul  5 21:17:44 server kdm: ws022:0[4261]: after XOpenDisplay(ws022:0)
Jul  5 21:17:44 server kdm: ws022:0[4261]: got remote address ws022:0 16
Jul  5 21:17:44 server kdm: ws022:0[4261]: ManageSession ws022:0
Jul  5 21:17:44 server kdm: ws022:0[4261]: autoLogon, tdiff = -12, rLogin = 0, goodexit = 0, nuser = (null)
Jul  5 21:17:44 server kdm: ws022:0[4261]: starting greeter for display ws022:0
Jul  5 21:17:44 server kdm: ws022:0[4262]: execute: /usr/bin/kdm_greet ; DISPLAY=ws022:0 DM_CONTROL=/var/run/xdmctl XAUTHORITY=/var/run/xauth/Aws022:0-WYwEj3 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin SHELL=/bin/bash CONINFO=7 10 24 27
Jul  5 21:17:44 server kdm: ws022:0[4261]: started greeter for display ws022:0 ("/usr/bin/kdm_greet"), pid 4262
Jul  5 21:17:44 server kdm_greet[4262]: SecureDisplay ws022:0
Jul  5 21:17:44 server kdm_greet[4262]: Before XGrabServer ws022:0
Jul  5 21:17:44 server kdm_greet[4262]: XGrabServer succeeded ws022:0
Jul  5 21:17:44 server kdm_greet[4262]: pseudoReset screen 0
Jul  5 21:17:44 server kdm_greet[4262]: before XSync
Jul  5 21:17:44 server kdm_greet[4262]: pseudoReset done
Jul  5 21:17:44 server kdm_greet[4262]: done secure ws022:0
Jul  5 21:17:44 server kdm: ws022:0[4261]: G_SetupDpy
Jul  5 21:17:44 server kdm: ws022:0[4261]: source /etc/X11/xdm/Xsetup_0
Jul  5 21:17:44 server kdm: ws022:0[4264]: execute: /etc/X11/xdm/Xsetup_0 ; DISPLAY=ws022:0 DM_CONTROL=/var/run/xdmctl XAUTHORITY=/var/run/xauth/Aws022:0-WYwEj3 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin SHELL=/bin/bash
Jul  5 21:17:44 server kdm: ws022:0[4261]: G_Ready
Jul  5 21:17:44 server kdm: ws022:0[4261]: greeter for display ws022:0 ready
Jul  5 21:17:44 server kdm: ws022:0[4261]: ManageSession, greeting, tdiff = -12
Jul  5 21:17:44 server kdm_greet[4262]: GreeterPlugin classic (Username + password (classic)) loaded
Jul  5 21:17:44 server kdm_greet[4262]: new greet_classic
Jul  5 21:17:44 server kdm_greet[4262]: greet_classic->presetEntity("pc22", 0)
Jul  5 21:17:45 server kdm_greet[4262]: greet_classic->start()
Jul  5 21:17:45 server kdm_greet[4262]: entering event loop
Jul  5 21:17:45 server kdm: ws022:0[4261]: G_ReadDmrc
Jul  5 21:17:45 server kdm: ws022:0[4261]:  user "pc22"
Jul  5 21:17:45 server kdm: ws022:0[4261]:  -> status 0
Jul  5 21:17:45 server kdm: ws022:0[4261]:  => "[Desktop]\nSession=custom\n"
Jul  5 21:17:45 server kdm: ws022:0[4261]: G_GetDmrc
Jul  5 21:17:45 server kdm: ws022:0[4261]:  key "Session"
Jul  5 21:17:45 server kdm: ws022:0[4261]:  -> "custom"
Comment 23 S. Umar 2007-07-06 15:47:31 UTC
Created attachment 21073 [details]
kdm.log with -debug 0x800

I am attaching the file you requested.
Comment 24 Oswald Buddenhagen 2007-07-06 16:17:38 UTC
Created attachment 21074 [details]
another test patch

ok, this didn't give the clues i hoped for. passwd is opened several times but
i cannot make any sense from this.
please apply this patch and repeat the test from comment #17.
anyway, this way we find only what the source of the new $HOME is, but not who
does it and why. can you handle gdb? :}
Comment 25 S. Umar 2007-07-06 17:16:15 UTC
Created attachment 21075 [details]
messages file created with -debug 0x40f

I have applied the patch (search for crap) and ran. I will also
attach the valgrind file if any use.
Comment 26 S. Umar 2007-07-06 17:16:52 UTC
Created attachment 21076 [details]
kdm.log with valgrind
Comment 27 Oswald Buddenhagen 2007-07-06 17:23:13 UTC
uhm, that was not according to the instructions. ;)

and forget about valgrind until further notice, it was only to exclude the possibility of a real memory corruption.
Comment 28 S. Umar 2007-07-06 17:39:54 UTC
Created attachment 21078 [details]
Try again...

Sorry, I read 7 instead of 17!
Comment 29 Oswald Buddenhagen 2007-07-06 18:01:40 UTC
thanks. but pasting just the two lines would have been sufficient. ;)
ok, $HOME is definitely reset from /etc/passwd - probably using getpwuid and setenv. one could confirm this by using ltrace, but this is most probably not necessary.
ok, now it becomes hairy: restart kdm with -debug 0x40. it will hang after starting the x server. switch to a console and attach gdb to it: gdb kdm_greet `pidof kdm_greet`. set a breakpoint at setenv and continue. each time it stops, create a backtrace, copy it (*) and continue. at some point it won't stop any more, then the greeter will be waiting for input and you're done. if it never stops, retry with getpwuid instead of setenv.
if you haven't yet, install a debug package for libc.

(*) ok, copy&paste might be a bit hard on the console. you can instead start an x session with "startx -- :1" and run gdb and your editor from there.
Comment 30 S. Umar 2007-07-06 18:14:39 UTC
How do I set breakpoint at setenv?

I may have to do this on Monday since I am running a long job and don't want
to loose it by accident!
Comment 31 Oswald Buddenhagen 2007-07-06 18:16:53 UTC
b setenv
cont

bt
cont

i'm in no hurry - quite obviously, i'm not affected by this problem. ;)
Comment 32 S. Umar 2007-07-07 00:49:04 UTC
Since I am waiting to do the above here is an educated idea, which I am sure
you can explain to me why it is wrong. I have been trying to see what has been
changed since 3.5.6 in terms of KDE.

I noticed from the strace output that "startkde" is called, which in turn
calls "start_kdeinit". Now, there is a new wrapper for start_kdeinit,
"start_kdeinit_wrapper.c" in kdelibs/kinit that restores back the environment:

"Fix the problem that the setuid kdeinit wrapper causes unsetting
some variables like LD_LIBRARY_PATH, I knew there would be somebody
who'd know what to do with it - add yet another wrapper that saves
the environment and use it again from withing the setuid wrapper."

added in May 25th, 2007. Any chance?
Comment 33 Oswald Buddenhagen 2007-07-07 08:05:09 UTC
nice try. ;)
no, kdm does not use kdeinit in any way.
Comment 34 S. Umar 2007-07-08 19:04:29 UTC
Created attachment 21090 [details]
gdb output for kdm_greet

I have done it on my laptop...gives the same error...running same
software. Kdelibs and kdebase from 3.5 SVN as of 7/7/2007.

I hope this is good enough!
Thanks
Comment 35 Oswald Buddenhagen 2007-07-08 23:34:27 UTC
dunno ... doesn't really help. the trace indicates three setenv calls from kapp:init() ... which is mysterious, as upstream kde 3.5 has *no* setenv calls in this place.
you don't seem to have debug symbols for kdelibs and libc. for glibc a debug package should be available; for kdelibs, reconfigure with --enable-debug=full and rebuild.
then repeat the last experiment with "where full" instead of "bt" - this should give a lot of actually useful info (the function arguments). apart from the extended backtraces, also do "list"s, so we see the actual code.
fwiw, also do a "svn diff" in kdelibs/kdecore - just to be sure.
Comment 36 S. Umar 2007-07-09 14:58:06 UTC
OK....I may have discovered something! Of course I am building my rpms for
Fedora and they have some patches. One of them for kdelibs called the
ICEauthority patch contains lines with 3 setenv calls. Is this the culprit?


--- kdelibs-3.5.7/kdecore/kapplication.cpp.orig 2007-05-20 22:04:53.000000000 +0200
+++ kdelibs-3.5.7/kdecore/kapplication.cpp      2007-05-20 22:38:53.000000000 +0200
@@ -774,6 +774,12 @@

 void KApplication::init(bool GUIenabled)
 {
+  if (getuid() == 0) {
+    setenv("ICEAUTHORITY", "/root/.ICEauthority", 0);
+    setenv("KDEROOTHOME", "/root/.kde", 0);
+    setenv("HOME", "/root", 1);
+  }
+
   d->guiEnabled = GUIenabled;
   if ((getuid() != geteuid()) ||
       (getgid() != getegid()))
~
Comment 37 Oswald Buddenhagen 2007-07-09 15:10:11 UTC
you can bet your ass it is. whoever did that hack should be shot. i'm out, so to say.
Comment 38 S. Umar 2007-07-09 15:15:42 UTC
I am equally upset and will file a bug report with Fedora with appropriate
language! I wonder if Ubuntu people who have the same problem are using
a similar patch.
Thank you very much.
Comment 39 Kevin Kofler 2007-07-09 17:46:38 UTC
They are:

--- kdelibs-3.5.6.orig/debian/patches/kubuntu_28_fix_sudo.diff
+++ kdelibs-3.5.6/debian/patches/kubuntu_28_fix_sudo.diff
@@ -0,0 +1,17 @@
+--- kdelibs/kdecore/kapplication.cpp	2006-08-01 16:58:45.000000000 +0000
++++ kdelibs/kdecore/kapplication.cpp	2006-08-01 16:58:58.000000000 +0000
+@@ -774,6 +774,14 @@
+ 
+ void KApplication::init(bool GUIenabled)
+ {
++  // stop KDE programs run with sudo changing permissions on ~/.kde and /.ICEauthority
++  int uid = getuid();
++  if (uid == 0) {
++    setenv("ICEAUTHORITY", "/root/.ICEauthority", 0);
++    setenv("KDEROOTHOME", "/root/.kde", 0);
++    setenv("HOME", "/root", 1);
++  }
++
+   d->guiEnabled = GUIenabled;
+   if ((getuid() != geteuid()) ||
+       (getgid() != getegid()))
Comment 40 Mike Cohler 2007-07-11 20:01:40 UTC
Please can you quote the url for the fedora bug you filed? I could not find it.
Thanks
Comment 41 Rex Dieter 2007-07-11 20:03:44 UTC
fedora bugzilla reference: http://bugzilla.redhat.com/247455
Comment 42 Mike Cohler 2007-07-11 20:08:01 UTC
Thanks