Bug 147003 - non KDE applications do not accept input from keyboard after a while
Summary: non KDE applications do not accept input from keyboard after a while
Status: RESOLVED NOT A BUG
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-20 16:07 UTC by Thomas Wagner
Modified: 2010-01-22 09:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Wagner 2007-06-20 16:07:01 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs
OS:                Linux

When I use non KDE applications such as Opera 9.2, OpenOffice 2.2 (both installed from a precompiled rpm), or often also other programs, after a few minutes (sometimes just a minute, sometimes nearly half an hour) these apps don't accept any keyboard input, neither normal charakters, nor key kombinations like STRG-W. Only ALT-F4 to close a window is working the most of the time. Meanwhile I can still control the application with my mouse, so the apps arn't hung up. Only keystrokes are rejected.

Switching with ALT-TAB between open windows sometimes makes the keyboard input work again. 

my system: openSuSE 10.2 on an Acer Aspire 1694WLMI with german keyboard layout

I don't think that the problem is corresponding with the Notebook keyboard, because connecting another keyboard via synergy also produces this problem.
Comment 1 Vikram Dhillon 2010-01-22 07:04:14 UTC
How does this bug relate to the web-site product. The www component is supposed to deal with web related issues. Thus marking this one invalid, if I am wrong in my judgement of this bug, change the status back to new :)
Comment 2 Thorsten Staerk 2010-01-22 09:33:13 UTC
What about the non-KDE-application xev? Its task is to display keyboard events. Does it display the keystrokes?