Bug 146964 - Sort order by date sometimes wrong, if pictures have exactly the same timestamp
Summary: Sort order by date sometimes wrong, if pictures have exactly the same timestamp
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-ItemsSort (show other bugs)
Version: 0.9.1
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-19 15:15 UTC by Unknown
Modified: 2022-02-20 08:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2007-06-19 15:15:03 UTC
Version:           0.9.1 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

If I have an album with pictures, which are numbered ascending and which have all the exactly same timestamp (e.g. 03/07/2001 00:00:00,  stored in EXIF header and used as file date), the pictures are sorted right using "by name" as sort order. 

If I change the sort order to "by date", sometimes some pictures are sorted wrong. They switch to the end of the block with the same timestamp. I can't reproduce it deterministicly, but it seems, that this problem occurs not with pictures taken by a digital camera, but with old scanned pictures with an manually added EXIF header. 

What I exspect is, that in case of a none unique primary sort key (exactly same date), a secondary sort key (name) is used. This seems not to be done. If all pictures of an album have an unique timestamp, the sort order should be the same independendly from the used sort order (name or date).
Comment 1 Unknown 2007-06-19 15:40:09 UTC
Okay, forgot to say: the problem does not affect pictures taken with a digital camera, because normally the timestamp is not exactly the same ;)
Comment 2 caulier.gilles 2008-12-04 16:35:55 UTC
Achim,

What news about this file ? it still valid using digiKam 0.9.4 (KDE3) or 0.10.0 (KDE4 ) ?

Gilles Caulier
Comment 3 Unknown 2008-12-04 17:02:56 UTC
Charles, this bug ist still valid in 0.9.4 (I'm not using 0.10.0 at the moment, so I can't say anything about that in 0.10.0).

Comment 4 Andi Clemens 2010-09-25 17:43:01 UTC
Closing some old bugreports that are related to old digiKam version, and that have not received answers for two years now.

If you think the reports are still valid, feel free to re-open them, but please provide updates and do not just open them without giving feedback.
Comment 5 caulier.gilles 2015-07-04 06:00:46 UTC
New digiKam 4.11.0 is available.

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?
Comment 6 caulier.gilles 2016-07-15 12:18:37 UTC
With digiKam 5.0.0, this problem is not reproducible.
I close this file now. Don't hesitate to re-open if necessary.
Gilles Caulier