Bug 146738 - Fuji *.RAF files aren't recognized as RAW files
Summary: Fuji *.RAF files aren't recognized as RAW files
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-DImg-RAW (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-13 13:40 UTC by Mikolaj Machowski
Modified: 2019-12-23 17:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2007-06-13 13:40:58 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

Fuji RAF files aren't recognized as RAW files and it is impossible to import them into digikam.

External dcraw 8.74 handles them correctly (sort of).
Comment 1 Mikolaj Machowski 2007-06-13 13:42:03 UTC
Since these are my first forays into RAW field - not sure if everything made correctly - I lower status of this bug.
Comment 2 Arnd Baecker 2007-06-13 16:00:24 UTC
More out of curiosity: what does "sort of" mean? Is the camera (which Fuji? BTW),
listed as supported on the dcraw homepage?
Comment 3 caulier.gilles 2007-06-13 16:10:36 UTC
...and here, i have 3 RAF files to test with digiKam, and all work fine...

Gilles 
Comment 4 Julien Narboux 2007-06-13 16:13:21 UTC
Maybe check that .raf are in the list of file types handled by digikam in the configuration dialog. If your configuration is very old it may be the case that it does not contains all the file types digikam can handle. I encountered this problem once.
Comment 5 Mikolaj Machowski 2007-06-13 18:26:02 UTC
I've had bad day...
Coming home from work, opening Digikam and... all RAFs are there. Didn't have to change anything. Sorry for false alarm.
Comment 6 Mikolaj Machowski 2007-06-14 01:53:09 UTC
> ------- More out of curiosity: what does "sort of" mean? Is the camera
> (which Fuji? BTW), listed as supported on the dcraw homepage?

For example results are worse than those from RawTherapee supposedly
basing on dcraw.

Camera is Fuji FinePix S9100/S9600 . It is not on supported list but
its name is in code with some parameters. Maybe it means that support
isn't complete?
Comment 7 caulier.gilles 2019-12-23 17:45:43 UTC
Not reproducible with digiKam 7.0.0-beta1.