Bug 146562 - flash performance on jamendo.com (audio)
Summary: flash performance on jamendo.com (audio)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: 3.5
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-09 00:15 UTC by Harald Sitter
Modified: 2012-06-18 14:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Sitter 2007-06-09 00:15:34 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
Compiler:          gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4) 
OS:                Linux

the site is causing sliders even though they shouldn't be necessary
Comment 1 A. Spehr 2008-04-24 06:31:31 UTC
I can't tell the difference between iceweasel and konq (~4.0.3+) on this site. So either something got fixed, or it isn't there anymore.

Or I don't know what "sliders" are. I'm assuming scrollbars or something.

I'd close this, but I notice I can't change languages in konq, and I get errors about flash's music backend when i try to play music. I wonder if this is testcaseable...

I get a ton of these, which may or may not tell anything:
konqueror(28029)/nspluginviewer (part) PluginLiveConnectExtension::get: PLUGIN:LiveConnect::get  "GetVariable"
Comment 2 A. Spehr 2008-04-24 06:44:32 UTC
This site is also really slow...

It renders fine, so i'm changing the subject. 
Comment 3 Gary Greene 2008-04-24 07:17:40 UTC
The site renders fine on Konqueror from 3.5.8. The player functionality will not work however in Konqueror, since the javascript explictly calls for WiMP or XUL Songbird stuff. Until someone adds XUL support to Konqueror, you'll have to make due with Amarok2 in KDE4 to browse this site.
Comment 4 Tomas Van Verrewegen 2008-04-24 09:55:09 UTC
the site renders fine for me, but the player window doesn't (all elements are there, but no data is in the listboxes, i suppose the data is loaded after validation of the flash player), and a box explaining there's a problem with the flash audio backend. konqueror goes into 100% cpu and i have to xkill the window. sometimes konq then crashes (backtrace: see below).

when i open the player window by pasting the address in the url-box, same thing happens, but konq doesnt go into 100% cpu, so i can close it properly (and konq doesnt crash).

kde 4.00.71
flash 9,0,115,0

Application: Konqueror (konqueror), signal SIGABRT
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1238092096 (LWP 23373)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb664c875 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb664e201 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb6645b6e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb45018c5 in KHTMLGlobal::finalCheck ()
    at /home/tomas/local/opt/kde4/src/kdelibs/khtml/khtml_global.cpp:247
#11 0xb4a3eb01 in ~KHTMLFactory (this=0x82473a0)
    at /home/tomas/local/opt/kde4/src/kdelibs/khtml/khtml_factory.cpp:35
#12 0xb7245f5e in QObjectCleanupHandler::clear (this=0x8212c20)
    at /home/tomas/local/opt/kde4/src/qt-copy/src/corelib/kernel/qobjectcleanuphandler.cpp:142
#13 0xb7245fcd in ~QObjectCleanupHandler (this=0x8212c20)
    at /home/tomas/local/opt/kde4/src/qt-copy/src/corelib/kernel/qobjectcleanuphandler.cpp:88
#14 0xb7b916b5 in destroy ()
    at /home/tomas/local/opt/kde4/src/kdelibs/kdecore/util/kpluginfactory.cpp:29
#15 0xb7b91638 in __tcf_0 ()
    at /home/tomas/local/opt/kde4/src/kdelibs/kdecore/kernel/kglobal.h:67
#16 0xb664f594 in exit () from /lib/tls/i686/cmov/libc.so.6
#17 0xb6a7df4b in qt_xio_errhandler ()
    at /home/tomas/local/opt/kde4/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:590
#18 0xb781f8b7 in KApplication::xioErrhandler (this=0xbfe019e8, dpy=0x80647d0)
    at /home/tomas/local/opt/kde4/src/kdelibs/kdeui/kernel/kapplication.cpp:418
#19 0xb781f8f6 in kde_xio_errhandler (dpy=0x80647d0)
    at /home/tomas/local/opt/kde4/src/kdelibs/kdeui/kernel/kapplication.cpp:130
#20 0xb7540d4d in _XIOError () from /usr/lib/libX11.so.6
#21 0xb7541be6 in _XRead () from /usr/lib/libX11.so.6
#22 0xb7542604 in _XReply () from /usr/lib/libX11.so.6
#23 0xb753c5da in XSync () from /usr/lib/libX11.so.6
#24 0xb6a7dd7f in QApplication::syncX ()
    at /home/tomas/local/opt/kde4/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:2667
#25 0xb6a826b4 in QETWidget::translateConfigEvent (this=0x8f07b48, 
    event=0xbfe01598)
    at /home/tomas/local/opt/kde4/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:4762
#26 0xb6a8b54e in QApplication::x11ProcessEvent (this=0xbfe019e8, 
    event=0xbfe01598)
    at /home/tomas/local/opt/kde4/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:3139
#27 0xb6ab0844 in x11EventSourceDispatch (s=0x805f638, callback=0, 
    user_data=0x0)
    at /home/tomas/local/opt/kde4/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:148
#28 0xb64b811c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0xb64bb55f in ?? () from /usr/lib/libglib-2.0.so.0
#30 0x0805e120 in ?? ()
#31 0x00000000 in ?? ()
#0  0xffffe410 in __kernel_vsyscall ()
Comment 5 Lubos Lunak 2008-07-21 16:22:50 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 6 Myriam Schweingruber 2012-06-18 14:14:39 UTC
Message from the Bugsquad and Konqueror teams:
This bug is closed as outdated, as we do not have the manpower to maintain the KDE3 version anymore.
If you still can reproduce this issue with Konqueror 4.8.4 or later, please open a new report.
Thank you for your understanding.