Bug 146455 - Image rotation and auto-rotate don't work
Summary: Image rotation and auto-rotate don't work
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-PostProcessing (show other bugs)
Version: 0.9.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-06 16:43 UTC by Amit Shah
Modified: 2017-08-16 06:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 1.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Shah 2007-06-06 16:43:51 UTC
Version:           0.9.1 (using KDE 3.5.7, Kubuntu (feisty) 4:3.5.7-0ubuntu1~feisty2)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-16-386

I pointed digikam to the location where my pics are stored. To get them to the correct orientation, I had to 'rotate by 90deg' and then 'rotate by 270deg'. This always rotated them to the correct orientation, no matter what the original rotation degree was.

The 'auto rotate' functionality also doesn't work.
Comment 1 caulier.gilles 2007-11-28 13:19:44 UTC
Amit,

Are you tried With digiKam 0.9.2 or 0.9.3-beta3 and with Exiv2 library 0.15 ?

Gilles Caulier
Comment 2 Andi Clemens 2008-09-07 14:59:35 UTC
For me this works, the bugreport is rather old.

Amit,
any updates here? Otherwise I think we can close this?
Comment 3 caulier.gilles 2008-12-05 09:22:59 UTC
Amit,

Without a fresh report using digiKam 0.9.4, we will close this file...

Gilles Caulier
Comment 4 Mikolaj Machowski 2009-05-17 21:21:49 UTC
And without fresh report using digiKam 0.10 we *really* should close this file :)
Comment 5 Amit Shah 2009-05-18 06:09:30 UTC
Sorry I haven't tested this again; I'm running 4.2.2 and haven't tried digikam in a while. You can close this for now and I'll reopen or open a new bug if it still persists.
Comment 6 Andi Clemens 2009-05-24 15:39:24 UTC
Ok, closing it...

Andi