Bug 146434 - fish:/ crashs since Kernel 2.6.21.x
Summary: fish:/ crashs since Kernel 2.6.21.x
Status: RESOLVED DUPLICATE of bug 145123
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: fish (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash with 40 votes (vote)
Target Milestone: ---
Assignee: Jörg Walter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-05 23:48 UTC by Patrick Matthäi
Modified: 2007-10-17 08:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Matthäi 2007-06-05 23:48:47 UTC
Version:           3.5.7-1 (using KDE KDE 3.5.7)
Installed from:    Debian testing/unstable Packages
Compiler:          GCC 4.2 
OS:                Linux

Since I'm using Kernel 2.6.21.x (a friend, too), KIO crashs every time if I want to connect to a ssh server about the fish:/ protocol.

Here's the .xsession-errors output:

kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Could not write data
kio (KLauncher): ERROR: SlavePool: No communication with slave.
kioslave: ####### CRASH ###### protocol = fish pid = 3073 signal = 29
Comment 1 Ruben Jenster 2007-07-05 11:18:46 UTC
I can confirm this behaviour although I'm using kde-3.5.5.
With kernel 2.6.20 fish is working but it doesn't work with kernel 2.6.21 or 2.6.22-rc*.
Comment 2 Ruben Jenster 2007-07-21 21:57:02 UTC
I assume that it is a 64bit related problem.  
I switched from a 64bit compiled kde to a 32bit version and now fish works again - same kernel version.

Regards,
Ruben
Comment 3 Patrick Matthäi 2007-07-23 18:02:24 UTC
It's not 64 bit related, I've got a 32 bit system.
Comment 4 Christian Weiske 2007-10-09 18:44:23 UTC
Same on a 64bit macbook with a vanilla 2.6.22 kernel
Comment 5 Christian Weiske 2007-10-17 07:38:53 UTC
This is a duplicate of bug #145123
Comment 6 Tommi Tervo 2007-10-17 08:33:56 UTC

*** This bug has been marked as a duplicate of 145123 ***