Bug 146312 - Configure rules for digikam 0.92 Beta 2 using --prefix=/home/xav/build
Summary: Configure rules for digikam 0.92 Beta 2 using --prefix=/home/xav/build
Status: RESOLVED NOT A BUG
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Compilation (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-03 11:25 UTC by Xavier Pouyollon
Modified: 2017-08-19 21:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Pouyollon 2007-06-03 11:25:43 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Mandriva RPMs
OS:                Linux

Downloaded digkiam 0.92 and all libs that it needs
For each, I do the following:

./configure --prefix=/home/build/xav
make
make install

Fine for the libs

However, when building digikam 0.92, it complains it can't find include files for libkdcraw.
The libs are well installed within /home/build/xav/include

I have to do:
 ./configure --prefix=/home/xav/build --with-extra-includes=/home/xav/build/include/
to allow build.

To me, I should not have to --with-extra-includes=/home/xav/build/include since the libkdcraw/lib/pkg-config is correct (with the right include path).

I would say that something is either wrong in the configure scripts or I don't build it correctly ?
(I'm quite new in trying to build at non usual location)

Thanks !
Comment 1 Frank Siegert 2007-06-03 11:34:46 UTC
I think the behaviour you are seeing is correct. Digikam's configure step cannot look in all possible paths on your harddrive for needed header files. It will certainly check a few standard locations like /usr/include, but if the needed headers are installed in a custom directory like /home/xav/build/include, it's only fair that you have to tell digikam's installation to look for them there.
Marking as INVALID, please reopen if you disagree.
Comment 2 Arnd Baecker 2007-06-03 11:58:33 UTC
Just one additional comment:
In principle, you might even have to specify the libs:
  ./configure --prefix=$DKPATH --with-extra-includes=$DKPATH/include  \
         --with-extra-libs=$DKPATH/lib
(I think I had cases where this was necessary ...)

Also it is worth mentioning, that there is a
problem for the kde-imaging part to find a self-compiled exiv2
(if exiv2 is already in /usr/)
due to an ordering problem in the configure script, see
http://mail.kde.org/pipermail/kde-imaging/2007-May/005106.html

In general, for installing from svn, the procedure at
  http://www.digikam.org/?q=download/svn
under "Install digiKam in your Home Directory"
usually works without problems.
Comment 3 Xavier Pouyollon 2007-06-03 12:36:47 UTC
Thanks all ! However...

I would have expect the libkdcraw.pc to be used because it contains the real path of the include in it (/home/xav/build/include). 
Looks like configure, at least of this part, is not taking full advantage of pkg-config..
Comment 4 Chris Spiegel 2007-06-18 19:55:39 UTC
Yes, this is definitely a bug (I'm referring to version 0.9.2-final here).  The configure process finds the libkdcraw package-config file and sets variables in the Makefile, which in my case are:
LIBKDCRAW_CFLAGS = -I/opt/kde3apps/include
LIBKDCRAW_LIBS = -L/opt/kde3apps/lib -lkdcraw

The problem is that these variables are never used.  Digikam certainly shouldn't search the entire drive for includes, but it seems reasonable that if it does find a package, it should use it, regardless of where it's installed.

I'm not sure if bugs marked resolved continue to be tracked, so I'll open a new report in a few days if it appears that no one saw this.
Comment 5 Achim Bohnet 2007-06-27 18:28:36 UTC
Hi, can you tell us
 o which version of libkdraw you are using?
 o the output of make with the error msg?

FWIW, IMHO --prefix should be enough if prefix for the involved
pkgs are the same.  If not it needs to be fixed. Everything in
$prefix, include, libs, .pc files etc should have automaticly
get highest precedence.

Achim
Comment 6 Achim Bohnet 2007-06-30 23:10:42 UTC
Same problem as in bug 147269.  I've fixed it right now in SVN.
Digikam builds now fine with libkexif/libkdcraw install in
/HERE/ARE/THEY using:

 PKG_CONFIG_PATH=/HERE/ARE/THEY/lib/pkgconfig  ../configure --prefix=/foo/bar

Achim
Comment 7 Arnd Baecker 2007-06-30 23:56:56 UTC
Achim, thanks a lot - this is a big relief!

Best, Arnd