Bug 146306 - immediate crash after splash screen error log generated
Summary: immediate crash after splash screen error log generated
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 140813 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-03 02:48 UTC by Don Ziesig
Modified: 2007-06-22 15:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Don Ziesig 2007-06-03 02:48:10 UTC
Version:           1.6.2 ? (using KDE KDE 3.5.6)
Installed from:    Compiled From Sources
Compiler:          g++ (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4) 
OS:                Linux

Easy to reproduce:  Select krita from menu, click!  or change to directory in which krita was built and enter ./krita.  Splash screen appears, followed almost immediately by the bug report screen.

The following is the result of ./krita 2> run_errors:

koffice (lib kofficecore): kritapart.desktop found.
krita (plugins): found plugin Selection Tools
krita (plugins): found plugin Polygon Tool
krita (plugins): found plugin Crop Tool
krita (plugins): found plugin Polyline Tool
krita (plugins): found plugin Star Tool
krita:  add perspective transform tool to the registry
krita (plugins): found plugin Perspective transform Tool
krita (plugins): found plugin Select Similar Colors Tool
krita (plugins): found plugin Curves Tool
krita (plugins): found plugin Default Tools
krita (plugins): found plugin Perspective Grid Tool
krita (plugins): found plugin Transform Tool
krita (plugins): found plugin Default Paint Operations
krita (plugins): found plugin Filter Tool
krita (plugins): Extensions Image enhancement Filters plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Image enhancement Filters (Extension)
krita (plugins): found plugin Sobel Filter
krita (plugins): found plugin Sobel Filter
krita (plugins): found plugin Emboss Filter
krita (plugins): found plugin Random pick Filter
krita (plugins): Extensions Convolution Filters plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Convolution Filters (Extension)
krita (plugins): found plugin Wave Filter
krita (plugins): found plugin Color Filters
krita (plugins): found plugin Invert Filter
krita (plugins): Colorify Filter plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Color Filters (Extension)
krita (plugins): Extensions Colors Filter plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Color Filters (Extension)
krita (plugins): found plugin Pixelize Filter
krita (plugins): found plugin LensCorrection Filter
krita (plugins): Image enhancement filter plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Enhancement Filters
krita (plugins): found plugin CImg Image Restoration Filter
krita (plugins): found plugin Oilpaint Filter
krita (plugins): found plugin Convolution Filters
krita (plugins): found plugin Levels
krita (plugins): found plugin Noise Filter
krita (plugins): found plugin Bumpmap Filter
krita (plugins): found plugin Raindrops Filter
krita (plugins): Color Transfer Filter plugin. Class: KParts::Plugin, Parent: KisFilterRegistry
krita (plugins): found plugin Color Transfer Filter
krita (plugins): found plugin Small Tiles Filter
krita (plugins): found colorspace YCbCr Color Model (8-bit integer)
krita (plugins): found colorspace LMS Color Model (32-bit float)
krita (plugins): found colorspace Grayscale Color Model
krita (plugins): found colorspace CMYK Color Model (16-bit integer)
krita (plugins): found colorspace Grayscale Color Model (16-bit integer)
krita (plugins): found colorspace RGB Color Model (16-bit float 'half')
krita (plugins): found colorspace RGB Color Model (16-bit integer)
krita (plugins): found colorspace Watercolor Paint Plugin
krita (plugins): found colorspace RGB Color Model
krita (plugins): found colorspace YCbCr Color Model (16-bit integer)
krita (plugins): found colorspace RGB Color Model (32-bit float)
krita (plugins): found colorspace CMYK Color Model
koffice (lib kofficecore): kritapart.desktop found.
KCrash: Application 'lt-krita' crashing...

The following are the contents of the Bug Report screen:

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1236023600 (LWP 28760)]
[KCrash handler]
#6  0xb6efa993 in QScrollView::viewport () from /usr/lib/libqt-mt.so.3
#7  0xb61828ba in SqueezedComboBox::SqueezedComboBox ()
   from /usr/lib/libkritaui.so.1
#8  0xb619b5eb in WdgNewImage::WdgNewImage () from /usr/lib/libkritaui.so.1
#9  0xb616c86c in KisCustomImageWidget::KisCustomImageWidget ()
   from /usr/lib/libkritaui.so.1
#10 0xb60eb9ad in KisDoc::createCustomDocumentWidget ()
   from /usr/lib/libkritaui.so.1
#11 0xb7eb16a1 in KoDocument::createOpenPane ()
   from /home/dziesig/Desktop/koffice-1.6.2/lib/kofficecore/.libs/libkofficecore.so.3
#12 0xb7eb4b7b in KoDocument::showStartUpWidget ()
   from /home/dziesig/Desktop/koffice-1.6.2/lib/kofficecore/.libs/libkofficecore.so.3
#13 0xb7edbb1b in KoApplication::start ()
   from /home/dziesig/Desktop/koffice-1.6.2/lib/kofficecore/.libs/libkofficecore.so.3
#14 0xb7f7a3bc in kdemain ()
   from /home/dziesig/Desktop/koffice-1.6.2/krita/.libs/libkdeinit_krita.so
#15 0x08048802 in main ()
Comment 1 Halla Rempt 2007-06-03 16:22:58 UTC
This is a bug in some styles, for instance the CDE or Motif style.
Comment 2 Halla Rempt 2007-06-22 15:21:24 UTC
SVN commit 678877 by rempt:

BUG:146306
Fix crash in squeezedcombobox when motif or cde style is selected. Not relevant for trunk,
because there we'll stop using squeezedcombobox Real Soon Now.


 M  +3 -0      squeezedcombobox.cpp  


--- branches/koffice/1.6/koffice/krita/ui/squeezedcombobox.cpp #678876:678877
@@ -62,6 +62,9 @@
 {
     setMinimumWidth(100);
     m_timer = new QTimer(this);
+
+    if (!listBox()) return;
+
     m_tooltip = new SqueezedComboBoxTip( listBox()->viewport(), this );
 
     connect(m_timer, SIGNAL(timeout()),
Comment 3 Sven Langkamp 2007-06-22 15:35:31 UTC
*** Bug 140813 has been marked as a duplicate of this bug. ***