Bug 146215 - filtering more than one mail(IMAP) make kmail hang
Summary: filtering more than one mail(IMAP) make kmail hang
Status: RESOLVED DUPLICATE of bug 126182
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-31 20:36 UTC by Olivier Vitrat
Modified: 2007-06-07 18:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Vitrat 2007-05-31 20:36:59 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Debian testing/unstable Packages

Reported in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=425739

 am using kmail (within Kontact) to filter email in my IMAP inbox into
different sub-folders within the IMAP structure.

When selecting multiple messages and doing a manual filter, or during the "initial collection", only the first of the new or selected messages is actually filtered.

No CPU usage is seen and after about 5 minutes I am able to select the
next message and have that filtered.

I have tried recreating the filters  but that did not help.

These filters were fine with the previous version that was replaced when
I upgraded this morning.

Additionnal info :
 - filtering mail/mail work
 - filtering more than one mail make filtering hang after filter the first mail. It is still possible no look at other mails, but those wich 
must be filtered(selected) are undisplayable. It is possible to 'quit' kontact/kmail correctly.
Comment 1 Thomas McGuire 2007-06-07 18:36:46 UTC
>When selecting multiple messages and doing a manual filter, or during the "initial collection", only the first of the new or selected messages is actually filtered. 
This sounds like the regression introduced in 1.9.7 which is also described in bug 126182.

*** This bug has been marked as a duplicate of 126182 ***