Bug 146127 - complains about broken configuration file (missing begining of module section) but nothing seems to be wrong with it
Summary: complains about broken configuration file (missing begining of module section...
Status: RESOLVED FIXED
Alias: None
Product: kdesrc-build
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michael Pyne
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-29 22:28 UTC by jos poortvliet
Modified: 2007-05-30 02:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
my kdesvn-buildrc, which apparently is wrong (but I don't see why) (12.78 KB, text/plain)
2007-05-29 22:29 UTC, jos poortvliet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jos poortvliet 2007-05-29 22:28:03 UTC
Version:           1.4.1 (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When running kdesvn-build, I get this:
Invalid configuration file /home/kde4/.kdesvn-buildrc!
Expecting a start of module section.
Global settings will be retained.

Now a few days ago, this worked fine (with the same file, I'll attach it), but now it doesn't anymore. The change is that I removed the kde directory (thus all compiled stuff) and re-downloaded kdesvn-build from the website. I try to recompile everything, but... :(

kdesvn-build --version gives:
kdesvn-build 1.4.1
Comment 1 jos poortvliet 2007-05-29 22:29:54 UTC
Created attachment 20720 [details]
my kdesvn-buildrc, which apparently is wrong (but I don't see why)
Comment 2 Michael Pyne 2007-05-30 02:55:01 UTC
Fixed in revision 669673.  The problem is that at line 320, the module extragear/libs part begins with a space.  I'm not sure why this hasn't been an issue for you before, as the code hasn't changed in forever. :)

It is fixed but you can workaround it by removing the leading whitespace from the couple of modules in that area of the file that have it.