Bug 146064 - arrowheads are not shown
Summary: arrowheads are not shown
Status: RESOLVED FIXED
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
: 148280 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-28 13:26 UTC by Anton Pussep
Modified: 2007-07-29 16:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Umbrello file, using version 1.5.7 the arrowheads disappear (87.63 KB, application/octet-stream)
2007-05-28 13:27 UTC, Anton Pussep
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Pussep 2007-05-28 13:26:19 UTC
Version:           1.5.7 (using KDE KDE 3.5.5)
Installed from:    Debian stable Packages
OS:                Linux

I have a Umbrello class diagram that is not shown properly in the version 1.5.7, the arrowheads are not shown. The version 1.5.61 displays them properly, however. I uploaded the file causing the problem to my server, it can be found here:

http://www.pussep.de/anton/downloads/umbrello_bug_001.xmi

Both Umbrello versions are self compiled using the original sources.
Comment 1 Anton Pussep 2007-05-28 13:27:19 UTC
Created attachment 20708 [details]
Umbrello file, using version 1.5.7 the arrowheads disappear
Comment 2 Oliver Kellogg 2007-05-28 23:44:12 UTC
SVN commit 669259 by okellogg:

loadFromXMI(): Before version 1.5.7, we forgot to write the "type" attribute
 of the AssociationWidget in saveToXMI().  As a workaround on loading pre-
 1.5.7 XMI files, use the type from the UMLAssociation.
BUG:146064


 M  +2 -0      ChangeLog  
 M  +14 -0     umbrello/associationwidget.cpp  


--- branches/KDE/3.5/kdesdk/umbrello/ChangeLog #669258:669259
@@ -1,12 +1,14 @@
 Version 1.5.71
 
 * Bugs/wishes from http://bugs.kde.org:
+* Switching between tabbed and non-tabbed views requires restart (98204)
 * Preprocessor keywords ignored which causes endless loop in code import (119125)
 * Unstable saves and loads, class names become dirty (145709)
 * Crash on deleting class in list view (145762)
 * Class attribute documentation not generated for python (145916)
 * Python code generator does not wrap lines properly (145918)
 * Attribute documentation not generated for 'Export to XHTML' (145972)
+* Arrowheads are not shown (146064)
 
 Version 1.5.7
 
--- branches/KDE/3.5/kdesdk/umbrello/umbrello/associationwidget.cpp #669258:669259
@@ -3437,7 +3437,21 @@
         }
 
         // New style: The xmi.id is a reference to the UMLAssociation.
+        // If the UMLObject is not found right now, we try again later
+        // during the type resolution pass - see activate().
         m_nId = STR2ID(id);
+        UMLObject *myObj = m_umldoc->findObjectById(m_nId);
+        if (myObj) {
+            const Uml::Object_Type ot = myObj->getBaseType();
+            if (ot != ot_Association) {
+                setUMLObject(myObj);
+            } else {
+                UMLAssociation * myAssoc = static_cast<UMLAssociation*>(myObj);
+                setUMLAssociation(myAssoc);
+                if (type == "-1")
+                    aType = myAssoc->getAssocType();
+            }
+        }
     }
 
     setAssocType(aType);
Comment 3 Oliver Kellogg 2007-07-29 16:15:05 UTC
*** Bug 148280 has been marked as a duplicate of this bug. ***