Bug 146032 - panning doesn't work in LT
Summary: panning doesn't work in LT
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: LightTable-Canvas (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-27 19:51 UTC by Mikolaj Machowski
Modified: 2022-02-01 09:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2007-05-27 19:51:35 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

After today (27.05) svn update panning in LT stopped working.
svn info 668753.

Pan widget opens as whole image was visible.
Comment 1 caulier.gilles 2007-05-27 20:37:37 UTC
Yes, i can reproduce it.

For info, commit #668753 come from Marcel :

SVN commit 668753 by mwiesweg:

Adapt to DImg-based preview

 M  +10 -9     digikam/imagepreviewview.cpp
 M  +3 -3      digikam/imagepreviewview.h
 M  +9 -0      libs/widgets/common/paniconwid
get.cpp
 M  +5 -0      libs/widgets/common/paniconwidget.h
 M  +6 -6      utilities/lighttable/lighttablepreview.cpp
 M  +1 -1      utilities/lighttable/lighttablepreview.h

Marcel, what wrong (:=))) ?

Gilles
Comment 2 caulier.gilles 2007-05-28 10:42:27 UTC
Mik, and it's the same problem about preview mode from Album GUI...

Gilles
Comment 3 caulier.gilles 2007-05-28 10:43:46 UTC
Gerhard,

Please wait than this file is fixed before to release 0.9.2-beta2. Thanks in advance

Gilles
Comment 4 caulier.gilles 2007-05-28 10:52:32 UTC
SVN commit 668971 by cgilles:

digikam from trunk : do not resize Dimg before to pass it like QImage else original image size informations will be lost.
BUG: 146032


 M  +1 -4      paniconwidget.cpp  


--- trunk/extragear/graphics/digikam/libs/widgets/common/paniconwidget.cpp #668970:668971
@@ -109,11 +109,8 @@
 
 void PanIconWidget::setImage(int previewWidth, int previewHeight, const DImg& image)
 {
-    QSize sz(image.width(), image.height());
-    sz.scale(previewWidth, previewHeight, QSize::ScaleMin);
     DImg img(image);
-    QImage qimage = img.smoothScale(sz.width(), sz.height()).copyQImage();
-    setImage(previewWidth, previewHeight, qimage);
+    setImage(previewWidth, previewHeight, img.copyQImage());
 }
 
 void PanIconWidget::slotZoomFactorChanged(double factor)
Comment 5 caulier.gilles 2007-05-28 10:59:21 UTC
Gerhard,

All is fine to release 0.9.2-beta2 now (:=)...

Gilles
Comment 6 Gerhard Kulzer 2007-06-02 07:08:47 UTC
Am Monday 28 May 2007 schrieb Gilles Caulier:
[bugs.kde.org quoted mail]

Can I do beta3, Gilles?
Would have time this weekend

Gerhard :-)
Comment 7 caulier.gilles 2007-06-02 08:40:54 UTC
Gerhard,

I recommend to wait to release next week, because this week end all extragear repository (witch contain digiKam) will be moved to another part of KDE.

Are you follow extragear mailing list announce ?

Gilles
Comment 8 Gerhard Kulzer 2007-06-02 09:10:39 UTC
Am Saturday 02 June 2007 schrieb Gilles Caulier:
[bugs.kde.org quoted mail]
Ok
> Are you follow extragear mailing list announce ?


Yes I do
>
> Gilles




A+
Gerhard
Comment 9 caulier.gilles 2007-06-03 12:20:51 UTC
Gerhard,

Like the migration is done and compile properlly, and like MArcel have commited yesterday a fix about Exif rotation rules with Light Table and Album Gui preview, I think all is right to release 0.9.2-beta3 today... (if you can of course (:=)))

Gilles