Bug 145263 - kmail doesnt erase temp files after exit
Summary: kmail doesnt erase temp files after exit
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN (3.5 branch)
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-10 15:05 UTC by
Modified: 2009-09-15 22:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2007-05-10 15:05:39 UTC
Version:           1.9.6 (using KDE 3.5.6, compiled sources)
Compiler:          Target: x86_64-mandriva-linux-gnu
OS:                Linux (x86_64) release 2.6.17-13mdv

Im using kdepim branch_3.5 svn release 663080, and now i see that in $HOME/tmp folder i have thousands of tmp files that were and are created by kmail and that after kmail exit these temp files continue existing. 
 
 Shouldnt these temp files be erased when kmail exists? 
 
 Shouldnt kmail create these temp files in $HOME/tmp/kde-user  folder instead in $HOME/tmp?
Comment 1 Thomas McGuire 2007-05-12 14:47:37 UTC
The location probably depends on some environment variables.
What kind of temp files are stored there?
Comment 2 2007-05-13 18:33:19 UTC
What you mean with "What kind of temp files"?
The names of the temp files are like this one:

tmp1c152d66.tmp

in wich the contents are messages stored in kmail, this in recent since never was used $HOME/tmp to save any kmail temp files, but whats more grave is that this temp files arent erased after kmail exits.

However this temp files shouldnt be in $HOME/tmp/kde-user?
Comment 3 2007-05-17 21:55:10 UTC
This is a very serious bug and seams no one will fix it for 3.5.7, great...
Comment 4 Bram Schoenmakers 2007-05-17 22:17:55 UTC
In fact it's impossible to fix for 3.5.7. It has already been tagged.

By the way, I haven't seen those temporary files, it may be a local problem then.
Comment 5 Bram Schoenmakers 2007-05-17 22:25:33 UTC
Sorry, I was looking in the wrong tmp folder. There are (empty) temp files in there.
Comment 6 2007-05-17 22:38:45 UTC
o locaL problem? doesnt seam so since this wasnt patched for it
Comment 7 2007-05-17 22:42:43 UTC
I have hundreds of tmp files and arent emty, they have messages
Comment 8 Bram Schoenmakers 2007-05-17 23:47:03 UTC
David, I hope you don't mind if I CC on this one. You changed something regarding tempfiles in kdelibs between 3.5.6 and 3.5.7, maybe it is causing these temp files which don't disappear?
Comment 9 2007-06-21 22:48:44 UTC
Can anyone give more attention on this bug, its very annoying when entering in %HOME/tmp and find thousands of files and sometimes see 300mb of temp usefull files.
Comment 10 2007-09-18 05:38:19 UTC
Can anyone set this bug to new?
Comment 11 Martin Koller 2009-08-17 21:47:30 UTC
Ze, can you still see this problem with a current KDE 4.3 version ?

Interesting here (KDE 4.3) is that in my tmp dir (~/.kde4/tmp-eiwrk039/ which is a symbolic link to /tmp/kde-koller/) the files all start with the respective application name, e.g. konsoleZ19286.tmp or dolphintc4602.tmp 
I see no files here having a name pattern you mentioned in comment #2
Comment 12 Martin Koller 2009-09-15 22:06:20 UTC
No response. Closing.