Bug 145199 - ICQ "Hide IP address" feature not working
Summary: ICQ "Hide IP address" feature not working
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 145581 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-08 20:27 UTC by Stefan Scheler
Modified: 2007-05-17 23:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Scheler 2007-05-08 20:27:33 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Gentoo Packages
OS:                Linux

The "Hide IP address" feature from the ICQ account preferences dialog is not working. IP address is not hidden upon activating this option and reconnecting. Please fix. Thanks.
Comment 1 Roman Jarosz 2007-05-09 19:06:59 UTC
SVN commit 662951 by rjarosz:

Fix bug 145199: ICQ "Hide IP address" feature not working

BUG: 145199



 M  +3 -3      senddcinfotask.cpp  


--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/senddcinfotask.cpp #662950:662951
@@ -64,10 +64,10 @@
 		kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting web aware on" << endl;
 		statusFlag |= 0x00010000;
 	}
-	if ( !client()->settings()->hideIP() )
+	if ( client()->settings()->hideIP() )
 	{
-		kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting show ip on" << endl;
-		statusFlag |= 0x00020000;
+		kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting hide ip on" << endl;
+		statusFlag |= 0x10000000;  // Direct connection upon authorization, hides IP
 	}
 	
 	buffer->addDWord( statusFlag | mStatus );
Comment 2 Roman Jarosz 2007-05-09 19:21:55 UTC
SVN commit 662955 by rjarosz:

Forwardport fix for bug 145199: ICQ "Hide IP address" feature not working

CCBUG: 145199



 M  +3 -3      senddcinfotask.cpp  


--- trunk/KDE/kdenetwork/kopete/protocols/oscar/liboscar/tasks/senddcinfotask.cpp #662954:662955
@@ -62,10 +62,10 @@
 		kDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting web aware on" << endl;
 		statusFlag |= 0x00010000;
 	}
-	if ( !client()->settings()->hideIP() )
+	if ( client()->settings()->hideIP() )
 	{
-		kDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting show ip on" << endl;
-		statusFlag |= 0x00020000;
+		kDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "setting hide ip on" << endl;
+		statusFlag |= 0x10000000;  // Direct connection upon authorization, hides IP
 	}
 	Buffer tlv06;
 	tlv06.addDWord( statusFlag | mStatus );
Comment 3 Stefan Scheler 2007-05-09 20:46:51 UTC
Works! Thank you!
Comment 4 Bartosz Fabianowski 2007-05-17 23:27:15 UTC
*** Bug 145581 has been marked as a duplicate of this bug. ***