Bug 144383 - kate crashed spontaneously, io error?
Summary: kate crashed spontaneously, io error?
Status: RESOLVED WORKSFORME
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-18 13:01 UTC by Niklas Laxström
Modified: 2008-08-13 10:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niklas Laxström 2007-04-18 13:01:24 UTC
Version:           2.5.6 (using KDE KDE 3.5.6)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1.2 
OS:                Linux

I was reading blogs using akregator and crash handler popped up. I had not touched kate since yesterday. Machine was suspended to ram over night. In kate there was about 50 files opened using sftp kioslave from remote host. It has never done this before. Another kate session with same setup but with less files from same host is still running, and the remote host seems to have worked normally during the crash.

Backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1230390592 (LWP 1068)]
[KCrash handler]
#6  QObject::removeEventFilter (this=0x0, obj=0x9dc2d90)
    at kernel/qobject.cpp:1406
#7  0xb738d26e in ~QDockWindow (this=0x9dc2d90)
    at widgets/qdockwindow.cpp:1117
#8  0xb73f1e12 in ~QToolBar (this=0x9dc2d90) at widgets/qtoolbar.cpp:393
#9  0xb7b4b49b in ~KToolBar (this=0x9dc2d90) at ktoolbar.cpp:224
#10 0xb7bb9efd in KXMLGUIBuilder::removeContainer (this=0x8235920, 
    container=0x9dc2d90, parent=0x0, element=@0xbfea9434, id=-1)
    at kxmlguibuilder.cpp:277
#11 0xb7b4a6c0 in KXMLGUI::ContainerNode::destruct (this=0x9d67448, 
    element=@0xbfea9434, state=@0x8273810) at kxmlguifactory_p.cpp:334
#12 0xb7b4a794 in KXMLGUI::ContainerNode::destructChildren (this=0x82305a8, 
    element=@0xbfea9580, state=@0x8273810) at kxmlguifactory_p.cpp:358
#13 0xb7b4a58d in KXMLGUI::ContainerNode::destruct (this=0x82305a8, 
    element=@0xbfea9580, state=@0x8273810) at kxmlguifactory_p.cpp:311
#14 0xb7b56084 in KXMLGUIFactory::removeClient (this=0x82327f0, 
    client=0x9daebf0) at kxmlguifactory.cpp:364
#15 0xb7b5653f in KXMLGUIFactory::removeClient (this=0x82327f0, 
    client=0x9d9419c) at kxmlguifactory.cpp:339
#16 0xb65ceb67 in KateDocument::disablePluginGUI (this=0x9d86178, 
    plugin=0x9604b38, view=0x9d94128) at katedocument.cpp:334
#17 0xb65df102 in KateDocument::disableAllPluginsGUI (this=0x9d86178, 
    view=0x9d94128) at katedocument.cpp:281
#18 0xb663a5bc in ~KateView (this=0x9d94128) at kateview.cpp:171
#19 0xb669b55e in QPtrList<KateView>::deleteItem (this=0x9d8630c, 
    d=0xb766b468) at /usr/qt/3/include/qptrlist.h:150
#20 0xb75108a0 in QGList::clear (this=0x9d8630c) at tools/qglist.cpp:701
#21 0xb663fcff in ~KateDocument (this=0x9d86178)
    at /usr/qt/3/include/qptrlist.h:93
#22 0xb65ec583 in ~KateFactory (this=0x811aaf0) at katefactory.cpp:172
#23 0xb65ec892 in __tcf_46 () at ../../kdecore/kstaticdeleter.h:126
#24 0xb6ac926b in *__GI_exit (status=1) at exit.c:75
#25 0xb727d59e in qt_xio_errhandler () at kernel/qapplication_x11.cpp:777
#26 0xb77f50fd in KApplication::xioErrhandler (this=0xbfeaa390, dpy=0x8080d60)
    at kapplication.cpp:728
#27 0xb77f5149 in kde_xio_errhandler (dpy=0x8080d60) at kapplication.cpp:179
#28 0xb6d34ed4 in _XIOError (dpy=0xb766b468) at XlibInt.c:2930
#29 0xb6d35b9f in _XRead (dpy=0x8080d60, data=0xbfea98cc "??\b??\203\001", 
    size=32) at XlibInt.c:1116
#30 0xb6d36fed in _XEventsQueued (dpy=0x8080d60, mode=2) at XlibInt.c:865
#31 0xb6d28c6f in XPending (dpy=0x8080d60) at Pending.c:57
#32 0xb7295bce in QEventLoop::processEvents (this=0x80ef6e8, flags=4)
    at kernel/qeventloop_x11.cpp:147
#33 0xb72e1786 in QEventLoop::enterLoop (this=0x80ef6e8)
    at kernel/qeventloop.cpp:198
#34 0xb72e164a in QEventLoop::exec (this=0x80ef6e8)
    at kernel/qeventloop.cpp:145
#35 0xb72d023e in QApplication::exec (this=0xbfeaa390)
    at kernel/qapplication.cpp:2758
#36 0xb771664b in kdemain (argc=1, argv=0x8084458) at katemain.cpp:253
#37 0xb7719819 in kdeinitmain (argc=1, argv=0x8084458) at kate_dummy.cpp:3
#38 0x0804e2a7 in launch (argc=1, _name=0x8078cd4 "kate", 
    args=0x8078cd9 "\001", cwd=0x0, envc=1, envs=0x8078ce9 "", 
    reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8078cee "jadekukka;1176307547;371553;32123_TIME592828048") at kinit.cpp:673
#39 0x0804eb49 in handle_launcher_request (sock=9) at kinit.cpp:1240
#40 0x0804eecc in handle_requests (waitForPid=0) at kinit.cpp:1443
#41 0x08050111 in main (argc=5, argv=0xbfeaae14, envp=0xbfeaae2c)
    at kinit.cpp:1909
#42 0xb6ab3838 in __libc_start_main (main=0x804f7c0 <main>, argc=5, 
    ubp_av=0xbfeaae14, init=0x8050910 <__libc_csu_init>, 
    fini=0x8050900 <__libc_csu_fini>, rtld_fini=0xb7f8afe0 <_dl_fini>, 
    stack_end=0xbfeaae0c) at libc-start.c:238
#43 0x0804b791 in _start ()
Comment 1 Lubos Lunak 2008-07-21 16:22:42 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Christoph Cullmann 2008-08-13 10:21:11 UTC
Should work for KDE 4.