Bug 144227 - allow for fully customized album names when importing
Summary: allow for fully customized album names when importing
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 2.1.0
Platform: Compiled Sources Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 166060 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-14 20:18 UTC by Mikolaj Machowski
Modified: 2017-08-16 09:34 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2007-04-14 20:18:21 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When changing filenames in CameraGUI user can select:
- default
- ISO
- Full text
- Local settings
- Advanced

When auto-creating albums there are only:
- ISO
- Full text
- Local settings

I think also possibility to create customized (Advanced option) names of auto-created albums would be good idea. At least for consistency.
Comment 1 Gunnar Lundström 2008-04-28 21:32:30 UTC
Especially (for me) the ability to have albums created by the time/date the photo was taken.
Comment 2 caulier.gilles 2009-05-13 09:54:35 UTC
Andi,

Something similar can be done here as new file renaming tool, that you have implemented ?

Gilles
Comment 3 Andi Clemens 2009-05-13 09:59:18 UTC
We should be able to just use the ManualRenameWidget here, too. Well in theory :D
Need to check that.

Andi
Comment 4 Todor Gyumyushev 2011-04-30 12:39:26 UTC
Recently I've switched to digiKam, but it miss very small thing when downloading photos, related to album folders. Now I can choose Date-ISO but it does create just one top folder in the albums structure. It will be very nice if you can allow more options here and create subfolders like: <AlbumsRoot>/2011/08/05/<downloaded_files>
Other apps I've used before do so and is nice if you can keep compatible with such option.
Thanks,
Todor
Comment 5 caulier.gilles 2011-08-09 13:53:56 UTC
Andi, 

Do you checked ManualRenameWidget usability for this entry ?

Gilles Caulier
Comment 6 caulier.gilles 2011-08-11 07:53:16 UTC
*** Bug 166060 has been marked as a duplicate of this bug. ***
Comment 7 caulier.gilles 2011-08-11 14:02:57 UTC
Git commit 0dc4a3ff1463eb514550c08f65fc90211c38db80 by Gilles Caulier.
Committed on 11/08/2011 at 16:00.
Pushed by cgilles into branch 'master'.

CameraGUI: Implement a way to customize target album creation by date. It use QDate::toString() syntax.
BUGS: 144227

M  +10   -1    utilities/cameragui/main/cameraui.cpp
M  +133  -21   utilities/cameragui/widgets/albumcustomizer.cpp
M  +13   -4    utilities/cameragui/widgets/albumcustomizer.h

http://commits.kde.org/digikam/0dc4a3ff1463eb514550c08f65fc90211c38db80
Comment 8 caulier.gilles 2011-08-11 14:14:21 UTC
sreenshot :

http://www.flickr.com/photos/digikam/6031906909/sizes/o/in/photostream/

Gilles Caulier
Comment 9 Tom Vincent 2011-08-31 14:29:58 UTC
*** Bug 281116 has been marked as a duplicate of this bug. ***