Bug 143474 - Crash: kontact complains about not being able to conntect to imap server and crashes then
Summary: Crash: kontact complains about not being able to conntect to imap server and ...
Status: RESOLVED DUPLICATE of bug 117991
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-26 07:47 UTC by gmud
Modified: 2007-04-12 00:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gmud 2007-03-26 07:47:53 UTC
Version:           Unbekannt (using KDE 3.5.6, Gentoo)
Compiler:          gcc version 3.4.6 (Gentoo 3.4.6-r1, ssp-3.4.5-1.0, pie-8.7.9)
OS:                Linux (i686) release 2.6.18-suspend2

In about 30 per cent of starting up kontact it complains about not being able to connect to the imap server. In 50 per cent of these cases it immeadiatly crashes after confirming the message about the connection failure. 

Here is the backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[...]
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242343232 (LWP 1928)]
[New Thread -1284568160 (LWP 2004)]
[New Thread -1276175456 (LWP 2003)]
[New Thread -1267782752 (LWP 2002)]
[New Thread -1259390048 (LWP 2001)]
[KCrash handler]
#9  0xb7e46dc0 in QMapPrivate<KPIM::ProgressItem*, bool>::QMapPrivate ()
   from /usr/kde/3.5/lib/libkdepim.so.1
#10 0xb7e46e6d in QMap<KPIM::ProgressItem*, bool>::detachInternal ()
   from /usr/kde/3.5/lib/libkdepim.so.1
#11 0xb7e46ee9 in QMap<KPIM::ProgressItem*, bool>::remove ()
   from /usr/kde/3.5/lib/libkdepim.so.1
#12 0xb7e45f4c in KPIM::ProgressItem::removeChild ()
   from /usr/kde/3.5/lib/libkdepim.so.1
#13 0xb7e45fd9 in KPIM::ProgressItem::setComplete ()
   from /usr/kde/3.5/lib/libkdepim.so.1
#14 0xb52b899d in KMail::ImapAccountBase::removeJob ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#15 0xb51fafbe in KMail::ListJob::slotListResult ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#16 0xb51fb077 in KMail::ListJob::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#17 0xb66b9464 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#18 0xb729de1d in KIO::Job::result () from /usr/kde/3.5/lib/libkio.so.4
#19 0xb72cb92c in KIO::Job::emitResult () from /usr/kde/3.5/lib/libkio.so.4
#20 0xb72f75fc in KIO::SimpleJob::slotFinished ()
   from /usr/kde/3.5/lib/libkio.so.4
#21 0xb72f79a6 in KIO::ListJob::slotFinished ()
   from /usr/kde/3.5/lib/libkio.so.4
#22 0xb72f9fcb in KIO::ListJob::qt_invoke () from /usr/kde/3.5/lib/libkio.so.4
#23 0xb66b9464 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb66b9bfc in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb729bdac in KIO::SlaveInterface::finished ()
   from /usr/kde/3.5/lib/libkio.so.4
#26 0xb72ecde6 in KIO::SlaveInterface::dispatch ()
   from /usr/kde/3.5/lib/libkio.so.4
#27 0xb72c9223 in KIO::SlaveInterface::dispatch ()
   from /usr/kde/3.5/lib/libkio.so.4
#28 0xb72bf62b in KIO::Slave::gotInput () from /usr/kde/3.5/lib/libkio.so.4
#29 0xb72c7568 in KIO::Slave::qt_invoke () from /usr/kde/3.5/lib/libkio.so.4
#30 0xb66b9464 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb66b9a8b in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb6a1c7c0 in QSocketNotifier::activated ()
   from /usr/qt/3/lib/libqt-mt.so.3
#33 0xb66d6360 in QSocketNotifier::event () from /usr/qt/3/lib/libqt-mt.so.3
#34 0xb6653b4f in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#35 0xb6653cfc in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#36 0xb6d6b1b5 in KApplication::notify ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#37 0xb6646f73 in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#38 0xb65fee82 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#39 0xb666a511 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#40 0xb666a456 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#41 0xb6652caf in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#42 0x08058edd in ?? ()
#43 0xbff085a0 in ?? ()
#44 0x00000001 in ?? ()
#45 0x00000001 in ?? ()
#46 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2007-03-26 11:35:08 UTC
Backtrace matches closed bug: #133023
Comment 2 Thomas McGuire 2007-04-12 00:02:50 UTC

*** This bug has been marked as a duplicate of 117991 ***